locked
Windows 10 1709 - How to make touch keyboard larger RRS feed

  • Question

  • We have found that since installing the fall creators update (1709) on our computer's on-screen touch keyboard is too small.

    Previously we were using the following reg keys to make the keyboard larger....

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Scaling]
    "MonitorSize"="13"

    [HKEY_CURRENT_USER\SOFTWARE\Microsoft\TabletTip\1.7]

    "EnableCompatibilityKeyboard"=dword:00000001
    "KeyboardLayoutPreference"=dword:00000003

    At this point, the reg keys above do not appear to be working.

    Does anyone have any fix's that would allow me to make the keyboard larger in this latest build?

    Thanks


    • Edited by vs2017sv Wednesday, October 18, 2017 7:03 PM
    Wednesday, October 18, 2017 6:58 PM

All replies

  • Hi,

    Please refer to this article and see if it helps.

    How to Change Touch Keyboard Size in Windows 10

    https://www.isunshare.com/windows-10/change-touch-keyboard-size-in-windows-10.html

    If the problem still persists, I would like to suggest you submit this feedback via the built-in Feedback App.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 19, 2017 2:06 AM
  • This acticle is about older verisons of Windows. The problem has not been solved.
    Tuesday, October 24, 2017 6:52 PM
  • try this workaround to bring back the older touch keyboard:

    https://superuser.com/questions/1260149/how-to-enable-full-layout-touch-keyboard-on-windows-10-1709

    Wednesday, October 25, 2017 9:06 AM
  • We have same problem found(the on screen keyboard too small after installed to Fall creators update)

    When I back to Prv. Version, the on screen keyboard is resume to normal.

    Thanks.

    Thursday, October 26, 2017 1:14 AM
  • Does anyone have any fix's that would allow me to make the keyboard larger in this latest build?


    Apparently the Standard layout stretches the width of the monitor.  Will that be big enough?   <eg>


    Robert Aldwinckle
    ---

    Thursday, October 26, 2017 2:21 AM
  • I've installed the Fall Creators Update (1709) for Windows 10.

    My LOCK SCREEN (LOGIN SCREEN) keyboard is the older and slightly larger version of the touch keyboard that's now displayed while logged in to Windows.

    I have deleted my .OLD Windows directory following the update. Unfortunately, I would like to have the same sized keyboard in Windows as the one from my LOCK screen.

    Is there a way in the REGISTRY to set the keyboard IN windows to the same keyboard from the LOCK screen which is only slightly larger? The larger size make typing easier.

    Any help is greatly appreciated.

    Sincerely.

    Friday, October 27, 2017 1:48 AM
  • Thanks but that's not what I am referring to. I am using a tablet running in Desktop mode. I can switch between the full, or enhanced, keyboard. The problem is that the new touch keyboard which shows the keyboard properties and voice control icons in the upper left-hand corner, that keyboard is slightly smaller due to an apparent font change. The difference can be seen when compared to the keyboard size of the touch keyboard that appears at the password screen on startup. The in-Windows version (post login) of the same keyboard is slightly smaller. This makes typing a nightmare as my muscle memory is trained to that slightly larger size. I want to increase the top, bottom size or key size to that of the lock screen keyboard. Any help is appreciated. Thanks.

    Friday, October 27, 2017 3:38 AM
  • And worth noting, I tried the older Scaling fix in the registry and even lowering my resolution but neither of those "fixes" changed anything.

    I have to believe there is a registry hack to force use of the login keyboard size and config globally within the OS. I have also found others in other forums with the same issue. If I find a fix first I'll post it here.

    Take care all.

    Friday, October 27, 2017 3:42 AM
  • What about this one? Where should I report this to? Feel free to do so:

    Found another "bug" with the new Touch Keyboard update in Windows 10 (1709) Creators Fall Update.

    When on an open folder with Medium Icons set for your View...you USED to be able to hold the Shift Key and use the Left or Right Arrow Keys to highlight mutiple files for a Cut or Copy, I can't do that any more.

    Anybody know if there's a fix or even if it's been reported?

    Cheers.

    Friday, October 27, 2017 5:55 AM
  • I think, a lot of things are reported, but this doesn't mean anything to Microsoft.

    I have my touch keyboard way TOO large after Fall Creators update, I cannot type normally without type errors 'cause it's too hard to target a right key on this LAAARGE keyboard.

    The scaling registry key work around previously used to fix the issue doesn't work anymore.

    The second thing with the shift key is also an issue, when you have to release and press the Shift key again to type the same symbol or a key.

    The real thing is, this was reported my MS itself long long ago in the old Insider Preview builds. THis is surprising that this bug was NOT corrected by the release build!!!

    So annoying that the common practice is to just roll out unfinished and raw features, they don't care this is all pain for the users!!!!!

    As I'm a participant of the Insider Program, I myself have sent several bug reports regarding these issues earlier when there were only preview builds present, but nothing have been changed since that time.

    Microsoft, do something???? 







    • Edited by Brown Bob Tuesday, October 31, 2017 7:08 PM
    Tuesday, October 31, 2017 6:58 PM
  • In this thread there seems to be interchangeable use of three phrases: on-screen touch keyboard; on-screen keyboard; and touch keyboard. With my FCU 1709 build there are two distinct keyboards which suggests the phrases are not interchangeable.

    When I use the Taskbar Touch keyboard button I get a large font, fixed keyboard right across the bottom of the screen.

    When I use the Start Menu (Ease of Access) On-Screen Keyboard shortcut I get a different keyboard with a smaller font and which can be resized and dragged anywhere on the screen.

    Does this explain the situation reported here or are other users seeing a different problem?

    Tuesday, October 31, 2017 10:05 PM
  • I have my touch keyboard way TOO large after Fall Creators update

    That sounds like the "Standard" keyboard layout has been chosen.  What do you see if you pick a different one?


    Robert Aldwinckle
    ---

    Wednesday, November 1, 2017 1:29 AM
  • It seems this issue has not been resolved until now. Does nobody know how to make use of the lock-screen keyboard? It looks like the old (good one) on-screen keyboard without scaling problems.
    Wednesday, November 8, 2017 11:06 AM
  • 100%

    This too is what I wish to do...if you find a way to do this please post the instructions.

    Cheers.

    Friday, November 10, 2017 6:01 PM
  • I think this one is about the same issue:

    https://answers.microsoft.com/en-us/windows/forum/windows_10-start-win_touchkey/touch-keyboard-size/60bc9c66-fe2e-4d60-9695-141a75bdd60e

    Sunday, November 12, 2017 9:10 AM
  • I think this one is about the same issue:

    [starts with picture]

    That example proves my point.  It uses the "chiclet keyboard".  Enable and switch to the Standard keyboard layout and see how big it is.

    https://www.laptopmag.com/articles/full-layout-touch-keyboard-windows-10 

    (BING search for
        keyboard windows touch layout windows.10
    )



    Robert Aldwinckle
    ---


    Sunday, November 12, 2017 3:13 PM
  • In order to bring the older touch keyboard back, i've replaced the touch keyboard files with the older files from windows 1703. I've copied the following directories:

    C:\Windows.old\Program Files\Common Files\microsoft shared\ink
    to -> C:\Program Files\Common Files\microsoft shared\ink
    and
    C:\Windows.old\‏‏Program Files (x86)‎\Common Files\Microsoft Shared\Ink
    to -> C:\‏‏Program Files (x86)‎\Common Files\Microsoft Shared\Ink

    If the .old directories are cleaned out (windows automatically delete the files a week after the feature upgrade), the older files can be obtained from another pc which still have windows 1703 or older installed on it,
    or can be extracted from a windows 1703 installation ESD file (i've posted instructions how to get the files from the ESD, see it here: 
    https://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install/the-windows-10-touch-keyboard-is-not-using-the/1ef577d7-1b99-470e-8fb4-d930e22fbc61?page=3).

    this solution is only temporary since the touch keyboard files are replaced back with the new files with the monthly cumulative updates,
    perhaps setting permissions to the folders to be read only will keep the files from being replaced every month...

    hopefully microsoft would improve this touch keyboard soon, it really drives me crazy :(
    Wednesday, November 15, 2017 7:44 AM
  • Dear authorities,

    In turkey in state schools when (it updates itself or) we update windows 10 to version 1709  screen keyboard becomes too small for a 50 inch smart board. And even its size cant be configured.  It's very difficult to use screen keyboard on touch screen smartboard. We need your help to correct this issue.

    Yours sincerelly.

    Sunday, December 10, 2017 8:23 AM
  • Hi Alico09,

    Can't you resize the screen keyboard as we can do almost all software/applications?
    If you cannot, you need to send a feedback via Feedback Hub.

    (Input "feedback hub" in Cortana search window, and select [Feedback Hub])
        

    Regards,

    Ashidacchi

    Sunday, December 10, 2017 9:37 AM
  • come on people i found  the solution 

    https://youtu.be/fbGko7AO_h0

    Wednesday, December 20, 2017 1:47 PM
  • @Abdul-Halwani,

    That is a work around. Not a fix. A fix entails the built in touch keyboard is sized normally and not have to use the "Ease-of-Access" keyboard.

    Monday, January 8, 2018 12:18 PM
  • In order to bring the older touch keyboard back, i've replaced the touch keyboard files with the older files from windows 1703. I've copied the following directories:

    C:\Windows.old\Program Files\Common Files\microsoft shared\ink
    to -> C:\Program Files\Common Files\microsoft shared\ink
    and
    C:\Windows.old\‏‏Program Files (x86)‎\Common Files\Microsoft Shared\Ink
    to -> C:\‏‏Program Files (x86)‎\Common Files\Microsoft Shared\Ink

    If the .old directories are cleaned out (windows automatically delete the files a week after the feature upgrade), the older files can be obtained from another pc which still have windows 1703 or older installed on it,
    or can be extracted from a windows 1703 installation ESD file (i've posted instructions how to get the files from the ESD, see it here: 
    https://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install/the-windows-10-touch-keyboard-is-not-using-the/1ef577d7-1b99-470e-8fb4-d930e22fbc61?page=3).

    this solution is only temporary since the touch keyboard files are replaced back with the new files with the monthly cumulative updates,
    perhaps setting permissions to the folders to be read only will keep the files from being replaced every month...

    hopefully microsoft would improve this touch keyboard soon, it really drives me crazy :(
    So far this has been the best option. Otherwise creating a batch file helps a lot with the same process above to just have to run the batch when an update comes out. Hopefully the 1803 update today will fix the issue. I am updating a few systems <g class="gr_ gr_315 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="315" id="315">with</g> the issue now. It seems to only affect 55" or larger displays from my testing.
    Tuesday, May 1, 2018 12:08 PM
  • Indeed after upgrade to 1709 touch KB has changed a lot. Now it has been look and behavior. I have found a solution how to revert it to the previous mode (compatibility to older builds):

    just add one more registry key:

    reg add HKLM\SOFTWARE\Microsoft\TabletTip\1.7 /v DisableNewKeyboardExperience /t REG_Dword /d 1 /f

    And all your previous reg keys will start working again!

    Wednesday, August 8, 2018 10:43 AM
  • Indeed after upgrade to 1709 touch KB has changed a lot. Now it has been look and behavior. I have found a solution how to revert it to the previous mode (compatibility to older builds):

    just add one more registry key:

    reg add HKLM\SOFTWARE\Microsoft\TabletTip\1.7 /v DisableNewKeyboardExperience /t REG_Dword /d 1 /f

    And all your previous reg keys will start working again!


    This worked for me after a reboot. Thanks!
    Thursday, August 9, 2018 9:44 PM
  • What reg keys should i apply before i try that one?

    I tried only that one and nothing changed, even after i reboot two times.

    Monday, August 27, 2018 2:52 AM
  • Hi, i am not from Microsoft corp. But i saved Microsoft by making a tool to fix this problem.

    This tool works on 64-bit windows 10

    Download Here


    M.AYGÜN

    Wednesday, November 28, 2018 4:01 PM
  • Indeed after upgrade to 1709 touch KB has changed a lot. Now it has been look and behavior. I have found a solution how to revert it to the previous mode (compatibility to older builds):

    just add one more registry key:

    reg add HKLM\SOFTWARE\Microsoft\TabletTip\1.7 /v DisableNewKeyboardExperience /t REG_Dword /d 1 /f

    And all your previous reg keys will start working again!


    Didn´t work for me with windows 1809.
    Monday, December 17, 2018 6:28 PM
  • Hi, i am not from Microsoft corp. But i saved Microsoft by making a tool to fix this problem.

    This tool works on 64-bit windows 10

    Download


    M.AYGÜN

    This fix works for 1809?

    How to recreate for 32bit?

    Monday, December 17, 2018 6:31 PM
  • Thanks for sharing.

    I have tried to install the fix.

    It is ok for the touch keyboard layout become lager, however, it makes the handwriting is not working very well.

    As a result, can you tell me how to remove this fix to return to the previous keyboard layout?

    Thanks for the help and for my poor English.

    Tuesday, December 18, 2018 4:16 AM