locked
Enabling Virtual machine platform slows down windows VM RRS feed

  • Question

  • I am trying to host Windows 10 enterprise 2004 on Kubernetes using kubevirt. I can host the instance and everything is working and fast when accessed remotely but when I enable Virtual machine platform the vm slows down significantly. Just enabling wsl does not seem to affect the instance, it is only when I try to enable wsl 2 for docker use by enabling Virtual machine platform. 

    I have restarted the instance after turning on the feature.
    In the process tab I can see vmmem is using like 1.5G memory but I have given the instance 16G so I thought that should not be the issue.

    Some of the things I have tried to solve this:
    Optimized the vm using vmware optimizer tool.
    Only using RAM by disabling virtual memory.

    Please let me know where I can look to debug this. Or maybe some pointers as to what I might be doing wrong.

    Thank you!
    Thursday, July 16, 2020 2:00 PM

All replies

  •   If you enable wsl2 you will enable the Hyper-V hypervisor. Your Windows 10 vm will then be running on top of that hypervisor, so it will now be running as a nested vm, Hyper-V nested in kubevirt. 


    Bill

    Friday, July 17, 2020 12:27 AM
  • Hi anuraagrijal,

    Thanks for your post! I would like to explain, Windows 10 virutalization is mostly related about Hyper V installed on Windows 10, it seems you use Kubernets as as base, if you have any performance issue, it's recommended to turn to Kubernets forum for better help.

    Thanks for your understanding!

    Best Regards,

    Anne

    This "Windows 10 Virtualization" Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.


    "Windows 10 Virtualization" forum will be migrating to a new home on Microsoft Q&A!

    We invite you to post new questions in the "Windows 10 Virtualization"  forum's new home on Microsoft Q&A!

    For more information, please refer to the sticky post.


    Friday, July 17, 2020 7:38 AM