none
GPO, printers, and rights... RRS feed

  • Question

  • Hello ! (and sorry for my english)

    I'm working in a 2008 R2 environment whith Seven clients and I'm trying to use GPOs (GPP exactly) mapping printers. 32 and 64bits drivers are on the server.

    User's preference for printers work good for 90% models but 3 of them post on the client's computer : "0x80070bcb The specified printer driver was not found on the system and needs to be downloaded".

    I tried any kind of GPO's configuration :

    "Point and Print Restrictions : Disabled" for User and Computer

    "Allow non-administrators to install drivers for these device setup classes : Enabled" whith printer's GUID

    "When Windows detects a driver file without a digital signature: Ignore"

    Users aren't administrators of their computers and all drivers are signed.

    They can to install themselves shared printers except the 3 printers : they have to enter an administrator password.

    However, if drivers are installed on the computers, GPP operates !

    Please any idea ?

    Thank you very much !

    R.B


    • Edited by roromano49 Monday, March 10, 2014 1:11 PM
    Monday, March 10, 2014 1:05 PM

All replies

  • Hi,

    This issue might be related with Windows 7 printer driver security settings, in order to make it work, we need to enable Point and Print Restrictions. See the reply from daniel.r in this thread:

    Issues with adding TCPIP printer using group policy preferences

    QUOTE:

    "

    I did some further research on the issue yesterday and found that the admx files included with W7/2k8R2 include a Point and Print Restrictions setting under Computer Configuration | Policies | Administrative Templates | Printers which you can use to set the printer security on the computer(previously only availible in user configuration, which was useless in this senario). once i upgraded the domain policy central store with the W7/2k8R2 policies and turned this setting on, it started working like it should! (for windows 7 anyway, i've given up with vista)

    the issue is that since vista & UAC, when you try and install a printer who's driver isnt in the local driverstore, it prompts you if you want to install it etc, but being a computer gp preference being applied before login, you cant see these messages etc and hence the preference will fail. 

    "

    For more information regarding Printer Driver Installation Security settings, please take a look here:

    Control Printer Driver Installation Security

    Hope this may help

    Best regards


    Michael Shao
    TechNet Community Support


    Tuesday, March 11, 2014 3:22 AM
    Moderator
  • Thank you for your response.

    I already tried to Disabled or Enabled (with "Don't ask elevation or show prompt") in Point and Print Restrictions. Also, it works whith all others printers but not only with 3 printers...


    same problem on :

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/c94ea362-bc3c-4bc7-9a27-354dc521dd91/issues-with-adding-tcpip-printer-using-group-policy-preferences?forum=winserverGP

    • Edited by roromano49 Tuesday, March 11, 2014 8:05 AM
    Tuesday, March 11, 2014 7:30 AM