none
Second Hard Drive Disappears when Windows 7 goes to sleep RRS feed

  • Question

  • Hello everyone!

    These forums look like a pretty good place to ask about something like this, so any help would be greatly appreciated.

    So, I did a clean install of Windows 7 Pro...was running Windows Vista Ultimate previously, and everything seems great, except for this one thing.  I have 7 booting from my primary hd (obviously), a WD Raptor 150gig, and all of my data, including all of the user account folders, directed to a second hd, a WD Caviar black 1TB drive, which is how everything was running in Vista.  

    I find now that when we put the computer to sleep (either because we set it to do so as we walk out the door, or it goes to sleep on its own if we forget about it), when it wakes up, the second HD is gone.  You can imagine the panic that caused.  Once the computer has been restarted, however, everything is back to normal, and all files appear in their respective libraries, the disk is back in My Computer, with the same drive letter as before.  

    I shouldn't have to reboot the computer every time I want my files.  I guess I could either start fully shutting the computer down, or maybe see what the results are if I try hibernating (not even sure if there's a difference there), but that would be avoiding instead of fixing the problem.

    Other notes: besides the OS, no changes to the system, which I built.  Drives are both about one year old.  No problems EVER.

    Let me know what you think, and if you need any details from me.

    Thanks!!!!!!!!
    Tuesday, January 26, 2010 9:56 PM

Answers

  • Hello,

    Try to update the SATA drivers and BIOS and see if the issue persists, you can download these latest drivers from Motherboard Manufacturer's website .

    If the problem still happens, try to the following step:

    Disable "write caching on the device"
    =======================
    1. Open device manager, right click the hard disk and choose properties.
    2. In Policies tab, uncheck the option "enable write caching on the device"
    3. Repeat the steps to the other hard disk.

     

     


    Thomas77
    • Marked as answer by Vivian Xing Tuesday, February 2, 2010 9:29 AM
    Wednesday, January 27, 2010 8:44 AM

All replies

  • Hello,

    Try to update the SATA drivers and BIOS and see if the issue persists, you can download these latest drivers from Motherboard Manufacturer's website .

    If the problem still happens, try to the following step:

    Disable "write caching on the device"
    =======================
    1. Open device manager, right click the hard disk and choose properties.
    2. In Policies tab, uncheck the option "enable write caching on the device"
    3. Repeat the steps to the other hard disk.

     

     


    Thomas77
    • Marked as answer by Vivian Xing Tuesday, February 2, 2010 9:29 AM
    Wednesday, January 27, 2010 8:44 AM
  • Thanks Thomas77, I'll give it a shot tonight!
    Wednesday, January 27, 2010 3:15 PM
  • I'm facing the same problem with the same OS and second drive (3rd partition).
    Did you found an answer ?
    Sunday, February 14, 2010 8:09 PM
  • This is apparently a common problem.  I have a new Dell Studio XPS 8000, Windows 7 64bit.  I added a second hard drive, WD Black Caviar 1 TB.  Plugged into SATA #4.  Everything checks out fine and drive works fine - except:  If computer hibernates, this drive dissappears - must restart the computer to recover access.  That drive also seems to dissappear if it is not accessed after a lengthy period (maybe an hour).  All BIOS and SATA updates have been applied.  So, either it is an issue with Windows 7 or with WD (although I think I have seen other similar reports with other brands of hard drive).

    Was there ever a final solution?
    Friday, March 5, 2010 7:28 PM
  • I found a solution to this very anoying problem.
    Just install the fix KB977178 proposed by Microsoft :
    http://support.microsoft.com/default.aspx/kb/977178
    I'm running this for 3 weeks now and never had the problem since.

    Hope this will help you too ...

    Regards.


    Saturday, March 6, 2010 9:28 AM
  • Check your advanced power settings .  Goto Control panel, click power options, click change plan settings, then change advanced power settings.  Click all the plus signs next to Hard Disk. Make sure you set to NEVER fall asleep
    Friday, January 28, 2011 9:14 PM