none
issue in server nslookup through CMD RRS feed

  • Question

  • Hi,

    I have an issue when I change the nslookup server in CMD, I dont get a proper DNS resolution. 

    assume if my local DC domain is something like example.com,

    when I open CMD from any machine in the domain, and insert nslookup then enter, the default server is my local DNS, names are resolved fine.

    but if I change the server to 8.8.8.8, or 1.1.1.1, or any public DNS server, an issue occurs when I want to resolve any name like google.com, yahoo.com ,,,etc. 

    the machine bind my local domain to the requested domain, so in the DNS query it will look like google.com.example.com

    this issue only happens when I use nslookup with public DNS servers.

    However, in the NIC card, if I put public DNS and surf the internet, resolution is working fine without local domain binding, I have verified that with WireShark,

    !

    > server 8.8.8.8

    Default Server:  dns.google

    Address:  8.8.8.8

    !

    > google.com

    Server:  dns.google

    Address:  8.8.8.8

    Non-authoritative answer:

    Name:    google.com.example.com

    Address:  93.184.216.34

    !

    > facebook.com

    Server:  dns.google

    Address:  8.8.8.8

    Non-authoritative answer:

    Name:    facebook.com.example.com

    Address:  93.184.216.34

    !

    !

    !

    what could be the issue, and how to solve it?

    thank you,

     


    • Edited by OudMaster Sunday, July 21, 2019 9:41 AM
    Sunday, July 21, 2019 9:40 AM

Answers

  • Hi,

    Appending domain DNS suffix is a default mechanism.

    When you run command nslookup google.com, I recommend you add a "." after goolgle.com,for example: nslookup google.com. ,and make it an FQDN.

    Best regards,

    Hollis


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by OudMaster Wednesday, July 24, 2019 1:01 PM
    Wednesday, July 24, 2019 9:07 AM

All replies

  • Hi,

    It's possible that your firewall stops the Nslookup request to the public DNS server.

    Try to add TELNET client : Go to the Control panel > Programs > Turn Windows features on or off > Check Telnet client.

    Open the command line as administrator, type the following command:

    • telnet 8.8.8.8 53                       // 53 is the port used by DNS.

    Do you get a message error?

    You can also add a conditional forwarder in your DNS server settings to forward all out of LAN traffic to the public DNS servers.

    Regards,

    SAAD Youssef

    _______

    Please remember to mark the replies as answer if they help, thank you.

    Sunday, July 21, 2019 11:06 AM
  • Hi,

    Thank you for posting your issue in this forum.

    I recommend you check your TCP/IP settings whether you append DNS suffix, please refer to the following link: https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-2000-server/cc959339(v=technet.10)

    Best regards,

    Hollis Huang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 22, 2019 6:34 AM
  • Thank you for your response,

    telneting to port 53 is open, I am surprised as this is a UDP port, how telnet see the port open!!

    also I tried to manipulate with DNS suffix following the URL provided, it did not help me,

    there is no firewall restriction at all. 

    Monday, July 22, 2019 1:13 PM
  • To show all connections and listening ports, open the command prompt and type:

                  netstat -an

    When you switch to a public DNS server with NSLOOKUP tool and try a public request, did you receive any error message?

    Monday, July 22, 2019 1:29 PM
  • no I dont receive error in the response,

    !

    but the issue as I stated it in my post, if I use any computer in my domain (even DC), open CMD and use nslookup, when I switch to a public DNS like 8.8.8.8, the machine bind my local domain name in the DNS request, so assume if my local domain is example.com, and I query google.com, then my machine will send google.com.example.com as DNS query.
    and because example.com is publicly registered domain, then google DNS will reply with the IP of that domain which is 93.184.216.34

    So currently with nslookup when I use public DNS, if I query any public domain, I get the same public IP, (because it is the same name of my local domain). I cannot change my local domain for this issue,
    !
    if I query the local DNS server instead of the public, the situation a little different, I get correct result, but in the wirshark I have noticed my machine send  google.com.example.com DNS query to my local DNS, then local DNS send no such name, after that the machine resend the DNS query but only keep google.com, local dns then send correct resolution.

    !

    However, this issue happens only with nslookup on CMD,

    when I use internet browser, resolving happens fine, means the machine does not bind the local domain in the DNS request (whether I use local DNS or public DNS), I have checked that with Wireshark, 

    !


    Wednesday, July 24, 2019 8:06 AM
  • Hi,

    Appending domain DNS suffix is a default mechanism.

    When you run command nslookup google.com, I recommend you add a "." after goolgle.com,for example: nslookup google.com. ,and make it an FQDN.

    Best regards,

    Hollis


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by OudMaster Wednesday, July 24, 2019 1:01 PM
    Wednesday, July 24, 2019 9:07 AM
  • Thank you very much Hollis, it worked for me when I used google.com.

    I also change the appended DNS suffix and made it just dot, it also worked well in nslookup without typing the dot in google.com.

    !

    !

    I am surprised of why this issue just appeared recently, I did not noticed it before, neither in my domain nor others.

    Thanks again..

    Wednesday, July 24, 2019 1:00 PM
  • Hi, 

    I am glad to hear that the information is helpful to you. If there is any another question, please feel free to post in the forum.

    Best regards,

    Hollis


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 25, 2019 1:13 AM