none
Unable to stop a software from autostarting

    Question

  • I have tried to disable the software Forticlient (from Fortinet). I only want to activate it when I need it. It is sort of an endpoint security software and I guess that is why i have had so hart disabling it.

    It is not in the startup folder but is started by a service "FA_scheduler". The service throws error message "Incorrect parameter" when i try to stop the service (net stop FA_scheduler). A different thread suggested that it first required a different service to be stopped ("Fortishield"). However if i run "net stop fortishield" from an elevated command prompt it tells me it was unable to stop the service. The service fortshield is not visible in the ordinary services.msc. From the registry (HKLM/currentcontrolset/services) I found out that there were a bunch of "forti*" services running but not visible in the services.msc. Neither of those can be stopped.

    Next I wanted to try to stop when loaded into windows 7 Safe mode. However it seems to be impossible to boot into safe mode if you are using Bitlocker with TPM and PIN. Correct?

    What can I do to prevent if from autostarting?

    Tuesday, May 21, 2013 4:41 PM

Answers

  • Hey, don't know if you're still looking but I ran into the exact same issue as you with the same behavior (Bad parameter), here's how I fixed it:

    1 Shutdown FortiClient (right click on the taskbar icon, if the shutdown option is greyed out it should be because you're registered to a FortiGate, un-register from it and then shutdown the client)
    2 In an elevated command prompt, run 'net stop fortishield'
    3 Run msconfig then in the Services tab, clear the FortiClient Service Scheduler check box and click Apply.
    4 Run services.msc and switch the FortiClient Service Scheduler startup to Manual (it should be on Disabled at this point)
    5 Restart your computer. FortiClient should not load up.

    Hope this helps!

    James

    EDIT: just realised you're asking for Win8.1, I'm on 7... so maybe those steps won't do it for you. Worth a try though!

    • Edited by JamesP77 Thursday, January 23, 2014 8:51 PM
    • Marked as answer by Jonas Haglund Friday, January 24, 2014 6:07 AM
    Thursday, January 23, 2014 8:47 PM
  • Try Windows key + W and type Services.

    Scroll down the list until you find FA_Scheduler

    If the Startup type is set to Automatic, change it to manual.

    Jerry

    Thursday, May 23, 2013 11:15 PM

All replies

  • In start search for msconfig and under boot tab look for the application that you want to prevent from start up and uncheck it.
    Wednesday, May 22, 2013 3:21 PM
  • Thanks for your suggestion. Unfortunately the application is not listed there (msconfig). It is started by the service FA_scheduler which cannot be stopped.
    Wednesday, May 22, 2013 4:02 PM
  • You can try:

    Ccleaner (In Tools/Start/Windows you can uncheck the programs running at the beginning)

    Or even better you can try to use this official Microsoft´s program. For me it´s a must-have: http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx



    • Edited by DRASTOKLOP Wednesday, May 22, 2013 9:14 PM
    Wednesday, May 22, 2013 9:13 PM
  • Have you done what you say from an account with admin privileges?
    Wednesday, May 22, 2013 9:18 PM
  • Well since it is not listed in msconfig it is not listed in CCleaner either (I have checked). The software is started by the service FA_scheduler. The autoruns.exe utility seems great, however I cannot uncheck the service FA_scheduler either, it throws the same error message as earlier ("Incorrect parameter"), even though i run autoruns.exe as administrator.
    Thursday, May 23, 2013 7:00 AM
  • Yes, Always. I Always choose "run as administrator" for example when running commands in the command prompt.
    Thursday, May 23, 2013 7:01 AM
  • Maybe in the settings of the program there is some kind of "autoprotection" option that you can disable. My Kaspersky Internet Suite has this component in order to avoid the program to be modified/deactivated by malware, virus, etc.

    But it´s strange.

    Thursday, May 23, 2013 8:29 AM
  • Use scheduler and create a start task, for service FA_scheduler



    • Proposed as answer by colakid Thursday, May 23, 2013 9:22 AM
    • Unproposed as answer by colakid Thursday, May 23, 2013 9:24 AM
    • Proposed as answer by rsebck Thursday, May 23, 2013 9:25 AM
    • Edited by colakid Thursday, May 23, 2013 9:28 AM
    Thursday, May 23, 2013 9:22 AM
  • Sounds interesting, but I am not entirely sure how you mean? Should i create a scheduled task that starts the service at startup issuing a command like cmd /c sc start FA_scheduler? How would that help me stop the service?

    Thursday, May 23, 2013 7:55 PM
  • Try Windows key + W and type Services.

    Scroll down the list until you find FA_Scheduler

    If the Startup type is set to Automatic, change it to manual.

    Jerry

    Thursday, May 23, 2013 11:15 PM
  • Here is how I used a bypass the metro screen with a bat in gpeditor. You can add the same task to the gp startup/shutdown

    Friday, May 24, 2013 5:32 AM
  • That might be a smart solution. Unfortunately all services belonging to this application restarts in the same second they are shutdown so this will not be a viable solution in this case, but thanks for the suggestion!
    Sunday, June 02, 2013 8:47 AM
  • Hi Jonas,

    You can try below;

    1. Run cmd as a Administrator (very important, without this admin right, you cannot stop the service)

    2. Type 'net stop fortishield' on path C: ==like > 'C:\net stop fortishield'

    3. after its success, then you go to service and change the startup type to 'Manual', you will not get parameter error :).

    Its work for me, hope you too!!

    Koong

    • Proposed as answer by Jayce Lane Thursday, August 20, 2015 9:01 AM
    Friday, June 21, 2013 5:43 PM
  • I typed in Services at the "search programs and files" box.  Windows found "services" (the one with the gears icon).  I found the "fortinet sevices scheduler".  I changed the service to "Manual".  That solved it.  This should work for your windows 8.  Unfortunately Im running Windows 7.  Hope this helps.  Maybe you just opened the wrong services box.  My search box listed several.
    Friday, January 10, 2014 12:47 AM
  • Thanks for info, it then seems to be an issue local to my machine. I do the exact same procedure, but when I hit OK after changing to manual, it responds "Bad parameter" and the change do not take effect. I am sure I am in the right "services" box. 
    Friday, January 10, 2014 9:13 AM
  • Hey, don't know if you're still looking but I ran into the exact same issue as you with the same behavior (Bad parameter), here's how I fixed it:

    1 Shutdown FortiClient (right click on the taskbar icon, if the shutdown option is greyed out it should be because you're registered to a FortiGate, un-register from it and then shutdown the client)
    2 In an elevated command prompt, run 'net stop fortishield'
    3 Run msconfig then in the Services tab, clear the FortiClient Service Scheduler check box and click Apply.
    4 Run services.msc and switch the FortiClient Service Scheduler startup to Manual (it should be on Disabled at this point)
    5 Restart your computer. FortiClient should not load up.

    Hope this helps!

    James

    EDIT: just realised you're asking for Win8.1, I'm on 7... so maybe those steps won't do it for you. Worth a try though!

    • Edited by JamesP77 Thursday, January 23, 2014 8:51 PM
    • Marked as answer by Jonas Haglund Friday, January 24, 2014 6:07 AM
    Thursday, January 23, 2014 8:47 PM
  • Worked like a charm! Thanks! 

    Jonas

    Friday, January 24, 2014 6:07 AM
  • This does not work on windows 7 unless you use the 'net stop fortishield' command first as described in other posts.
    Tuesday, May 05, 2015 5:54 PM
  • @JamesP77

    Thanks a lot! Your solution works on Windows 8.1 as well. Only there was no entry (at least with my installation) in the Task Manager's  Startup section (Startup was moved to the Task Manager since Windows 8), so no need to uncheck something here.

    Thanks again.


    Thursday, July 09, 2015 10:23 AM