none
Printers not mapping through GPO RRS feed

  • General discussion

  • Hi All,

    We have a Windows server 2008 release 2 printer server. I have added a new printer to our server but cannot map the printer. We have windows 7 64bit computers. within the GPO user configuration - control panel settings - printers i already have two Lexmark CS510 printers with a universal v2 XL driver mapping to the site policy everytime. I have just added a new printer in the office and setup the same (also the same printer Lexmark CS510 with the same driver) but once i add that to the printer mapping with the other two and logon as the user the only two that map are the original two and not the third new one. Everything is set up the same as the other two printers, same drivers, security etc... When doing gpresult i can see the two originals mapped but no reference to the new at all, its like it doesn't see it so no errors or anything.

    Can anyone please help?

    Cheers

    Marc

    Friday, September 26, 2014 10:02 AM

All replies

  • Hi,

    Have you restart the client computers or run gpupdate /force to force the computer applying the latest gpo?

    If it still doesn't work, I suggest you try to manually map the printer on client PC to see if it can work fine:

    net use \\server name\Printer

    If it can work fine, please try to configure the GPP to share the printer again:

    GP Preferences: Add a new printer, set as default
    http://blogs.technet.com/b/grouppolicy/archive/2009/06/24/gp-preferences-set-a-default-printer.aspx

    After that, Every user logging onto the computer will have to wait as the printer installs.

    If it still fails, help to collect following log for our research:

    GPMC.log
    ==================
    a.    On domain controller, click Start -> Run, type GPMC.MSC, it will load the GPMC console.
    b.    Right click on "Group Policy Result" and choose wizard to generate a report for the problematic computer and user account (please place appropriately). (Choose computer and select the proper user in the wizard)

    Userenv.log
    ====================
    1.    Start Registry Editor.
    2.    Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon 
    3.    Right-click and new add DWORD(32-bit) with the Value of "UserEnvDebugLevel"
    4.    Type in 10002(Hexadecimal) or 65538(Decimal) in the Value data box, and then click OK.
    5.    Reboot the problematic computer to make the change take into effect.

    The Userenv.log is located in the following folder: %SYSTEMDRIVE%\Debug\UserMode\

    In addition, there are some related articles for your reference:

    Troubleshooting Group Policy
    http://technet.microsoft.com/en-us/library/cc758608(v=WS.10).aspx

    Troubleshooting Group Policy Using Event Logs
    http://technet.microsoft.com/en-us/library/cc749336(v=WS.10).aspx

    Your Guide to Group Policy Troubleshooting
    http://technet.microsoft.com/en-us/magazine/2007.02.troubleshooting.aspx


    Kate Li
    TechNet Community Support

    Monday, September 29, 2014 8:04 AM
    Owner