none
Services.msc - Remembers Previous Computer RRS feed

  • Question

  • A strange thing - when I open the services.msc MMC and connect to another computer, then close the MMC, when I open the MMC the following time it remembers the previous computer I connected to and automatically opens the services MMC connected to that machine (which asside from annoying is problematic when the remote machine is unaccessible).

    I tried Computer Management but that behaves as the previous versions of Windows did, where the following time you open the MMC it always connects you by default to the Local Computer.

    Anyone else get this?

    Reuvy

    Thursday, October 11, 2012 6:24 AM

Answers

  • You can solve this problem by adding everyone-deny-write permission on this file:
    "c:\Users\YourUserName\AppData\Roaming\Microsoft\mmc\services"
    Before applying the  permissions you need to go into "Services.msc" and make sure you are connected to your local computer.
    If you can't find the file try switching Roaming  with Local.
    I Hope this helps :)
    Thursday, October 24, 2013 10:52 AM

All replies

  • Not sure about remote computers, but Services.msc also finally remembers if reorder the columns so please don't "fix" this! Just "forget" the last computer.
    Thursday, October 11, 2012 1:14 PM
  • Hi,

    I also tested this on my lab and got the same. Thanks for your feedback.


    Nicholas Li

    TechNet Community Support

    Wednesday, October 17, 2012 7:44 AM
    Moderator
  • Yes. I'm getting the same, can be very confusing when administering a number of machines remotely!!

    I've been busy restarting services that i thought were local but it turns out they are on the remote server that I last connected to -oops!!

    Any way to disable this behavior?

    Cheers,

    Alex

    Thursday, December 6, 2012 8:50 AM
  • This seems to still be an issue almost a year later, is this going to be addressed?
    Tuesday, October 15, 2013 11:33 PM
  • The story get's funnier - the problem still exists in Windows 8.1! :-(
    Thursday, October 24, 2013 7:58 AM
  • Agreed Reuvy, I am on 8.1BETA and problem still exists.

    Has anyone tried the Win 8.1 RTM version yet?

    Another interesting note. Searching the start menu for "services" yields the result "View local services" as a result, clicking on "View *local* services" opens the MMC and shows me services on whatever the last machine was that I was viewing services on, which in my case is a *remote* machine!! Misleading eh!!?

    Come on MSFT, any comment at all on this??

    Thursday, October 24, 2013 8:10 AM
  • I'm on the RTM. I just tried the two different "services" options you mentioned above and they both tried to connect me to the same old server which isn't turned on at the moment. I honestly never noticed there were two new options nor is it clear what each one does.
    Thursday, October 24, 2013 8:12 AM
  • You can solve this problem by adding everyone-deny-write permission on this file:
    "c:\Users\YourUserName\AppData\Roaming\Microsoft\mmc\services"
    Before applying the  permissions you need to go into "Services.msc" and make sure you are connected to your local computer.
    If you can't find the file try switching Roaming  with Local.
    I Hope this helps :)
    Thursday, October 24, 2013 10:52 AM
  • ldavid's answer works. For some reason though I can't mark it as the answer/solution. Moderator, please do so.

    Thanks,
    RS

    Monday, October 28, 2013 10:09 AM
  • Perfect.  This was bugging me for the last couple of weeks.  Thanks Idavida...
    Friday, February 28, 2014 3:52 PM
  • David's answer works but I'll just add that applying the "Read Only" attribute is enough and a bit nicer than adding the deny permission.
    Tuesday, February 9, 2016 9:34 AM
  • Fantastic, thank you sooooo much.
    Thursday, May 23, 2019 4:53 PM
  • You can solve this problem by adding everyone-deny-write permission on this file:
    "c:\Users\YourUserName\AppData\Roaming\Microsoft\mmc\services"
    Before applying the  permissions you need to go into "Services.msc" and make sure you are connected to your local computer.
    If you can't find the file try switching Roaming  with Local.
    I Hope this helps :)

    Possible de to use GPO at start-up computer to delete fil 

    echo Batch to delete file

    del "C:\Users\%Username%\AppData\Roaming\Microsoft\MMC\services" /s /f /q

    echo Done!

    Thursday, August 15, 2019 7:37 PM