none
Your folder can't be shared.

    Question

  • I am a local administrator on this domain member Windows 7 Professional computer. When I try to share a folder, I get the message "Your folder can't be shared". The folder is on a local USB-attached drive. That is all the message says; it does not provide any further details whatsoever. Also, I cannot seem to find a KB article pertaining to this issue. Very frustrating. Any help would be very much appreciated!

    TIA,

    Sam "flux"

    Tuesday, April 27, 2010 4:18 PM

Answers

  • Hi Sam, you can try enabling file sharing in the network properties:

    Network and Sharing Center -> Click the current connection -> Status -> Properties

    Make sure that "File and Printer Sharing for Microsoft Networks" is checked.


    Sean Zhu - MSFT
    Thursday, April 29, 2010 12:53 AM
    Moderator

All replies

  • Hi Sam, you can try enabling file sharing in the network properties:

    Network and Sharing Center -> Click the current connection -> Status -> Properties

    Make sure that "File and Printer Sharing for Microsoft Networks" is checked.


    Sean Zhu - MSFT
    Thursday, April 29, 2010 12:53 AM
    Moderator
  • I have the same problem. All possible sharing is turned on and encryption has been downgraded. Everyone has full access for both share and security permissions and I am an administrator of the machine. I can even check the share box in advanced sharing but get the "Your folder can't be shared" message when I try from the context menu. Bottom line is tht the folder is not shared.
    Alan MacKenzie asmac@hotmail.com
    Wednesday, June 02, 2010 5:39 PM
  • I had the same problem. After i disabled the Virtual Machine network adaptor it worked. I turned the VM machine adaptor after the sharing and all is good. Hope theis helps you out.
    • Proposed as answer by stivio Friday, May 17, 2013 6:56 PM
    Wednesday, August 10, 2011 9:43 AM
  • I have Win7x64 with VMWare for other virtual systems and [paulie_] suggestion solved the problem for me correctly, thx.

    Thursday, September 15, 2011 10:30 AM
  • I had similar error due to my 'right-clicking' the folder I desired to 'share' on a Windows 7 Pro box.  Found that I instead had to utlize:

    'Control Panel\All Control Panel Items\Administrative Tools\ComputerManagement'

    Then, 'SystemTools\SharedFolders\Shares' and create a 'New Share'.  Configured with the wizard and all done.  Silly me.

    Friday, July 20, 2012 2:19 PM
  • Hi Paulie_, I believe I have inadvertently created a VM Network adaptor as I experiment with VMware and now I have this 'folder cannot be shared' problem.  Do you mind saying how you disabled the VM machine adaptor?

    I found this technet article (http://technet.microsoft.com/en-us/library/cc708372(v=ws.10).aspx) describing how-to, but it doesn't apply to my particular problem as I am using VMware/vsphere.  Any ideas, please?

    Saturday, October 13, 2012 8:28 PM
  • Paulie_  - how on earth did you work that out - I disable VMware network adapters and it worked as you suggest!  Thanks.

    Friday, May 17, 2013 6:56 PM
  • paulie_ answered this for me as well, I disabled all my VirtualBox and VMware adapters and now I'm able to share my folders. Thanks very much!!!
    Friday, August 09, 2013 4:02 PM
  • Go to network interfaces, right click the adapter, and select disable. Now it is disabled and you should be able to add the share. Afterwards you can right-click it to enable it again.
    Wednesday, August 21, 2013 9:19 AM
  • Crazy Mando has it correct for those of us without any VM-ware. You have to go through the wizard.

    • Edited by hoytpr Friday, September 27, 2013 4:44 PM
    Friday, September 27, 2013 4:44 PM
  • I was having the same problem after installing Visual Studio 2013. When I disabled the Internal Ethernet Port Windows Phone Emulator in the "Network Connections" control panel, I was able to share folders again.
    Monday, October 28, 2013 1:52 PM
  • I am a local administrator on this domain member Windows 7 Professional computer. When I try to share a folder, I get the message "Your folder can't be shared". The folder is on a local USB-attached drive. That is all the message says; it does not provide any further details whatsoever. Also, I cannot seem to find a KB article pertaining to this issue. Very frustrating. Any help would be very much appreciated!

    TIA,

    Sam "flux"

    If you find all the answers below do no good (as I did) and your machine has been acting strange for some time, and running sfc /scannow resulted in some things that weren't fixable, and networking was working fine before, then there is probably only one answer left: the reinstallation of the OS.  In my case that was the one and only fix.  As soon as my  Win7 Pro got a makeover networking was a breeze.  LOL

    Sunday, November 17, 2013 11:52 PM
  • I had the same issue. here is what i did to share a folder on windows 7.

    from top menu select:

    tools > Folder options...

    in the pop-up window click on the "view" Tab

    go to the bottom of the list and un-check "Use Sharing Wizard (recommended)" and hit OK

    Then Right-click on the folder you want to share and from menu select:

    Share with > Advanced sharing...

    from "Share properties" window, select "share" tab and then "Advanced sharing..."

    check "share this folder" and you can further set the permissions on the same pop-up window by clicking "permissions"

    My other PC was on another network from where I wanted to access the folder on windows 7 so i added windows 7 pc to work group. you can play around with the workgroup but the above will share the folder without any error.

    Friday, January 31, 2014 1:07 PM
  • Had the same issue on Windows 8.1 and this worked for me... I agree it is quite silly.
    Tuesday, March 04, 2014 12:20 PM
  • i use virtualbox latest 2014.

    it solved my problem too.

    thanks

    Wednesday, April 02, 2014 1:10 PM
  • Thsnks paulie

    This Is the exact reason why sharing wont be enabled.

    Vmware takes control of all networks, I verified it by streaming online mp3 songs and then disabling the vmnet and vmnet8 adapter. streaming stops.

    this is the culprit for all vmware users.

    ( Its really good to see such a great no of virtualization users )

    Monday, May 12, 2014 9:08 AM
  • I had the same problem. After i disabled the Virtual Machine network adaptor it worked. I turned the VM machine adaptor after the sharing and all is good. Hope theis helps you out.

    thanks this worked for me!
    Sunday, August 10, 2014 12:06 PM
  • 1. Open Network And Sharing Center ( win7>> Control Panel\All Control Panel Items\Network and Sharing Center )

    2. Click Change Adapter Settings

    3. Tow Lcd Monitor Colored Blue Is Your Current Connection . Right Click On It.

    4. Click Properties.

    5. Go To "This Connection Uses The Following Items:"

    6. Click " File And Printer Sharing For Microsoft Networks".

    7. Click Install

    8. Click "Client"

    9. Click "Add"

    10. Click "Ok"

    11. Click "Protocol"

    12. Click "Add"

    13. Click "Ok"

    14. Click "Ok"

    15. Share Your Favorite Folder.

    have a good time.

    Monday, March 16, 2015 3:11 PM