none
Windows 7 XP mode bridged network not available

    Question

  • Hello everybody,

    Yet another one with no more options than "Not Connected", "Internal Network" & "Shared Networking (NAT)". I cannot have my virtual NIC connected to a physical adapter. Here is what I have already done:

    1. Clean system boot (msconfig...)
    2. Un-installed my Kaspersky antivirus.
    3. Un-installed and then re-installed the new drivers for my NIC (Marvell Yukon 88E8057 PCI-E Gigabit Ethernet Controller)
    4. System BIOS and drivers are up-to-date (new Lenovo ThinkCenter PC)
    5. Deleted [user path]\Microsoft\Windows Virtual PC\options.xml
    6. The "Virtual PC network filter driver" is correctly checked in my adapter properties (I cycled checked it to be sure...)
    7. I added another physical Intel 1GB NIC in my system with no better results.

    Here is a copy of the networking sections of the "new" options.xlm:

    [...]
    <virtual_network id="0">
     <id type="bytes">A485543708B74EE4B29C962FC6354D68</id>
     <gateway type="integer">0</gateway>
     <name type="string">Internal Network</name>
     <virtual_server>
      <dhcp>
      <enabled type="boolean">true</enabled>
      <ending_ip_address type="integer">2851998462</ending_ip_address>
      <network type="integer">2851995648</network>
      <network_mask type="integer">4294901760</network_mask>
      <starting_ip_address type="integer">2851995664</starting_ip_address>
      </dhcp>
     </virtual_server>
     </virtual_network>
     <virtual_network id="1">
     <id type="bytes">01010101010101010101010101010101</id>
     <gateway type="integer">1</gateway>
     <name type="string">Shared Networking (NAT)</name>
     </virtual_network>
    [...]

    I am running out of ideas, and can't find other clues on the forums.

    Please help! Thanks,

    Xavier.

    Monday, May 10, 2010 12:58 PM

All replies

  • Uninstall NIC (in the "hosts" machine), and restart.

    Regards,

     


    Jose Manuel Tella Llop news://jmtella.com

    Tuesday, May 11, 2010 4:14 AM
  • Hi,

     

    Do you mean that the physical network adapter on the host machine is not available in the Networking settings of the Windows XP Mode?

     

    If so, you may also try to uninstall and reinstall Windows Virtual PC to check the result.

     

    Regards,


    Arthur Li - MSFT
    Tuesday, May 11, 2010 6:44 AM
    Moderator
  • Hello Jose,

    Thank you for your answer. As said in my point #3 , I already un-installed the NIC, and even updated the drivers. Same result here.

    Regards,

    Xavier.

    Tuesday, May 11, 2010 11:08 AM
  • Hello,

    Yes, this is what I mean.
    I did a full un-installation / re-installation of the Windows Virtual PC along with its two twin KB hotfixes: no results - I still have no reference to the physical adapter in the Networking settings.

    Regards,

    Xavier.

    Tuesday, May 11, 2010 11:11 AM
  • Hi,

     

    You may also try to disable and re-enable Windows Virtual PC in Windows Features to reset it.

     

    Does it work?

     

    Regards,


    Arthur Li - MSFT
    Wednesday, May 12, 2010 8:24 AM
    Moderator
  • Hello Arthur,

    Sorry for the late answer... my wife just gave birth last week :-)

    Disabling / re-enabling the Windows Virtual PC Windows Feature did not change anything... I even un-installed the application completly without any success.

    Thanks,

    Xavier.

    Tuesday, May 18, 2010 6:25 PM
  • You might try disabling TCP offloading on the NIC, that's been an issue with VPC2007 and Virtual Server previously.
    Tuesday, May 18, 2010 6:49 PM
  • Hello Smjain,

    No luck with that either. I disabled all kind of offloading in my NIC (Flow control, IPv4 Checksum, Large Send, RSS, TCP Checksum) then deleted my Options.xml and checked/unchecked the Windows Virtual PC feature with proper reboot.

    Can anybody send a copy of its C:\Users\[user name]\AppData\Local\Microsoft\Windows Virtual PC\options.xml?

    Thanks,

    Xavier.

    Wednesday, May 19, 2010 12:19 PM
  • I got it to work (was having same issue).

    There should be an option in virtual pc settings to clear all messages.  I cleared all messages and restarted virtual pc 2007.  When it started i got a message saying virtual pc 2007 was having trouble binding to the network adapter and it could be fixed by binding to all... then it asked for a file.  The file it wanted was located here: C:\Program Files (x86)\Microsoft Virtual PC\Utility\VMNetSrv\x64

    After that everything worked.

     

    Other stuff i did that may or may not be related:

    -uninstalled vmware workstation

    -unchecked ipv6 on ethernet adapter

    -turned off hardware virtualization in xml file

    Friday, August 06, 2010 11:27 AM
  • i had the same problem but mine was resolved by checking the "virtual pc network filter driver" in my nic adapter properties.  it was unchecked making the host nic unavailable in the list of nics for the virtual machine.


    what it is!
    Saturday, August 28, 2010 9:53 AM