none
Why do I get black bars around my screen on lower resolutions when it never used to do that? RRS feed

  • Question

  • In Windows 7, any game I play or just on the Windows Desktop, I used to be able to change the resolution and it would just stretch it to fit on the screen and make things bigger or smaller, Now when I do it, it doesnt stretch it anymore, it leaves black bars on either the top and bottom, or the left and right depending on the resolution selected, What changed? Why does it do that? (It is incredibly annoying while playing a game, I like full screen, not black bars, thank you)

    Monday, November 9, 2009 4:23 AM

Answers

  • I actually figured this out!

    I did not disable UAC.

    Instead of changing resolutions in Windows 7's "Screen Resolution" menu, I went into the Intel Graphics Properties app and I changed the resolution in there to 800 X 600 (the resolution I use in games) and I got no black bars, so I went back into COD 4 and there was no black bars! So then I changed the resolution back to 1280 X 800 and it was good on the desktop and good on the game.

    I think the reason for this is that there is a glitch in the resoluton options for certaing display adapters, and when you do it in Windows it changes the size of the screen, but when you do it in the Display Properties it changes the size that the graphics adapter is outputting. That seems like the only logical explanation.

    Thanks for your help even though I got it myself. I hope that people who are having this same issue see this thread/message.
    Wednesday, November 18, 2009 8:57 PM

All replies

  • Hi,

     

    You need to update the BIOS and the display card driver for Windows 7.

     

    After that, you also need to make sure that the games support the resolution you set on the monitor.

     

    If the issue persists, would you please upload the following information to SkyDrive and provide us the link for analyzing?

     

    System Information

    ========================

    1. Click “Start”, type in “msinfo32” (without quotation marks) in the Search bar and then press Enter.

    2. Choose “Save” from the File menu and save it as an NFO file.

    3. Find the file, right-click on this file, click "Send To", and click "Compressed (zipped) Folder".

    4. Send the compressed file to us.

     

    You also can use a digital camera to capture a photo of the symptom to us.

     

     


    Arthur Li - MSFT
    Tuesday, November 10, 2009 6:18 AM
    Moderator
  • Right click your Desktop behind this message selecting Screen Resolution; click Advanced Settings, Monitor Tab. Change the refresh rate value & see difference.

    I have same problem with large LG screen. This is new with Windows 7. If I set it to 1152x864, refresh rate defaults to 60 HZ which presents smaller view in large screen. I have to manually set it to 75 HZ for it to fill screen. In Vista U. 32 Bit, view fills screen at both 60 & 75 HZ.

    This is a bug in Windows 7 as compared to previous Windows operating systems which never, in my experience displayed less than screen.

    Tuesday, November 10, 2009 9:47 AM
  • Right click your Desktop behind this message selecting Screen Resolution; click Advanced Settings, Monitor Tab. Change the refresh rate value & see difference.

    I have same problem with large LG screen. This is new with Windows 7. If I set it to 1152x864, refresh rate defaults to 60 HZ which presents smaller view in large screen. I have to manually set it to 75 HZ for it to fill screen. In Vista U. 32 Bit, view fills screen at both 60 & 75 HZ.

    This is a bug in Windows 7 as compared to previous Windows operating systems which never, in my experience displayed less than screen.


    My laptop cannot support this with my current drivers even though my drivers are the latest for Windows 7 off of the Intel website for my X3100.

    It will not go above 60Hz

    I dont understand how changing the screen refresh rate to a higher frequency would change the size of your screen, so maybe you have a bug as well...
    Thursday, November 12, 2009 10:52 PM
  • Hi,

     

    You need to update the BIOS and the display card driver for Windows 7.

     

    After that, you also need to make sure that the games support the resolution you set on the monitor.

     

    If the issue persists, would you please upload the following information to SkyDrive and provide us the link for analyzing?

     

    System Information

    ========================

    1. Click “Start”, type in “msinfo32” (without quotation marks) in the Search bar and then press Enter.

    2. Choose “Save” from the File menu and save it as an NFO file.

    3. Find the file, right-click on this file, click "Send To", and click "Compressed (zipped) Folder".

    4. Send the compressed file to us.

     

    You also can use a digital camera to capture a photo of the symptom to us.

     

     


    Arthur Li - MSFT

    Thank you for the information, I have the latest BIOS (A16) from the Dell Canada website, and I have the X3100 display driver --.--.--.1930 from the Intel website (that is the latest one available for Windows 7)

    I find that when I go into Graphics Properties>Display Settings>Aspect Ratio Options - I get these
    "Maintain Apsect ratio" "Full Screen (No border)" "Center Image" it is set to Full Screen (No border) but I dunno whats up with that...cuz in the game it goes all funny, but then again when i change the resolution in the Intel Graphics Properties window, I dont get a border, but for some reason i get it when i change the resolution in the Screen Resolution window and in games. Odd...

    Thanks very much and here is the link with the file you requested for System Info:
    http://cid-5d22fa7c2533f10e.skydrive.live.com/self.aspx/System%20Information/My%20System%20Information%20for%20Microsoft.nfo
    Thursday, November 12, 2009 11:06 PM
  • Hi Josh1230,

     

    I would like to confirm the following questions:

     

    1.    Does it keep displaying in full screen if you do not launch any games?

    2.    If it keeps the full screen without starting games, I would like to confirm if this issue occurs on all the games?

     

    According to your System Information, I do think the BIOS and display card driver has been up to date.

     

    Have you also installed the Chipset driver update for your Mobile Intel® 965 Express Chipset from the following Intel Website?

     

    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17882&lang=eng

     

    Note: The third-party products discussed here are manufactured by that are independent of Microsoft. We make no warranty, implied or otherwise, regarding these products' performance or reliability.

     

    If it still cannot work, I also suggest you disable UAC and test the issue in Clean Boot mode.

     

    Disable UAC

    ==========

    1. Click the Start Button, type "User account control" and press Enter.

    2. When the User account control settings box appears, move the slider to Never notify.

    3. Click OK.

     

    What’s the result?

     


    Arthur Li - MSFT
    Friday, November 13, 2009 8:42 AM
    Moderator
  • I actually figured this out!

    I did not disable UAC.

    Instead of changing resolutions in Windows 7's "Screen Resolution" menu, I went into the Intel Graphics Properties app and I changed the resolution in there to 800 X 600 (the resolution I use in games) and I got no black bars, so I went back into COD 4 and there was no black bars! So then I changed the resolution back to 1280 X 800 and it was good on the desktop and good on the game.

    I think the reason for this is that there is a glitch in the resoluton options for certaing display adapters, and when you do it in Windows it changes the size of the screen, but when you do it in the Display Properties it changes the size that the graphics adapter is outputting. That seems like the only logical explanation.

    Thanks for your help even though I got it myself. I hope that people who are having this same issue see this thread/message.
    Wednesday, November 18, 2009 8:57 PM
  • Hey,,


    as a 13 year old, filipino kid, i finally got it :))

    ive been playing warcraft for 2 years now and this happened, black bars all around, and i found this forum and i also found a answer.(that doesnt work)

    so i think i got it.. i just kinda fixed the answer.

    1.Right Click on desktop
    2. Click display settings for vista ( i dont have windows 7)
    3. Adjust screen resolution
    4. Click advance settings
    5. Click on the intel graphics media app
    6. Click graphic properties
    7. Click aspect ratio options ( if non-clickable, change the screen resolution to 800x600, and back to your normal resolution, idny but im kinda noob in comps :)
    8. You will see center desktop, maintain aspect ratio, and FULL SCREEN
    9. Click full screen

    Done :)
    • Proposed as answer by NotsoHated12 Saturday, December 5, 2009 8:23 AM
    Saturday, December 5, 2009 8:15 AM
  • (From what I can tell after reading the thread, Josh is actually the one who came up with this solution. However, I'm directing my fawning and praise to NotsoHated12 because his is the message that I found via the search engine, and it actually solved my problem!)

    Omg thank you SO so much, dude. I'm a hardcore WarCraft II player (which is sad in itself :P) and I just upgraded from Vista to 7 and encountered this problem - maddening! Nothing worked, not compatibility troubleshooting, upgrading drivers, installing hotfixes, nothing!

    This did the trick though. And it's so crazy easy, I love it. I don't care who figured it out, thanks to both of you. I'm bookmarking the ____ out of the webpage too, because this fix is pure gold.

    /endrant xD

    Cheers!

    Friday, December 31, 2010 2:32 AM