none
Multiple sessions, programs wont start RRS feed

  • Question

  • Hi,


    I have a newly installed Windows 2016 Terminal server. I sat up HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\fSingleSessionPerUser registry setting to allow one user multiple login.

    As I expected the users could log in multiple times, but the second, third ... login could not run programs, explorer restarts.

    Eg: cmd wont run, but the registry editor runs.

    Did i miss a required settings, anyone faced a problem like this?


    Regards, Robert

    Monday, July 22, 2019 1:08 PM

All replies

  • Hi,

     

    Thanks for your posting. Could you please clarify the steps you performed for the registry key?

     

    Moreover, kindly check if below KB is helpful:

    https://support.microsoft.com/en-ie/help/302883/restrict-each-user-to-one-session-setting-in-tscc-msc-does-not-work

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 23, 2019 2:37 AM
  • Hi,

    I made these changes in registry:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\fSingleSessionPerUser set to 0

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\UserSessionLimit set to 99999

    And also i set up a GPO with these settings:

    Computer Configuration/Administrative Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Connections/Limit number of connections -> Enabled / 99999

    Computer Configuration/Administrative Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Connections/Restrict Remote Desktop Services users to a single Remote Desktop Services session -> Disabled

    Computer Configuration/Administrative Templates/Windows Components/Remote Desktop Services/Remote Desktop Session Host/Temporary folders/Do not use temporary folders per session - > Disabled

    I tried to figure out what happens, and its strange, if you log in with user01, everything works. And if you log in and start a second session with user01 just few programs works. BUT if you log out with the first logged in user01 the the second logged in user01 starts working.

    Robert


    Tuesday, July 23, 2019 8:40 AM
  • Hi Robert,

    What precise programs are having problems running?

    What precise error message/behavior are you seeing when a program doesn't start?

    Do these same programs allow you to open them multiple times within the same session?  For example, you can have many instances (processes) of Notepad running within a single session, but for other applications they will refuse to start more than one instance of the .exe within a session.

    Please note that most programs are not designed to be run in multiple sessions using the same user account on the same server.  How this fact manifests will vary depending on the specific program.  For example, some programs will appear to work fine with little (if any) detrimental side effects.  Other programs, they may exhibit unexpected behavior, experience data loss, strange errors, fail to start (as in your case).

    Thanks.

    -TP

    Tuesday, July 23, 2019 9:11 AM
    Moderator
  • Hi,

    I set up the new Windows 2016 server this way because the old, windows 2012 R2 server worked fine with the same settings.

    Programs which wont start, eg:

    Firefox, cmd.exe, office programs notepad etc.

    The error message in the logs if i try to start notepad:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2019-07-23T10:06:47.424667700Z" />
        <EventRecordID>49120</EventRecordID>
        <Channel>Application</Channel>
        <Computer>mycomputer.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>explorer.exe</Data>
        <Data>10.0.14393.3053</Data>
        <Data>5d01d1c5</Data>
        <Data>unknown</Data>
        <Data>0.0.0.0</Data>
        <Data>00000000</Data>
        <Data>c0000005</Data>
        <Data>0000000000000000</Data>
        <Data>860c</Data>
        <Data>01d5413e5426a014</Data>
        <Data>C:\Windows\explorer.exe</Data>
        <Data>unknown</Data>
        <Data>fa88660a-4acd-41b7-b117-bbb6f62ba6f4</Data>
        <Data>
        </Data>
        <Data>
        </Data>
      </EventData>
    </Event>


    • Edited by Thund3rw Tuesday, July 23, 2019 10:19 AM
    Tuesday, July 23, 2019 10:18 AM
  • Hi,

     

    Thanks for the detailed steps and update.

    Could you please confirm whether the affected programs are the same ones you opened in first session?

     

    Have you also verified if the GPO settings have been updated successfully?

     

    It would be the expected behavior if the Restrict Remote Desktop Services users to a single Remote Desktop Services session set as enable according to the KB.

    https://support.microsoft.com/en-ie/help/302883/restrict-each-user-to-one-session-setting-in-tscc-msc-does-not-work

     

    I will keep you updated if any findings after my test to reproduce your issue. Thanks for your patience.

     

    Best Regards,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 25, 2019 6:02 AM
  • Hi,

    Is there any update? Please feel free to let us know if more assistance needed.

     

    Have a nice day.

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 30, 2019 1:53 AM
  • Hi,



    I already made the required settings in the KB.

    While i try to solve the problem i installed a new Windows 2016 Std and sat up for RDS for testing purpose.

    Looks like some parts working, eg Firefox don't :)

    The key points in the infrstructure:

    1.  the users profiles are local on a dedicated drive (D:\UserProfiles)

    2.  some of the users have to use multi session settings



    As i know for the key points to work, i have to set up these settings in the GPO:

    1. make a registry modification for the userprofiles (HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList and sat up D:\UserProfiles)

    - set up the GPOs to:

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Connections\Limit Number of connections -> 99999

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Connections\Restrict Remote Desktop Services users to a single Remote Desktop Services session -> DISABLE

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Temporary folders\ - > Both settings: DISABLE



    And thats all, it should work.



    Did i miss something?

    Robert

    Tuesday, August 6, 2019 10:21 AM
  • Hi Robert,

     

    Thanks for your update with details. I did not see anything missed from your GPO settings.

     

    You might need to capture some dumps or traces to further investigate the issue, which I suggest to contact Microsoft Customer Support and Services where more in-depth investigation can be done so that you would get a solution to this issue.

     

    You may find phone number for your region accordingly from the link below:

    Global Customer Service phone numbers

    https://support.microsoft.com/en-us/help/4051701/global-customer-service-phone-numbers

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 7, 2019 5:50 AM