none
Why does my internet explorer open en present de default bing page, when my wifi connection is made? RRS feed

  • Question

  • This is my setup:

    I have a enterprise setup with windows 8 RTM in a windows domain.

    The wifi connection is setup using WPA2 (AES) with authentication against a RADIUS server.

    The RADIUS server is using the Active Directory as users store.

    The connection's are encrypted with certificates provided by a CA in the same domain.

    Problem:

    Each time when the connection over wifi is established, the internet explorer starts.

    En when the explorer is already open then a new tab is started.

    And each time the default page with in my case bing search is displayed.

    Question:

    Why this behavior?

    I was able reproduce this behavior on all the notebooks that I connect in this way.

    And when I change the wifi connection type to not using RADIUS then this does not happen.

    I think that this behavior is by design an that I have to change some settings to stop the explorer from starting.

    What settings must I change to stop this?

    Wednesday, October 10, 2012 4:43 PM

Answers

  • I have found the solution!

    Tests with fresh installed pc’s showed that this problem is network related.
    As soon as a window 8 PC joins my network it will show the Bing page.
    It is actually a redirect to the bing page as mentioned.
    The problem is name resolving related.
    My lab has it’s own ddns server and this server forwards requests to opendns.
    And opendns filters, so not all requests result in a connection.
    The problem disappears when I select the dns servers from my ISP.
    But the question remains what has been built into Windows 8 that causes this behavior and what should I configure on dns level to really solve this problem?
    So more investigation is needed here to find the real answer.

    This is what I captured with fiddler:
    Good works:
    # Result Protocol Host URL Body Caching Content-Type Process Comments Custom 
    3 502 HTTP Tunnel to client.wns.windows.com:443 512  text/html; charset=UTF-8 explorer:5364   
    4 302 HTTP go.microsoft.com /fwlink/?LinkId=129793 170 private  Expires: Fri, 26 Oct 2012 08:02:57 GMT text/html; charset=utf-8 msfeedssync:2188   
    5 302 HTTP go.microsoft.com /fwlink/?LinkId=68929 166 private  Expires: Fri, 26 Oct 2012 08:02:57 GMT text/html; charset=utf-8 msfeedssync:2188   
    6 302 HTTP go.microsoft.com /fwlink/?LinkId=129794 170 private  Expires: Fri, 26 Oct 2012 08:02:58 GMT text/html; charset=utf-8 msfeedssync:2188   
    7 200 HTTP rssgov.windows.microsoft.com /usagovrssfeed.rss 970  application/rss+xml msfeedssync:2188   
    8 200 HTTP www.microsoft.com /atwork/community/rss.xml 9.774 max-age=900   text/xml msfeedssync:2188   
    9 200 HTTP rssgov.windows.microsoft.com /usagovrssfeed.rss 970  application/rss+xml msfeedssync:2188
    Error page Bing.com
    # Result Protocol Host URL Body Caching Content-Type Process Comments Custom 
    96 502 HTTP Tunnel to client.wns.windows.com:443 512  text/html; charset=UTF-8 explorer:5364   
    97 302 HTTP go.microsoft.com /fwlink/?LinkID=219472&clcid=0x409 136 private  Expires: Fri, 26 Oct 2012 08:52:47 GMT text/html; charset=utf-8 iexplore:2420   
    98 200 HTTP www.bing.com / 10.622 private, max-age=0   text/html; charset=utf-8 iexplore:2420   
    99 200 HTTP www.bing.com /fd/ls/l?IG=a7443623375a411ba1d169c33554fff7&Type=Event.CPT&DATA={"pp":{"S":"L","PC":24,"FC":-1,"BC":25,"BS":29,"H":46,"FE":-1,"LE":-1,"C1":-1,"C2":-1,"BP":124,"KP":45,"CT":189,"IL":0}}&P=SERP&DA=Db3 42 no-cache  Expires: Sun, 12 Oct 2003 00:00:00 GMT image/gif iexplore:2420   
    100 200 HTTP www.bing.com /sa/8_01_0_1569928/homepageImgViewer_c.js 3.873 public, max-age=15548278   application/x-javascript iexplore:2420   
    101 200 HTTP www.bing.com /HPImageArchive.aspx?format=js&idx=0&n=1&nc=1351241629552 546 private   application/json; charset=utf-8 iexplore:2420   
    102 200 HTTP www.bing.com /HPImageArchive.aspx?format=js&idx=0&n=1&nc=1351241629557 546 private   application/json; charset=utf-8 iexplore:2420   

    • Marked as answer by Mike_Cwnbrgh Friday, October 26, 2012 9:18 AM
    Friday, October 26, 2012 9:17 AM

All replies

  • Hi,

    If you change to the other authentication method, will this happen?

    For example, you don't need the CA provided by the NPS side, but use the other methods?

    Thanks.

    Annie


    Friday, October 12, 2012 9:46 AM
  • Hi,

    Thanks, for the response,

    You mean that I should change from PEAP to EAP-MSCHAP v2 and test if it still happens.

    Well I have changed the configuration to first try EAP-MSCHAP V2 and fall back to PEAP.

    I am running tests for a few days to see if there is a difference.

    I will come back with the results in a few days.

    Saturday, October 13, 2012 12:59 PM
  • After testing for a few day's I must conclude de following:

    1. It does not Mather which authentication method I use.
    2. The internet explorer also starts when I am not using wifi. An interruption of the network connection also starts the internet explorer.
    3. There is probably one instable router or switch in the network that causes interruptions in the network traffic.

    Never the less the question remains why does the internet explorer start and how can I stop this from happening even if there is an network connection interruption?

    Is there a GPO setting that needs to be changed?

    Tuesday, October 23, 2012 7:15 AM
  • Hi Mike,

    I never met this kind of problem on Windows 8 when I was beginning to test it. 

    I suggest you to reinstall I.E to see if it won't be opened automatically. At the meanwhile, you can try to diconnect the network manually, such as pull out the wired cable to see if that will traigger IE.

    I don't think there is a GPO settings to be changed, and I think you haven't made any changes on the local group policy on this Windows 8. 

    By the way, is this the only machine suffered this issue? And, how about the others? Is that possible that you get any virus or script running automatically on the client?

    Thanks.

    Annie Gu

    Tuesday, October 23, 2012 9:46 AM
  • I'm getting this error too. After logon the default browser starts and opens some go.microsoft.com link and redirects to www.bing.com..its very annoying. I did a clean install of Windows 8 Pro, and I'm using VPN Connection to connect to the internet.
    • Edited by gogyvk Tuesday, October 23, 2012 5:38 PM
    Tuesday, October 23, 2012 5:35 PM
  • Hi Annie,

    I have 6 systems running in the same windows 8 configuration and they all have the same problem. They are member of active directory and there is a set of group policies that are applied to user and computer. They all use off line folders, home folder redirection, drive mapping, and more. I am using MS Forefront client protection on all the systems and these setting are also managed within GPO’s. This forefront client and its settings are pushed to the windows all systems and are mandatory. All systems are managed using SCCM 2007 and I am using TMG 2010 as proxy server to connect to the internet. A virus or script is not likely but you never known for sure.

    I have pulled out the wired cable and the same thing happened but not always. By the way on all windows 8 systems the tile apps are not always able to determine that there is a network connection. Sometimes I just takes a while and worst case it only recovers after a reboot. And the normal windows applications have no problem at all with the internet connection.

    Because this is a test lab all systems are dual boot en can also be started with windows 7 in exactly the same configuration as Windows 8. When running windows 7 there is no problem what so ever with the systems.

    While writing this feedback I came up with a test that I can perform. I will configure one computer that has only windows 8 and is not member of the domain. And is plugged into the same network as the other systems to see if it still happens.

    At the beginning I thought that this behavior was by design. Because it looks a lot like when I connect my windows phone 7.5 to an internet hotspot that has an authentication web page. This generates also a popup message.

    With sysinternals process monitor I captured the event that starts the internet explorer.

    It says process start

    “C:\Program Files\Internet Explorer\iexplore.exe" http://go.microsoft.com/fwlink/?LinkID=219472&clcid=0x409

    I am going to do some more testing and will report back in a few days

    Tuesday, October 23, 2012 9:13 PM
  • I have found the solution!

    Tests with fresh installed pc’s showed that this problem is network related.
    As soon as a window 8 PC joins my network it will show the Bing page.
    It is actually a redirect to the bing page as mentioned.
    The problem is name resolving related.
    My lab has it’s own ddns server and this server forwards requests to opendns.
    And opendns filters, so not all requests result in a connection.
    The problem disappears when I select the dns servers from my ISP.
    But the question remains what has been built into Windows 8 that causes this behavior and what should I configure on dns level to really solve this problem?
    So more investigation is needed here to find the real answer.

    This is what I captured with fiddler:
    Good works:
    # Result Protocol Host URL Body Caching Content-Type Process Comments Custom 
    3 502 HTTP Tunnel to client.wns.windows.com:443 512  text/html; charset=UTF-8 explorer:5364   
    4 302 HTTP go.microsoft.com /fwlink/?LinkId=129793 170 private  Expires: Fri, 26 Oct 2012 08:02:57 GMT text/html; charset=utf-8 msfeedssync:2188   
    5 302 HTTP go.microsoft.com /fwlink/?LinkId=68929 166 private  Expires: Fri, 26 Oct 2012 08:02:57 GMT text/html; charset=utf-8 msfeedssync:2188   
    6 302 HTTP go.microsoft.com /fwlink/?LinkId=129794 170 private  Expires: Fri, 26 Oct 2012 08:02:58 GMT text/html; charset=utf-8 msfeedssync:2188   
    7 200 HTTP rssgov.windows.microsoft.com /usagovrssfeed.rss 970  application/rss+xml msfeedssync:2188   
    8 200 HTTP www.microsoft.com /atwork/community/rss.xml 9.774 max-age=900   text/xml msfeedssync:2188   
    9 200 HTTP rssgov.windows.microsoft.com /usagovrssfeed.rss 970  application/rss+xml msfeedssync:2188
    Error page Bing.com
    # Result Protocol Host URL Body Caching Content-Type Process Comments Custom 
    96 502 HTTP Tunnel to client.wns.windows.com:443 512  text/html; charset=UTF-8 explorer:5364   
    97 302 HTTP go.microsoft.com /fwlink/?LinkID=219472&clcid=0x409 136 private  Expires: Fri, 26 Oct 2012 08:52:47 GMT text/html; charset=utf-8 iexplore:2420   
    98 200 HTTP www.bing.com / 10.622 private, max-age=0   text/html; charset=utf-8 iexplore:2420   
    99 200 HTTP www.bing.com /fd/ls/l?IG=a7443623375a411ba1d169c33554fff7&Type=Event.CPT&DATA={"pp":{"S":"L","PC":24,"FC":-1,"BC":25,"BS":29,"H":46,"FE":-1,"LE":-1,"C1":-1,"C2":-1,"BP":124,"KP":45,"CT":189,"IL":0}}&P=SERP&DA=Db3 42 no-cache  Expires: Sun, 12 Oct 2003 00:00:00 GMT image/gif iexplore:2420   
    100 200 HTTP www.bing.com /sa/8_01_0_1569928/homepageImgViewer_c.js 3.873 public, max-age=15548278   application/x-javascript iexplore:2420   
    101 200 HTTP www.bing.com /HPImageArchive.aspx?format=js&idx=0&n=1&nc=1351241629552 546 private   application/json; charset=utf-8 iexplore:2420   
    102 200 HTTP www.bing.com /HPImageArchive.aspx?format=js&idx=0&n=1&nc=1351241629557 546 private   application/json; charset=utf-8 iexplore:2420   

    • Marked as answer by Mike_Cwnbrgh Friday, October 26, 2012 9:18 AM
    Friday, October 26, 2012 9:17 AM
  • I have the same problem. I set my internet connection blocked by default when I start my Windows 8 PC. If I am connecting imediatly after booting I have the same issue, but if I am waiting a little bit and after that connecting to the internet, the bing page does not appear. 
    Monday, November 26, 2012 7:29 PM
  • Same here. Whenever my PCs reconnect to the network I get the Bing page. This happens whether I remove the cable and reconnect it, or resuming from sleep or whatever. As soon as the netowrk connection is re-eastablished IE10 starts and shows Bing. I am on a corporate network behind Proxy servers so I can't really control this. But Windows 7 computers don't do this, must be something hardcoded in Windows 8; whoever thought that would be a good idea should take a reality check.
    Wednesday, December 19, 2012 4:42 PM
  • I found what is causing it. It is my Cisco VPN client (5.0.07.0290). As soon as I install that I get the Bing pop ups while reconnecting the network cable even when the VPN client is idle. Just its presence makes it happen. And only on Windows 8!

    Anybody else with the problem has the same VPN Client?

    Thursday, January 3, 2013 1:06 PM
  • This behaviour only started when I installed a standard VPN client (the Microsoft client built into Windows 8)
    Monday, January 14, 2013 3:23 PM
  • To clean start of page after connection value with 1 is necessary here therefore for the address to change on 0

    • Proposed as answer by Nic Zarrilli Wednesday, February 27, 2013 12:01 PM
    Thursday, February 7, 2013 2:25 PM
  • Then to remove a line of the register here therefore to the address , to reboot and enjoy work.

    Thursday, February 7, 2013 2:28 PM
  • Works for me: no more bing.com when connected to corporate network.
    Tuesday, February 26, 2013 1:09 AM
  • Whenever windows connects ( or reconnects ) to a network, it tries to access an internet URL to validate internet connectivity. Some Wifi access points can be configured to redirect user to a custom URL for additional authentication, or acceptance of license agreement. You will see this mostly for free public hotspots.

    By disabling ncsi, you are disabling the network probing (That windows automatically performs to check for internet connectivity). There is nothing wrong with windows here, it is just the way the AP is configured.

    • Proposed as answer by M. Israr Khan Tuesday, February 26, 2013 2:16 AM
    Tuesday, February 26, 2013 2:00 AM
  • Sorry but you are wrong. This has nothing to do on how the AP is configured. This is caused by some sort of code within Win8 that is triggered by a VPN software. In my setup if I install the Cisco VPN client then as soon as it is installed Windows 8 starts to show Bing everytime I connect to a network even cabled ones. I can disable my WLAN adapter on my laptop and then just by unplugging and plugging the LAN cable back in, Windows 8 shows Bing. This doesn't occur if the Cisco VPN software is not installed. Needless to say that on Windows 7 this doesn't occur.

    Wednesday, February 27, 2013 11:50 AM
  • And I have tried the registry settings above and it works (thank you XORROR. This was driving me mad!).

    It is sufficent to disable ActiveProbing to fix it. I don't need to implement the second part.

    Wednesday, February 27, 2013 12:00 PM
  • Deleted
    Wednesday, March 20, 2013 8:37 AM
  • kindly explain it in layman language.. so i may do it as well.
    Tuesday, April 30, 2013 6:41 AM
  • Did it ever occur to you, that Microsoft implemented that behaviour on purpose to boost up bing page visits?

    Yes that crossed my mind too, only it had the opposite effect - I started to hate Bing :-)
    Tuesday, May 7, 2013 2:14 PM
  • kindly explain it in layman language.. so i may do it as well.

    Create a .REG file with this in it:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet]

    "EnableActiveProbing"=dword:00000000

    Run the .REG file to import it into your Windows 8 PC.

    Tuesday, May 7, 2013 2:18 PM
  • In IE try this  Tools-->Internet Options-->Connections-->Lan Settings   Uncheck Automatically detect settings
    Thursday, July 18, 2013 4:08 PM
  • This setting is specific if you have a WPAD or Proxy deployment and are pushing the settings via DNS or DHCP
    Wednesday, September 25, 2013 3:44 PM
  • See also Mazurca's work below, culminating in a single registry change.
    Wednesday, December 11, 2013 7:29 PM
  • Thank heavens for people like Mike who started this post and are prepared to do the hard yards so people like me can get rid of this annoying behavior on my browser.  Not sure if it was mentioned here but it isn't just IE. Since win8 this bing page pops up on chrome as well. Now that's annoying. Thanks Mike.  And for microsoft....you can't control the internet. you just can't. get out of my head!!!
    Tuesday, March 11, 2014 10:26 AM
  • me too.  it's annoying. I would like chrome to open. is there a way to get rid of the bing page at startup?  I am not very tech savvy. BTW I have windows 10.
    Monday, November 5, 2018 12:03 PM