none
Permissions on Windows 8 libraries keep resetting for homegroup users to read only!! HELP! RRS feed

Answers

  • I've a workaround but I'm unable to post the link to my thread.

    I copy it here.

    Hi at All,

    as somebody, I faced the famous issue that reset HomeGroup permission to Read and eXecute on folders that reside in a different drive than C and that  are in the Windows 8 default libraries.

    I explain you how I solved this issue. It's a workaround not a solution, I hope Microsoft is going to publish a patch for this nasty bug.

    In few words, I use Scheduled Tasks to start every logon a script which set Homegroup permission to Full control on the folder of interests.

    I publish how to apply this workaround.

    1) List all folders that you have added in your Windows Library
         For example, I have added F:\Pictures F:\Video F:\Music F:\Documents in my Windows 8 Library.

    2) Create a text file with notepad in C:\folderslist.txt and write the folder you listed in the previous step.
         Remember to put one folder per line, not more. For example, my folderslist.txt is :

         F:\Pictures
         F:\Video
         F:\Music
         F:\Documents

        Save the file and close it.

    3) Create a text file, again with notepad, named setPerm.cmd  and save in C:\ .
         Please write these command in the file:

         FOR /F %%I IN (C:\folderslist.txt) DO icacls "%%I" /C /Q /T /grant HomeUsers:(OI)(CI)(F)

         Save and close it.
         When we run this script, it reads the file folderlist.txt , get the path of  folders we listed in the step 1 and set Read and Write permission for Homeusers.

    4) Now test it. If all worked correctly you should be able to write from a computer in the Home Group.

    5) We have to schedule this permission every logon. How do we do? With this command:

        SCHTASKS /Create /SC ONLOGON /TN setPermTask /TR c:\setPerm.cmd /DELAY 0002:00 /RU System

        You must run this command in an elevated command prompt. Open the Task Manager, click File, click New Task, write cmd , check the flag run as Administrator and click run.

        You should see a command prompt, copy the line above, paste in the black window and press enter.

        If you do that correctly, you won't see error messages.

        Ok, what did we do? We created a task that run every logon and start the script which set correctly homegroup permissions on our folders.

        The task doesn't start at once, the system wait 2 minutes before run the script.  Remember that the bug reset the folder permission after we logon, so we have to take a while before setup permission correctly. If we don't care about this, we will have broken permission.

       The last detail, our PC run the script as System user so we won't see the ugly black box, if you want to see remove /RU System from the command above.

    6) Reboot your computer and check if the workaround works.

    Please comment the workaround and tell me if it works for you. If you know other workarounds please tell me.

     Emiliano

    <Here is the link to the original thread that Emiliano posted>

    Workaround for HomeGroup reset permission issue:
    http://social.technet.microsoft.com/Forums/en-US/w8itpronetworking/thread/5ec5746b-fc5e-4897-880d-23bbd74cd47d/#5ec5746b-fc5e-4897-880d-23bbd74cd47d

    Wednesday, February 20, 2013 1:51 PM

All replies

  • Hi,

    I cannot reproduce your issue.

    I tested on my machine and when share library to homegroup user read/write permission, it will not change even restart PC.

    I suggest to create another administrator account and share the library again to see if the same issue occurs.


    Leo Huang
    TechNet Community Support

    Monday, January 14, 2013 8:54 AM
    Moderator
  • Hi,

    I cannot reproduce your issue.

    I tested on my machine and when share library to homegroup user read/write permission, it will not change even restart PC.

    I suggest to create another administrator account and share the library again to see if the same issue occurs.


    Leo Huang
    TechNet Community Support

    What process are you using to do this?   I edited the NTFS permissions and changed the HomeUsers group to full permissions.  Upon reboot it is reset to read only.  I can reproduce and there is a handful of people that have responded to my thread in answers.microsoft.com that can also reproduce the issue.
    Monday, January 14, 2013 12:56 PM
  • Are you using the default libraries?  I have changed the location of my libraries to a different drive other than C:\.
    Monday, January 14, 2013 12:58 PM
  • Others having this issue:

    http://www.eightforums.com/network-sharing/14824-share-homegroup-does-not-keep-edit-permissions-2.html

    http://answers.microsoft.com/en-us/windows/forum/windows_8-networking/share-to-homegroup-does-not-keep-the-edit/deb46a2d-fe1c-490a-a22d-de99e5ae5046

    http://answers.microsoft.com/en-us/windows/forum/windows_8-security/homegroup-sharing-messing-up-folder-permissions/2e18569b-b36c-4c14-9e84-a31b1597fd70

    Monday, January 14, 2013 1:11 PM
  • I can also reproduce this rather annoying problem.  I have an additional documents folder (in my documents library) on a secondary hard drive on my Windows 8 pro system, and every time the Windows 8 system restarts, the permissions revert to read only for the Home group.


    Tim in Dublin

    Wednesday, January 16, 2013 9:26 AM
  • Can someone from microsoft  please confirm and respond to this thread regarding this bug.  Pretty significant if you ask me.
    Wednesday, January 16, 2013 10:21 AM
  • I will help you to submit this bug to our development team. If they recognize it was a bug, they will fix it on next update.

    Thank you for your information.


    Leo Huang
    TechNet Community Support

    Friday, January 18, 2013 8:16 AM
    Moderator
  • I will help you to submit this bug to our development team. If they recognize it was a bug, they will fix it on next update.

    Thank you for your information.


    Leo Huang
    TechNet Community Support

    Thank you very much. I assure you sir this is indeed a bug.  Permissions for the HomeUsers group get reset to read only on folders added to a library after every reboot.  this behavior does not occur in windows 7 and prevents any home group users from having write permissions to a library on a homegroup PC.

    • Edited by davidb1234 Friday, January 18, 2013 1:44 PM
    Friday, January 18, 2013 1:41 PM
  • As I mentioned previously, I too can =easily= reproduce this problem in Windows 8.

    Tim in Dublin

    Friday, January 18, 2013 1:46 PM
  • I will help you to submit this bug to our development team. If they recognize it was a bug, they will fix it on next update.

    Thank you for your information.


    Leo Huang
    TechNet Community Support

    Leo,

    May I get added to the list. My system does the exact same thing.

    Paul P

    Friday, January 18, 2013 2:25 PM
  • David,

    Any news on this?  It's getting to be a real pain in the neck.

    - Tim


    Tim in Dublin

    Sunday, January 27, 2013 8:25 AM
  • David,

    Any news on this?  It's getting to be a real pain in the neck.

    - Tim


    Tim in Dublin

    Sorry still waiting for a mod to submit this as a bug.   Everyone can reproduce it but I don't have the solution.  makes homegroups a useless feature in windows 8.   I think we are just going to have to wait for more people to report the problem here before anyone does anything about it unfortunately.

    Sunday, January 27, 2013 12:47 PM
  • I will help you to submit this bug to our development team. If they recognize it was a bug, they will fix it on next update.

    Thank you for your information.


    Leo Huang
    TechNet Community Support

    Leo have you submitted this yet?  This is a pretty serious bug.
    Sunday, January 27, 2013 12:48 PM
  • Yes, I have done.

    If our development team recognize it was a bug, they will fix it on next update.

    Thank you for your understanding.


    Leo Huang
    TechNet Community Support

    Monday, January 28, 2013 1:49 AM
    Moderator
  • I can confirm this is happening for me as well with 4 new PC's.

    Remember you are not a salmon

    Monday, January 28, 2013 9:27 AM
  • Yes, I have done.

    If our development team recognize it was a bug, they will fix it on next update.

    Thank you for your understanding.


    Leo Huang
    TechNet Community Support

    This is wonderful news!  Can you give us an idea of what the next update is?  Will this be in Feb Windows update patches??  We need to know when to test again and confirm resolved
    Monday, January 28, 2013 1:31 PM
  • Leo,

    Can you please define "next update"?  Would that be the next patch cycle (patch Tuesday), or the next SP release?  This has become a major issue for three of my clients, and I would like to be able to give them some reasonable expectation as to a fix.

    - Tim Toles


    Tim in Dublin

    Monday, January 28, 2013 3:59 PM
  • I will help you to submit this bug to our development team. If they recognize it was a bug, they will fix it on next update.

    Thank you for your information.


    Leo Huang
    TechNet Community Support

    Have you submitted this yet?  Lots of other people are reporting this same issue on other microsoft support forums.  We are all still waiting for a response.
    Tuesday, February 5, 2013 9:06 AM
  • We all still need help from Microsoft on this issue!  This has been reported many times in the forums here and nobody from Microsoft is helping. PLEASE HELP US?  One would think fixing important functionality like Homegroup would be up there on the priority list but I guess not...
    Friday, February 15, 2013 3:37 PM
  • I've a workaround but I'm unable to post the link to my thread.

    I copy it here.

    Hi at All,

    as somebody, I faced the famous issue that reset HomeGroup permission to Read and eXecute on folders that reside in a different drive than C and that  are in the Windows 8 default libraries.

    I explain you how I solved this issue. It's a workaround not a solution, I hope Microsoft is going to publish a patch for this nasty bug.

    In few words, I use Scheduled Tasks to start every logon a script which set Homegroup permission to Full control on the folder of interests.

    I publish how to apply this workaround.

    1) List all folders that you have added in your Windows Library
         For example, I have added F:\Pictures F:\Video F:\Music F:\Documents in my Windows 8 Library.

    2) Create a text file with notepad in C:\folderslist.txt and write the folder you listed in the previous step.
         Remember to put one folder per line, not more. For example, my folderslist.txt is :

         F:\Pictures
         F:\Video
         F:\Music
         F:\Documents

        Save the file and close it.

    3) Create a text file, again with notepad, named setPerm.cmd  and save in C:\ .
         Please write these command in the file:

         FOR /F %%I IN (C:\folderslist.txt) DO icacls "%%I" /C /Q /T /grant HomeUsers:(OI)(CI)(F)

         Save and close it.
         When we run this script, it reads the file folderlist.txt , get the path of  folders we listed in the step 1 and set Read and Write permission for Homeusers.

    4) Now test it. If all worked correctly you should be able to write from a computer in the Home Group.

    5) We have to schedule this permission every logon. How do we do? With this command:

        SCHTASKS /Create /SC ONLOGON /TN setPermTask /TR c:\setPerm.cmd /DELAY 0002:00 /RU System

        You must run this command in an elevated command prompt. Open the Task Manager, click File, click New Task, write cmd , check the flag run as Administrator and click run.

        You should see a command prompt, copy the line above, paste in the black window and press enter.

        If you do that correctly, you won't see error messages.

        Ok, what did we do? We created a task that run every logon and start the script which set correctly homegroup permissions on our folders.

        The task doesn't start at once, the system wait 2 minutes before run the script.  Remember that the bug reset the folder permission after we logon, so we have to take a while before setup permission correctly. If we don't care about this, we will have broken permission.

       The last detail, our PC run the script as System user so we won't see the ugly black box, if you want to see remove /RU System from the command above.

    6) Reboot your computer and check if the workaround works.

    Please comment the workaround and tell me if it works for you. If you know other workarounds please tell me.

     Emiliano

    <Here is the link to the original thread that Emiliano posted>

    Workaround for HomeGroup reset permission issue:
    http://social.technet.microsoft.com/Forums/en-US/w8itpronetworking/thread/5ec5746b-fc5e-4897-880d-23bbd74cd47d/#5ec5746b-fc5e-4897-880d-23bbd74cd47d

    Wednesday, February 20, 2013 1:51 PM
  • I've a workaround but I'm unable to post the link to my thread.

    I copy it here.

    Hi at All,

    as somebody, I faced the famous issue that reset HomeGroup permission to Read and eXecute on folders that reside in a different drive than C and that  are in the Windows 8 default libraries.

    I explain you how I solved this issue. It's a workaround not a solution, I hope Microsoft is going to publish a patch for this nasty bug.

    In few words, I use Scheduled Tasks to start every logon a script which set Homegroup permission to Full control on the folder of interests.

    I publish how to apply this workaround.

    1) List all folders that you have added in your Windows Library
         For example, I have added F:\Pictures F:\Video F:\Music F:\Documents in my Windows 8 Library.

    2) Create a text file with notepad in C:\folderslist.txt and write the folder you listed in the previous step.
         Remember to put one folder per line, not more. For example, my folderslist.txt is :

         F:\Pictures
         F:\Video
         F:\Music
         F:\Documents

        Save the file and close it.

    3) Create a text file, again with notepad, named setPerm.cmd  and save in C:\ .
         Please write these command in the file:

         FOR /F %%I IN (C:\folderslist.txt) DO icacls "%%I" /C /Q /T /grant HomeUsers:(OI)(CI)(F)

         Save and close it.
         When we run this script, it reads the file folderlist.txt , get the path of  folders we listed in the step 1 and set Read and Write permission for Homeusers.

    4) Now test it. If all worked correctly you should be able to write from a computer in the Home Group.

    5) We have to schedule this permission every logon. How do we do? With this command:

        SCHTASKS /Create /SC ONLOGON /TN setPermTask /TR c:\setPerm.cmd /DELAY 0002:00 /RU System

        You must run this command in an elevated command prompt. Open the Task Manager, click File, click New Task, write cmd , check the flag run as Administrator and click run.

        You should see a command prompt, copy the line above, paste in the black window and press enter.

        If you do that correctly, you won't see error messages.

        Ok, what did we do? We created a task that run every logon and start the script which set correctly homegroup permissions on our folders.

        The task doesn't start at once, the system wait 2 minutes before run the script.  Remember that the bug reset the folder permission after we logon, so we have to take a while before setup permission correctly. If we don't care about this, we will have broken permission.

       The last detail, our PC run the script as System user so we won't see the ugly black box, if you want to see remove /RU System from the command above.

    6) Reboot your computer and check if the workaround works.

    Please comment the workaround and tell me if it works for you. If you know other workarounds please tell me.

     Emiliano

     


    YOU ARE MY HERO!!!  Thank you so much for sharing this script with us to work around this TERRIBLE MICROSOFT BUG THAT THEY REFUSE TO ACKNOWLEDGE.

    SHAME ON YOU MICROSOFT for forcing customers to go to such great length creating scripts to work around a serious microsoft bug.

    Wednesday, February 20, 2013 2:20 PM
  • Thanks you for compliments.

    We have to hope that Microsoft publish the patch asap.

    Stick the question as answered.

     Emiliano


    • Edited by EmilianoB Thursday, February 21, 2013 12:45 AM
    Thursday, February 21, 2013 12:42 AM
  • Hi Emiliano, while I appreciate your efforts, I am having the same issue but I don't even use Homegroups!

    I simply have several devices which I use to access the Win 8 Machine as a media server. On XP, I used to just do a simple SMB share, set permissions for "Everyone" to "Read Only",  and that was that.

    If i try that with Win 8, any folder that is linked in the Library has its permissions reset at reboot. I have noticed that this is the case if ANY of the users has the the folder in their library, even if they are not logged in.

    The workaround I have used is to remove all Library links from all users; then the permissions on the folders persist. Unfortunately this renders the Library, and all the glossy Win 8 apps that use it, completely useless.

    To use your workaround, would I just replace "HomeUsers:(OI)(CI)(F)" in your code with "Everyone::(OI)(CI)(R)"?

    Monday, March 11, 2013 10:38 AM
  • Hi,

    I too am having this problem and it is very annoying! I had no problems sharing when I had files on my old XP desktop sharing with my Windows 7 laptop. However, now I have a lovely new Windows 8 PC which stores all my main files, it is a nightmare trying to access from my Windows 7 laptop.

    I too have set up a Homegroup. For me, my data files are on a separate partition from my OS. I change permissions to allow the Homegroup Read/Write access and all works fine for a while. Then mysteriously the permissons change so the Homegroup only has Read Only access and cannot be accessed.

    I haven't yet pinned down whether it only resets when the Windows 8 machine is rebooted or if it happens at other times.

    If it is just at Reboot then I will give Emiliano's workaround a go (thanks for that). If it happens at other times though, I will have serious problems as I will have to teach my two daughters how to change file permissions just so they can do their homework!

    This seems a pretty big bug in Windows 8. Any news on when it will be fixed and if it has even been acknowledged as a bug?


    • Edited by Stef45 Thursday, March 21, 2013 1:21 PM
    Thursday, March 21, 2013 1:20 PM
  • Hi,

    I too am having this problem and it is very annoying! I had no problems sharing when I had files on my old XP desktop sharing with my Windows 7 laptop. However, now I have a lovely new Windows 8 PC which stores all my main files, it is a nightmare trying to access from my Windows 7 laptop.

    I too have set up a Homegroup. For me, my data files are on a separate partition from my OS. I change permissions to allow the Homegroup Read/Write access and all works fine for a while. Then mysteriously the permissons change so the Homegroup only has Read Only access and cannot be accessed.

    I haven't yet pinned down whether it only resets when the Windows 8 machine is rebooted or if it happens at other times.

    If it is just at Reboot then I will give Emiliano's workaround a go (thanks for that). If it happens at other times though, I will have serious problems as I will have to teach my two daughters how to change file permissions just so they can do their homework!

    This seems a pretty big bug in Windows 8. Any news on when it will be fixed and if it has even been acknowledged as a bug?


    The workaround works great.  It only happens at reboot.  Implement the scripts and you will be fixed up.

    Shame on Microsoft for not getting this fixed in any reasonable amount of time.

    Thursday, March 21, 2013 1:35 PM
  • Thanks David, that is reassuring. I will give that workaround a go. It does seem staggering that file sharing was much easier between XP and 7 than between 8 and 7!

    You are right that it is not great Microsoft have not organized a fix yet, especially for such a fundamental problem. It would be nice to see a plan for when it will be fixed.

    Thanks for your help.

    Thursday, March 21, 2013 8:45 PM
  • Hey Gonzonator1982, sorry for the late answer.

    You are right, you only have to change HomeUsers to Everyone. Probably you have already tested it but i will really appreciate if you say if it worked or not.

    Thanks a lot!

    Emiliano

    Sunday, April 7, 2013 1:46 AM
  • Hey Gonzonator1982, sorry for the late answer.

    You are right, you only have to change HomeUsers to Everyone. Probably you have already tested it but i will really appreciate if you say if it worked or not.

    Thanks a lot!

    Emiliano

    I would NOT under any circumstances consider changing permissions of HomeUsers to EVERYONE. Your basically disabling all security and giving anyone free access.
    Thursday, April 11, 2013 11:23 PM
  • Yes, I have done.

    If our development team recognize it was a bug, they will fix it on next update.

    Thank you for your understanding.


    Leo Huang
    TechNet Community Support

    Leo can you provide an update on this bug?  It has not been fixed yet and pretty much breaks homegroup functionality without disabling your security.
    Thursday, April 11, 2013 11:26 PM
  • I too am experiencing this issue. Exactly as everyone else has described, when a folder is shared with homegroup with read/write permissions, it always resets the permissions to read only, on every reboot. One thing I wonder, is anyone else using Classic Shell on the affected computer? Don't know if that has anything to do with it but it's about the only software besides Quickbooks installed on the affected machine.
    Tuesday, April 16, 2013 1:08 PM
  • I too am experiencing this issue. Exactly as everyone else has described, when a folder is shared with homegroup with read/write permissions, it always resets the permissions to read only, on every reboot. One thing I wonder, is anyone else using Classic Shell on the affected computer? Don't know if that has anything to do with it but it's about the only software besides Quickbooks installed on the affected machine.
    It has nothing to do with classic shell or 3rd party applications.  Default install of Windows 8, add a folder from a 2nd drive to your libraries, writer permissions will be set to read only after every reboot.  The only way around it right now is with the script workaround provided above.  Still waiting for Microsoft to acknowledge the bug and let us know it will be fixed.
    Tuesday, April 16, 2013 1:29 PM
  • Leo, I'm with davidb1234. This is a pretty nasty bug and brings all those stereotypes of MS delivering shoddy, amateur software to mind. Not great for the new flagship that's charting MS's future. Please could you push your guys to resolve this.
    Tuesday, April 23, 2013 7:21 AM
  • Hi, This is my first time posting, I too feel very bitter over the Homegroup issue as it had become  very important to my family with PC's in different parts of the house.

    Previously with Win 7, the Homegroup worked perfectly, since upgrading to Win 8, no such luck, every Logon the permissions have to be reset and occaisionally the Homegroup has to be rejoined, what has happened to Microsoft?

    Lets hope Windows 8.1 resolves the situation, or its back to Windows 7 for us. i have tried the workaround mentioned previously but couldn't get it to work satisfactorily.

    Saturday, May 18, 2013 2:16 PM
  • Hi All,

    I am facing exactly the same issue with HomeGroup permissions....:(

    Leo, do you have any news from MS Dev Team regarding hotfix...??

    Pretty annoying bug....:(

    Thanks,

    Greg

    Wednesday, June 5, 2013 7:35 PM
  • I have several windows 8 devices now in a homegroup.  One of them acts as a main media center in which I have added additional folders on a second drive letter source to the libraries such as a 2nd internal hard drive or USB drive.  I have added the HomeUsers group to each of the libraries and set it for FULL access permissions but after each reboot all of the libraries keep getting reset back to read only for homegroup users on the folders I have added to the libraries from the second drive letter source. 

    This worked perfectly in windows 7.

    I have thoroughly tested this.  This is 100% reproducible.  Create a home group.  Configure libraries and add folders to the libraries from a 2nd drive letter source.  Grant HomeUsers group full access and it only works until you reboot on the folders you have added to the libraries from the second drive letter source.

    This only happens on folders you add to a library on a 2nd drive.  Not the default library folder.  


    Why is nobody from Microsoft addressing this bug? How do we request help?  The moderator has abandoned this thread without resolution on a confirmed bug in homegroup functionality.
    Wednesday, June 5, 2013 11:37 PM
  • Has this been addressed in the Windows 8.1 release due out later this year?
    Thursday, June 6, 2013 6:23 PM
  • Has this been addressed in the Windows 8.1 release due out later this year?
    Thursday, June 6, 2013 6:25 PM
  • Hi Leo, 

    Mine like a large number of Windows 8 Pro PCs have just been patched and this bug is still present.

    Are you able to advise when this issue will be addressed?

    The workaround posted by EmilianoB works well, but it is clearly a workaround as we shouldn't need to have a scheduled task to ensure permissions set in the UI are persistent post reboot.

    Thursday, June 13, 2013 10:18 PM
  • This is incredible that the issues still persists...I initially responded way back in DavidB's original thread...I've simply just not used libraries since this PC is more of a media server anyways.  But I'd like to use the file history for backup....and can't, because they require the use of libraries.  Was hoping to follow up and see if it was resolved in 8.1.  Sounds like it isn't...

    I guess I could use the script posted above...that was a good idea...but a shame that it's necessary after this much time has passed.


    • Edited by bschiav21 Saturday, June 29, 2013 1:02 PM Typo
    Saturday, June 29, 2013 1:00 PM
  • I have been dealing with this is as well ever since upgrading to Windows 8.  I really hope this is addressed in Windows 8.1 but I haven't seen anything suggesting it might be.

    Some sort of update from Microsoft would be great.  Hello?

    Saturday, July 20, 2013 5:28 PM
  • Boy am I glad to find this thread. I'm having the same problem and it's been driving me nuts. Was beginning to think it was just me! I hadn't noticed the correlation between restarts & losing access. I'll have to try the temporary work around while we wait for Microsoft to fix this extremely annoying bug. It's obnoxious, results in some of my programs not working. I also believe it may be causing a massive memory leak in my system. But that will take more work to prove out.
    Thursday, July 25, 2013 12:29 AM
  • We are still waiting for a fix for this bug after months and months.   Microsoft where are you?
    Thursday, August 22, 2013 8:21 PM
  • Another request to fix the same problem. I use FreeFileSync to synchronise files between my W7 desktop and my W8 laptop over my home WiFi. Both computers are members of the Homegroup; obviously the laptop needs to have its folders set to 'view and edit' for the sync to work.

    After re-starting my laptop, I have to re-set this permission before I can synchronise. With my old (W7) laptop there wasn't a problem..

    Wednesday, September 11, 2013 9:16 AM
  • Just wanted to let everyone know that this issue appears to still be present in 8.1  

    Monday, October 7, 2013 2:39 PM
  • If this is not fixed in 8.1 it is really pathetic of Microsoft. Why is there no response from them on this topic?
    Thursday, October 17, 2013 2:27 PM
  • I was able to resolve my issue by going in and fixing the NTFS permissions of the "HomeUsers" group on the security tab.  My Pictures library permissions would reset back to RO shortly after I applied them.  Once doing it under NTFS permissions the Home group stuff has worked flawlessly.
    Tuesday, October 22, 2013 9:33 PM
  • jesse66 - please could you provide a step by step description of what you did so a thicky like me can attempt to do it.

    Also, for the workaround from EmilianoB - does this render file history useless if the size of the storage is very large as every file gets changed every time the system boots up? Or am I missing something?

    Wednesday, October 23, 2013 9:18 AM
  • Just one more confirmation that this IS a problem. Please FIX.
    Friday, October 25, 2013 12:13 AM
  • Just one more confirmation that this IS a problem. Please FIX.
    Friday, October 25, 2013 12:13 AM
  • same issue
    Wednesday, November 13, 2013 5:00 PM
  • Same problem here, Windows 8.  Occurs on C: drive files.

    • Edited by dmwinsd Sunday, December 1, 2013 3:09 PM
    Sunday, December 1, 2013 3:08 PM
  • MS, really?  This thread is incorrectly marked as Answered -- it needs to be updated as NOT ANSWERED.  This is still a problem with Windows 8.1.  How frustrating.
    Thursday, January 16, 2014 6:26 AM
  • Leo:  thanks for your offer to assist with this problem.  I am experiencing the same thing.  I have 3 Windows 8 computers.  I set sharing to allow the Homegroup to view and edit.  It lasts until a reboot.  Then I have to re-enable it.  
    Wednesday, February 12, 2014 2:56 AM
  • No.  8.1 did not fix the problem for me
    Wednesday, February 12, 2014 2:57 AM
  • Exactly how does one do that?
    Wednesday, February 12, 2014 2:59 AM
  • I do systems work for small businesses and personal computing. A few of my customers have this problem with Windows 8.1. Upon restart, shared folders (in libraries) revert to read only from full control.  8.1 has not resolved the issue.
    Thursday, July 31, 2014 5:39 PM
  • I am able to reproduce the issue on Windows 10 pro.
    • Edited by EZtouch Monday, August 3, 2015 8:34 AM
    Monday, August 3, 2015 8:33 AM
  • Yes, me too. New Windows 10 Pro upgraded by update from Windows 8.1 Pro. Default user folders redirected to D:\Documents. Each time I restart permissions for HomeUsers users are reset - HomeUsers lose Full Control / Modify / Write permissions. Even though I am logged in as Administrator, membership of HomeUsers trumps this permission, and I am unable to save to these folders until resetting permissions manually.
    Tuesday, August 11, 2015 11:35 AM