USB Device Not Recognized on Windows 7 - USB mouse

    General discussion

  • I have a 4 week old Inspiron 1545 with Windows 7 Home premium that has developed an error: USB errors while trying to install a Microsoft USB mouse on this Laptop.   Interestingly, my Microsoft USB Mouse installed perfectly first time and worked for about 2 weeks, and then failed.   In looking at the system restore points, it tells me that there have been two driver updates to the USB environment since the unit was shipped from Dell.   I wonder if an automatic update from Microsoft has somehow inadvertently updated or replaced a Dell factory driver.

    Two nights ago I spent 45 minutes with Dell tech support doing remote control bug fixing on this laptop.  They werent able to fix it (in the time allowed).  They downloaded at least one of their newest drivers onto this machine and rebooted it - and they seemed pretty savvy - but still not working.  So I went ahead a did a system restore to a point about 10 days back because I could see that a USB driver would be affected (as shown in the system restore menus), and I would like to compliment Microsoft on this very cool functionality!

    At this point, I've unplugged the USB mouse , used the Device Manager to delete the 'unknown device', and done a system restore back to what I suspected was a working point.   But still getting a 'Device not recognized' warning every few minutes, and still don't have a working mouse.  I don't want to have to do system restores back to pprevious dates, although I suspect this is one solution.

    Sunday, January 03, 2010 5:48 PM

All replies

  • Just for grins, have you tried another usb mouse yet?
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, January 03, 2010 7:22 PM
  • If it shows up as an unknown device, it's unlikely to be caused by a mouse driver problem.  This means that the USB controller can't get some critical info from the piece of hardware.  The driver being used for the mouse is either a driver provided by Windows, or one that came from Windows Update for that mouse.  It wouldn't be a Dell driver in this case (it's not a piece of hardware embedded in the machine).

    It's possible that the hardware is in a bad state.  Please power off the machine, disconnect the mouse, pull the battery, and let it sit for about 15 minutes.  Then connect everything up again and see if you still have this issue.

    Do you see any other errors in device manager?
    Want to know if your current hardware & software will work with Windows 7? Check out these links: **Windows 7 Upgrade Advisor ** **Windows 7 Compatibility Center**
    Sunday, January 03, 2010 11:02 PM
  • *try another mouse?*  yes, I have tried both another known-good-working Microsoft wired USB mouse, and an ordinary Dell USB wired mouse.  none of them work in this 1545 laptop.  Also, I plugged the new Microsoft USB wireless mouse into my older HP laptop, and it worked flawlessly.  (the older HP laptop runs XP pro and normally has the Microsoft wired USB mouse in it.  XP 'found new hardware' and it worked in a few seconds.  So I think we have 3 working mice.

    I read Mark's reply and slapped my forehead - that could be it!  But no joy.  I powered everything off, disconnected everything including the mouse internal battery, and still getting 'USB device not recognized' as soon as I plugin the little USB mouse adapter.

    Is there a log written anywhere that will give something more specific?

    and no, there are no other errors in the device manager.
    Tuesday, January 05, 2010 12:50 AM
  • here's an entry from the Event viewer on this 1545...though I dont know what it means...this is about the time I plugged in the USB wireless dongle after powering down and then rebooting.

    at 1830
    Driver Management concluded the process to install driver FileRepository\usb.inf_amd64_neutral_e2b28ecac19a29af\usb.inf for Device Instance ID USB\VID_0000&PID_0000\5&1A53B0D9&0&1 with the following status: 0x0.

    Tuesday, January 05, 2010 1:38 AM
  • I actually meant to pull the battery on the laptop.  Sorry that wasn't clear.

    Did you try uninstalling all of the USB root hubs, then all of the USB controllers & then rebooting (so they'll reinstall)?
    Want to know if your current hardware & software will work with Windows 7? Check out these links: **Windows 7 Upgrade Advisor ** **Windows 7 Compatibility Center**
    Tuesday, January 05, 2010 5:20 AM
  • I'll try both of those later this evening.   Uninstalling the root hubs, then the controllers will be the second step if the battery removal doesnt clear it.  thanks for your continued support.  I will let you know what happens.
    Wednesday, January 06, 2010 1:11 PM
  • success.  pulling the battery out of the laptop for 5 minutes forced 'something'.   after reinstalling battery, rebooting, then plugged in wireless USB dongle.  got a popup window (I clicked first on the try icon that said 'installing new hardware click here for status') that told me it was searching for the appropriate windows driver...I'm guessing here, but it looked like it searched over the internet too...and it came back in about 20 seconds.  said new hardware was ready to use.

    Mark thnx for your help here. 
    Thursday, January 07, 2010 1:41 AM
  • I am having the exact same issue. Same computer, same age. My external mouse was working one minute and the next not. I tried many of the same things. However, I get the same error when I do not have anything plugged into my USB ports, as well as other items will work in the ports, both mice work on my other computers, which leads me to believe there is something much deeper going on here. I have looked for all available driver, MS, and other updates available. This was the first other person I had found that had almost the exact same situation as myself.

    I have done everything but a complete system rebuild (already done many restores almost to the date I received the laptop), however I personally think it is Windows 7 issue since my other Dell Laptop is working fine. Not sure what else than to just deal with having to use the laptop touch pad for now, as I have spent way more time on this than it warrants. Since all my other USB devices seem to work....for now.

    If I figure something out, will share.
    Friday, January 15, 2010 1:35 AM
  • Thanks from me too...
    Tuesday, February 09, 2010 11:15 PM
  • Same laptop, same problem..WTF???  Am about ready to say "screw 7".   Anyone find an answer yet?
    Wednesday, April 21, 2010 8:57 PM
  • I have been getting the same message/balloon on my 2 month old studio laptop for the past few weeks.  However, for me it seems to be affecting my integrated webcam.  When I try to turn it on, I am told that there is no supported webcam and the webcam is no longer listed under my device manager.  Under my USB device list, one unknown device (clearly my 'missing' webcam) is noted.

    I have chatted with my friends at Dell's tech support a number of times and still do not have any solution.  It will work for a short time after it has been powered off and restarted, and then a short time later it goes missing again.  I have removed the battery as well.

    There must be a permanent fix for this!  Any ideas?


    Saturday, May 22, 2010 4:43 PM
  • exact same problem.  Same thing over the last few weeks this has started to happen.  different computer.  nothing wrong with the mouse
    Tuesday, May 25, 2010 10:07 PM
  • tried the battery thing and it works temporarily.
    Wednesday, May 26, 2010 2:37 AM
  • This just started happening on my HP Pavilion laptop today.  I've had the machine since March, so it's been working without a problem for about three months.  The mouse still lights up and works on another laptop, so is functional.  I am about as non-techie as they make them, and have not found my way around Windows 7 too well yet - no "new hardward detected" when I unplug and replug the USB mouse (mouse not detected or no plug & play notices in 7?).

    My abilities are enough to bring myself to the mouse section of the hardware portion of the control panel.  I see that the pad-mouse of the laptap is listed, but the Targus USB mouse is not.  How to I get to look at driver updates as mentioned in previous posts to see if that is the problem? 

    I bought this laptop to assist in a job search because my old one kept freezing up part-way through on-line job applications, but I'm very disappointed that Windows 7 is making most of my previous applications and gizmos obsolete!  - can't use my Palm Pilot, can't play older solitaire games, can't transfer 10 years' worth of emails because Outlook Express is not supported . . . for all the talk about how well this new operating system is designed, it's not intuitive like XP and prior versions and does not appear to have tried very hard to work with older versions of files and applications.

    It's also preposterous to think that I have the most advanced operating system for Windows, on a 64-bit machine, and the only solution is to take the battery out for 15 mintues to see if that works!!!  Maybe next you'll tell me to put it on the floor and give it kick or two?  Or twist some tin foil on the mouse cable?


    Sunday, June 20, 2010 7:41 PM
  • Seeing similar issue on my desktop machine running Win7 64-bit. 1-2 months ago the USB mouse (a standard Logitech Laser) worked perfectly and then suddenly Win7 reports that the device is a unknown USB device.

    Inserting the mouse into other machine works fine (also other Win7 64-bit machines) so it is not a hardware issue with the mouse nor the desktop as lots of other devices are connected through the USB hub. Also tried disconnecting any other USB device from the desktop machine to rule out low USB-power issues - same same...

    Also tried using Nirsoft's USB Deview to remove all unknown USB-devices from the system but it did not solve the issue.

    Any clues appreciated?


    Anders Heick | Software Architect | HandStep
    Wednesday, June 23, 2010 7:50 AM
  • I've just recovered from a no-mouse situation by unpluging the powercord and removing the battery :-)

    Thanks for the tip, finally one that works :-)

    Saturday, July 17, 2010 12:49 PM
  • I do not understand why this happens. The mouse does not work, but a pen works when plugged to that same USB port. Pathetic it is, but the fact still remains that the mouse does not work.

    The solution was provided by Mark[MFST] in his posting near the top of this page: kill all the power supply, let the machine discharge internally, power the machine again.

    Killing all the power supply means to disconnect from the mains, but also actually unplug the battery. Then wait a few minutes, so that all the internal electronics have time to discharge.

    I tried to help the discharging by keeping the "power on" button pressed, and at the same time connecting and disconnecting the mouse in all the USB connectors, but I don't know if I was just being naif :-)

    Anyway, this simple operation solved the no-mouse problem on my Sony Vaio.

    In his posting, Mark also suggests that the USB root hubs be uninstalled, if needed be. They will be reinstalled when the machine reboots. In my case, this was not necessary, the "Kill All Power Supply" did the trick.

    Saturday, July 17, 2010 1:06 PM
  • Like they responded in the other replies, i had same exact problem did the battery thing were you take it out and put it back in and it worked amazingly, i have tried absolutely  everything there is,  from installing and uninstalling drivers, full factory image restore, buying new mice and still  did not worked.

    I thought that the battery thing was retarded and would not worked, but i said lets give it a try , it only takes couple seconds to take the battery out and snap it back in, amazingly my mouse  works again.

    Wednesday, October 20, 2010 3:42 PM
  • I was skeptical of the battery removal test too.  I had an update this morning and afterward my USB mice stopped working in any of my USB ports.  Other devices worked in them, but not mice.  Went out and bought a Microsoft mouse and tried to no avail.  Hit the interwebs and finally found this thread.  Thanks guys, my wireless mice work again.  Removed the power supply and battery after a shutdown.  Let it chill out for a few mins, plugged everything back in and fired it up and they work.  Thanks.
    Tuesday, November 16, 2010 8:54 PM
  • O M G, I have spent 5 hours tonight trying to resolve the exact same problem - my Dell Inspiron 1545with Vista suddenly started giving "USB device not recognized" messages on my mouse and wouldn't recognize two other mice I tried. I uninstalled all the USB ports, reinstalled them updated all the drivers for the mouse, Dell, etc and spent 2 hours on the phone with an IT expert friend doing all sorts of things but nothing helped, including a system restore. Thank heavens for this thread! I took out the battery for 15 minutes and voila! It's working again! Thank you Mark!!
    Monday, November 22, 2010 2:56 AM
  • worked for me also, i unplugged the cord and then took off the battery for 5 minutes, now my mouse and usb ports are working.. this is really weird that it randomly started failing. i have  a dell inspiron 1545 with win 7 upgrade version 64 bit.
    Wednesday, December 08, 2010 4:49 AM
  • I have a VAIO computer and it too has lost webcam and wireless (usb) mouse.

    I have tried another mouse same problem. What makes matters worse, I was using skype to video chat with my son while he was in Sydney, Austraila. If anyone fines a fix, please let me know.





    Thursday, December 09, 2010 12:46 PM
  • Interesting, I am running a Vaio notebook running Win 64bit using a Logitech laser mouse, and it does work fine on any other pc. I've borrowed another Logitech Laser mouse and I have the same problem, it does not work.  The mouse and webcam stopped working last night. (Dec09,2010)


    Thursday, December 09, 2010 12:50 PM
  • Yep, removing the battery worked for me too on a HP 6730b laptop.

    When this happened non of the USB ports worked and nor did the fingerprint device. After unplugging from power, removing the battery and then put all back in and startup it started to install the fingerprint driver and all bluetooth related drivers. After that all worked again.

    Thank you for sharing this resolution Mark!



    Thanks JP
    Saturday, December 18, 2010 12:04 PM
  • Does Microsoft expect every Windows 7 user in the world to pull out the battery, wait for 5-10 mins and resume work? 

    Monday, December 20, 2010 2:43 PM
  • Hi All!


    I encounter this problem now for several days.

    I don't think this is an issue due to the USB Port installation.

    I also browsed the internet to find solutions.

    Here my problems. I bought a Dell U3011 and the internal hub gets properly recognized by my laptop (Windows 7 64Bit) and my fedora 13 server.

    My Windwos 7 64Bit Ultimate Desktop doesn't regognize/install the drivers properly. No my keyboard (cheap Saitek) isn't regognizes anymore. I bought a new one a wireless Logitech MK300 including mouse. No way to get is properly installed.

    I tried to uninstall, to power off, to delete the cache1.inf, etc pp....

    Outside of Windwos during startup my mouse and keyboard work like a charme. Then after up to 5 Minutes after windwos failed to install drivers (standard drivers should work with those components) neither the keyboard nor the mouse work anymore. When I then plug in my mini traveller trust mouse (also a usb device) it works, just like all of my external usb sticks and harddisks.....

    As I said m other Windows 7 installation on my laptop regognizes all devices properly. Fedora too.

    I never had trouble with my pc's past 2 years and no other software got installed or changed.

    I hope there's somebody around who has an idea how to refresh or clean certain parts of windows without the need of a reinstall.

    Right now I'm only able to work remotely on my machine. Beeing a freelancing consultant I can only say all the trys are getting quite expensive right now.




    Tuesday, December 21, 2010 3:22 AM
  • Yes, the Dell machine isn't the problem its my zotac minitix pc. I develop critical applications and I used several usb devices with it. Mouse, Keyboard, Camera, Touchpad, mp3 player, drawing board, webcam, printer,...

    but with a sudden my keyboard doesn't work anymore (but it still works on my other pc's) and a new one isn't installable as is the mouse or the DellU3011 monitor usb hub.

    But on my other Pcs everything is fine.

    I didn't have to install any drivers on the other pcs and laptops. And even if I do,... it still doesn't work on this particular machine.

    Tuesday, December 21, 2010 3:44 AM
  • Thank you I'll give it a try.
    Tuesday, December 21, 2010 4:22 AM
  • I had the problem again so I think it is safe to say that the problem with my laptop can be pin pointed to my Nokia E52 when it is attached to the laptop. The problem occurs when I attach or detach the phone's USB cable from the computer while the computer is resuming from hibernation. There is no problem when I wait 5-10 minutes to be sure the pc is fully up and running again. This only happens with this phone. There is no problem if I do the same with the usb antenna from my wireless mouse.

    Thanks JP
    Tuesday, December 21, 2010 9:13 AM
  • Thanks

    Already did, everything is up-to-date.

    Thanks JP
    Tuesday, December 21, 2010 2:06 PM
  • I don't think there is much chance with Nokia...

    According to this thread it happens with a variety of USB devices not just Nokia, so I believe it's a Windows issue. And even if it would be related to third party drivers, then Windows should not constantly warn with the "USB Device Not Recognized" message. Normally when such message occurs it only happens once and stops when you disconnect the device. In this situation it keeps on complaining even when the device is disconnect and even when you have disabled the problem item in the device management list.

    Thanks JP
    Tuesday, December 21, 2010 2:46 PM

    I guess it is some kind of Windows Certificate problem.

    I gambled around today and i fixed my problems.

    Here's how.

    Once you go to "Control Panel" -> "Hardware and Sound" (not the HardwareManager under System!!!)-> "Devices and Printers" you should see your usb devices which are currently connected to the PC. You should also see those devices which cause problems.


    Right click on the device and open "Setting/Properties" (Sorry I have a german version,... am not really sure).
    Here you have to open the "Hardware"-Tab. Open "Settings".
    Go to "Change Settings"

    Then open "Driver"-Tab. Here's a button "update drivers" -> Choose the "Search on computer"-option. Point to Folder C:\Windows\System32 and check the "search in subfolders too" option. Then proceed.

    Now you should get an Error Message, I've at least never seen bevor on Windows (Completely Red and White). It tells you something about the origin of the driver and that it might be unsecure to install it.
    Proceed with "Yes, I want to install",....

    Voilá! Everything works properly!

    I'm really wondering why Windows just gives you that information on the driver with this kind of driver reinstall process....

    I hope this might help others, too.
    Good luck!


    Tuesday, December 28, 2010 2:52 AM
  • That's really funny.

    Maybe Microsoft shall sign it's own drivers! The keyboard I used doesn't need no additonal drivers and I never installed any. It's the standard driver provided by windows which caused that problem....

    It's not the first time I had trouble with this. But in this case it was much harder than before. Previousely Windwos just complaint if I was sure to use that driver and installed it properly afterwards.

    Thanks for the tip! I used the filechecker already and I also did sfc scannow,... but no problem where found.

    It could also be a problem with not properly installed updates, or uninstalled drivers. I whish there was some kind of "clean-up-Windows" function, which refreshes the system in some kind. Repairing Windows often doesn't work and sometimes leads to the need to reinstall applications and that's quite hard with development environments..... and takes too long.

    It would be fine if the installation of driver would work the same with both ways. One via the hardware manager and the other way via the hardware properties. It's hard for users to find out that there's a difference.


    Windwos is one amorphous system it is definitely hard to maintain such a beast,... but I'm not looking forward into the future. In 8 years we might have a merely untouchable system and linux might be a much better choice for standard users...

    Wednesday, December 29, 2010 5:42 PM
  • Hi

    Please power off the machine, disconnect the mouse, pull the battery, and let it sit for about 15 minutes.  Then connect everything up again and see if you still have this issue.

    It worked for me in my LG R480 windows 7.

    Thanks a lot.




    Thursday, December 30, 2010 3:59 PM
  • Thanks all. I had the same problem on my desktop; reboots or driver updates didn't help.

    Solved it by shutting down, disconnecting the power plug and reconnecting it 15 minutes later.

    Tuesday, January 25, 2011 7:49 PM
  • I have a Toshiba satellite laptop upgraded from Vista to Windows 7.

    The first time I had the "USB device not recognized..." problem, I tried the trick of pulling out the battery (I spent three nights reading different forums and found the trick), the problem had gone away for about a year. The second time the battery trick worked for about only  one month. Now I am having this problem randomly, sometimes, as frequent as a couple of days. Some poeple posted cases (in other forums) caused by damaged USB ports on the computer or the plug for the mouse, I chekced mine they don't look like being damaged. It gets really frustrating. 

    Sunday, January 30, 2011 4:16 AM
  • Hi Fellas,


    I´ve excact the same problem ! I spent over 6 hours by reading etc.


    In my opinion it´s a hardware problem, especially the battery/mainboard ; My battery stoped working for approx 6 days, after I got problems with the Webcam, sometimes it stoped and ran again after rebooting. Now for 3 days it stoped total to work.

    Every day I get i message about an Unknow Device like you all; I think it hasn´t to do anything about driver signing or Windows Update etc.


    If I´ll update the Unknow Device by a driver from c:/.../system32 , it tells me that the driver is up to date...


    I updated Bios and so on already, nothing happened...


    I hope some of my mates has a HP Laptop and a suitable battery too due to I can test on myself


    Further suggestions are welcome




    found what here: http://www.online-tech-tips.com/computer-tips/usb-device-not-recognized/


    doesn´t worked for me





    Tuesday, February 01, 2011 5:17 PM
  • Yes it is Win7 ; Now I´ll uninstall all USB controller
    Tuesday, February 01, 2011 8:24 PM
  • YES ! Works !


    So I did it: Uninstall USB Controllers ; Reboot/Shutdown - removed battery - restart - Windows installed all drivers - restart ->>> WORKS !

    Tuesday, February 01, 2011 8:39 PM
  • Today, again the same problem :-( After a time windows informed me that the usb device isn´t recognized :-((

    I haven´t a Windows dvd Handy just an apple ipod


    I started sfc /scannnow



    Wednesday, February 02, 2011 4:18 PM
  • Any problems with the4 System File Checker?


    My MVP is for Windows XP, Vista and Windows 7 IT, and I am getting increasingly good with Visual Studio.

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Wednesday, February 02, 2011 7:32 PM
  • No problems  :( with the system scan


    It will not work; whether I uninstall the usb controllers or removing the battery :(:(


    Damn Cam !

    • Edited by Fredmaster86 Thursday, February 03, 2011 2:30 PM addition
    Thursday, February 03, 2011 1:00 PM
  • I also bought a new laptop Asus P52F serie with windows 7 64 bit.
    The usb mouse is not detected. I tested the mouse on other laptops and there it's working fine.

    I did the thing with the battery and removing usb hubs on the Asus laptop but that did not help for me.

    Strange enought the mouse is working in the bios. USB legasy is enabled.
    When Windows starts loading the mous stops working and is not detected in windows device manager.

    When i boot the laptop connected with the usb mouse the lights are on.
    When the laptop is turned on and then connect the USB mouse the lights will not turn on :S

    I tried everything!

    any suggestions are welcome, thank you!

    Friday, February 04, 2011 10:29 AM
  • unfortunately my problem isn´t solved :((((
    Friday, February 04, 2011 3:09 PM
  • I have no further idea ; I haven´t a battery set in my laptop for 2 weeks cause it´s defect; Fuck USB Controller
    Wednesday, February 09, 2011 1:51 PM
  • Hey thanks alot, i was trying hard to find a fix, and this was it. thx agn
    Sunday, February 27, 2011 4:28 PM
  • If it shows up as an unknown device, it's unlikely to be caused by a mouse driver problem.  This means that the USB controller can't get some critical info from the piece of hardware.  The driver being used for the mouse is either a driver provided by Windows, or one that came from Windows Update for that mouse.  It wouldn't be a Dell driver in this case (it's not a piece of hardware embedded in the machine).

    It's possible that the hardware is in a bad state.  Please power off the machine, disconnect the mouse, pull the battery, and let it sit for about 15 minutes.  Then connect everything up again and see if you still have this issue.

    Do you see any other errors in device manager?
    Want to know if your current hardware & software will work with Windows 7? Check out these links: **Windows 7 Upgrade Advisor ** **Windows 7 Compatibility Center**

    Mark, You Are THA MAN.  Like you adviced; power off, take out battery, wait 15min and restart;  Not only made my usb ports agian, but also my blue tooth is working again now!!!

    my system is; lenovo w700, windows7   64bit            Thank God for this thread and people like you. My question is tho; so is there a permenant fix for this issue or we just have to discharge the battery every once in a while?  I remember hearing this advice along time ago somewhere I must say

    Thanks Mark! 

    Friday, July 01, 2011 5:49 AM
  • If you have to take the battery out to resolve this type of issue, should the battery be replaced?  I am really new so I don't know.
    Sunday, July 03, 2011 8:57 PM
  • OK, lets see

    1) check for a BIOS update for your machine

    2) did you upgrade from XP/Vista, if so go back to it

    3) if the USB still is at issue, backup everything and run the restore


    Windows MVP, paid Remote Assistance is available for XP, Vista and Windows 7.

    My page on Video Card Problems is now my most popular landing page. See my gaming site for game reviews etc.

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Hi folks,

    I have a problem along these lines, and I am an IT professional.

    A customer gave me the Dell Inspiron 1545 with complaint of screen black no cursor using Windows Vista on 64-bit machine.

    After a long series of tests, and connecting the hard drive to my own machine to verify that the disk itself is not faulty, I backed up her important files and scanned them for virus and malware. Satisfied it was clean, the disk was reformatted using Dell's recovery disks. After restoring to Vista, I upgraded it to Windows 64 Ultimate.

    All went well and customer was happy until she plugged in her wireless Microsoft usb mouse, and the computer went back to an unusable state- black screen no cursor.

    Booting into Safe Mode, running Repair Utility gave no result, and she recalls that issues began with errors from the USB port, not only from the mouse but from an external camera.

    Is this a USB issue on the motherboard? If so, I am recommending a different machine, as I truly dislike Dell with its proprietary issues, and do not plan to keep repairing the same issue.


    Thank you

    Tuesday, July 05, 2011 3:42 PM
  • Does the mouse work fine on another system?

    Does the system work fine without the mouse?

    Does the system work fine with a different mouse?

    Sounds like a mouse driver issue.

    Thursday, July 07, 2011 4:18 PM
  • I've got an similar issue on an intel processor 4gig memory, 250 gig HDD, intel up to 1695MB DVMT aspire 5732z

     tha tlong string o characters is on the laptop sticker. i'm using a razer naga mouse ( molten edition, love the orange glow ( found here http://store.razerzone.com/store/razerusa/en_US/pd/productID.219936100 )

     it works for ten minutes, then stops funcitoning. try unplugging and replugging it, hel even tried the suggestions her eon this page. BUT, nothing is working...


    help please!

    Thursday, July 28, 2011 3:30 AM
  • Just experienced the same problem. Restarts didnt clear the problem but powering off and removing the battery for a few mins as suggested before does work.

    Im glad I found this thread so quickly!

    Wednesday, August 17, 2011 10:31 AM
  • Thanks Mark, its a magic, I was struggling for this USB driver to be get installed and it worked smoothly after removing the battery and restarting.
    Friday, August 19, 2011 3:51 AM
  • I've been having the same problem with my brand new HP computer not recognizing my HP printer (only a year old).  I had uninstalled and reinstalled the printer, the drivers, changed USB cables, and more.

    I am going to try the unplug thing tonight.  I've been working on this issue for almost two weeks and have two days left in which to return the computer.  Several of you have talkeda about removing the battery, so I assume you're all on laptops.  I have a desktop so is there anything I should do besides just unplug from the power source and wait 30 minutes?

    Tuesday, August 23, 2011 1:28 PM
  • The picture below shows COnflicts/sharing. I tried unplugging battery, updated bios. I think the hardware im using is outdated. And if I install old Usb port drivers I ll manage to resolve this issue. The hotfix from Windows sucks. So please tell me if there is a problem in COnflicts/sharing.
    Thursday, August 25, 2011 6:22 AM
  • oh, i use a acer aspire 4910TG. THe error is code 43. 
    Thursday, August 25, 2011 6:25 AM
  • ok i just realized,  my Sony Cyber shot, my mp3 player is not being recognized, all drivers are upto date. This is some microsoft issue for sure! MS team plz plz plz get on it! I reinstalled windows. It worked for a whilee. After the windows updates, it stopped working!

    please post a real solution!



    Thursday, August 25, 2011 7:11 AM
  • Finally i got a solution that worked for me. 


    download this for win7 64 bit. Install and works. For some reason it bypasses the windows drivers. windows dont recognize them but works like a charm! 

    They are generic windows usb drivers by some cheap chinese mp3 player i think!

    WoRKs for me. People can try it. I restarted my computer a few times. no harm dont:!

    Code 43 flushed!

    Case solved!

    Thursday, August 25, 2011 7:42 AM
  • windows 7 not detecting usb device

    usb device not recognized windows 7

    usb device not recognized by windows 7


    Step 1:


    Copy the below files:




    Paste the files in


    Step 2:
    Then go to device manageer (START, serach program and files for Device Manager, then click it). It will show a list

    of devices, and half way down is an 'UNKNOWN DEVICE' with the yellow icon next to it. Right click that and

    'reinstall driver' or 'update driver software' - > Browse my computer for driver software -> Put the path 'C:


    This should install the USB devise

    Step 3:

    If you get an error while installing that, the next step is to go to C:/Windows/System32/drivers/USBSTOR.SYS

    and paste the file USBSTOR.SYS file only mentioned in Step 1 (if prompted to replace, pls allow)

    Sunday, October 16, 2011 1:35 AM
  • Thanks mark
    Monday, October 24, 2011 10:06 PM
  • correction to posted fix on Sunday, October 16, 2011 1:35 AM, >> USBSTORE.PNF not USTSTORE.PNF Most likely, USBSTORE.SYS won't be found in the inf folder, if even needed at all.
    Monday, November 14, 2011 1:01 PM
  • The first fix posted on Sunday, January 03, 2010 11:02 PM is the correct answer to Inspiron 1545 problems with this mouse:

    "It's possible that the hardware is in a bad state. Please power off the machine, disconnect the mouse, pull the battery (out of the laptop,) and let it sit for about 15 minutes. Then connect everything up again and see if you still have this issue."

    The HP Retractable (Black) Mobile USB Mouse (NY225AA)does not need any special drivers to operate on the Dell Inspiron 1545 laptop notebook. The Windows 7 system uses it's USBSTORE.inf driver to install this mouse.

    After 9 grueling hours of following advice from five different help forums between HP and Windows, I hope this post saves someone else's time and gets them up and running in seconds!!

    If the mouse worked fine and then one day it suddenly generates an "unknown device" error and won't work, and....as in my case....no other USB mice wired or wireless, new or old, would work in any of the USB ports, then the solution I quoted above is the proper fix. Just remove power, let it sit, and restart.

    NOTE ***I first went to the Device Manager (start > control panel > Device Manager) and found the "unknown device" with the yellow exclamation mark error (mine was under Universal Serial Bus Controllers)and right-clicked > uninstall. Then I right-clicked and selected scan for hardware changes to ensure all USB Root Hubs were cleared of any warning symbols. Then I followed the battery removal instructions above.*** Worked like a charm!!!!
    • Edited by bunnislippers Monday, November 14, 2011 1:36 PM html code for returns
    Monday, November 14, 2011 1:26 PM
  • This is just simply pathetic that it actually works:

    1. USB device unrecognised.  No mouse works on any port

    2. Laptop: HP 6730b

    3. Mouse(s):Microsoft Mouse

    4. Disconnected everything, removed battery for 5 minutes

    5. Reconnected and installed battery again

    6. Voila!  All working again.


    Thanks all!

    • Edited by Scubie Sunday, November 27, 2011 9:55 AM
    Sunday, November 27, 2011 9:54 AM
  • I have a HP EliteBook 8730W. was baffled when the mouse just stopped working. The mousepad thingy on the laptop itself was fine but i really dislike using it. I got the answer in this forum... basically

    same as above

    1. Power down completly

    2. Remove battery

    3.Wait 5 minutes

    4. Plug everything back in and power up.

    5. Everything now works! 



    Wednesday, December 14, 2011 3:29 PM
  • I agree. What I did first was boot from both a Windows Dart disk and an aftermarket conglomerate disk and neither would load any USB peripherals. I noticed when I first had the problem that Windows complained with no devices plugged in which led me to try the hardware solution first. The controller most probably locked up. Happens all the time in cars.....
    Thursday, December 15, 2011 3:13 PM
  • Thanks Mark, removed the battery from my Sony Vaio, waited a bit of time, then re-installed and booted up and all is working 100% again, you're a genius man! Sincerely, Chris O.
    Wednesday, December 28, 2011 7:25 PM
  • While my mouse and keyboard were working fine any other USB device i plugged in would fail and not install successfully. This was on a Lenovo desktop as well. I gave the "pull the CMOS battery" a try and it seems to have corrected the issue as my flash drives and what not are now working as they should and installing without issue. Thank you for your post and solution, this is something I wont forget to try in the future.
    Thursday, January 05, 2012 3:40 PM
  • Thanks Mark, removed the battery from my Sony Vaio, waited a bit of time, then re-installed and booted up and all is working 100% again, you're a genius man! Sincerely, Chris O.

    When I started reading this thread, I was rather skeptical about the suggestion to remove the laptop battery, I had already re-booted twice, changed the AA batteries in the mouse, downloaded software from Logitech and installed, got out two old USB corded mice that didn't work (which do work fine on my wife's iMac, so I was about at my wits end.

    I do have a Sony Vaio, so when I read your post I figured I wouldn't have anything to lose by removing the battery, and sure enough as soon as it booted up, it recognized all my mice again, no problems!



    Saturday, January 14, 2012 2:58 PM
  • Yep, removing the battery worked for me too on a HP 6730b laptop.

    When this happened non of the USB ports worked and nor did the fingerprint device. After unplugging from power, removing the battery and then put all back in and startup it started to install the fingerprint driver and all bluetooth related drivers. After that all worked again.

    Thank you for sharing this resolution Mark!



    Thanks JP

    this also worked for the fingerprint reader (Egistec ES603) on my Lenovo V570! been fighting it for 1-2 hours now and was about to do a full format!! who knew it was so trivial! excellent work and many thanks.
    Sunday, January 29, 2012 3:36 AM
  • I have a Dell Inspiron as well and tonight my mouse just stopped working. I tried a few of the things then read about removing the battery. That worked like a charm. Took the battery out for 5 mins.  Once reconnected, my mouse was recognized. Such a simple solution! Thanks whoever suggested it!
    Tuesday, March 06, 2012 2:03 AM
  • Okay look the whole pulling the battery thing IS NOT a suitable fix IMO!!  Yes it works but only for awhile...  And having to shut down, pull the battery etc. 3 - 4 times every few hours of working on the laptop is a total pain in the !#$!  There has to be a better fix then having to stop what I'm doing and shut everything down whenever it happens!

    Somebody please explain how to fix this crap once and for all!!!!!

    Sunday, March 18, 2012 7:32 AM
  • ThanX A lot MArk ur Advice really worked thanks a lot once again
    Sunday, April 29, 2012 11:34 PM
  • There are some very good ideas here, but if they all fail, and especially if you have a laptop, and the one im trying to fix gets pretty hot, you may want to consider that the Chipset has gone.
    Thermal expantion and contraction have probably caused the soldering under the chipset to crack or detach.
    You could fix that if you were to reball the Chipset to the motherboard :-)

    Thanks everyone :-)

    I tried everything ive seen here plus Windows XP/Vista and a recovery Mini Windows XP, nothin'.

    Friday, May 11, 2012 2:45 AM
  • I have an Acer laptop, 10 months old with Win 7 Pro, same problem. The mouse works perfectly, just not on my laptop. I also have done systems restore without any luck, my updates are all done. Please anybody, help.
    Saturday, July 21, 2012 5:59 AM
  • Hello,

    I just wanted to let u know, I had this same issue for about 2 weeks. Basically what happened was a bad install of my AMD Chipset drivers. When I attempted to upgrade, the install didn't go all the way through.
    I then restarted my system, and BAM! No Mouse or Keyboard functionality thru USB.

    Even when I went into SAFE MODE the Mouse and Keyboard were not functional. The only time they worked was when the computer first attempted to start, BEFORE windows loaded.
    So, this means that your issue is a software problem.

    I thought it was some other software that I installed, and ran a restore session, but that wasn't the issue. Still no functionality.

    I even tried removing my CMOS battery, to reset it, since some people said that had solved their problems...Still nothing.

    I then read other forums around the web using my Android phone to try and find a solution, only those solutions were no help.

    I was also advised to run: MSCONFIG and Hide all  Windows programs and then stop every other driver, source from loading (of course if my mouse and kb worked, I would have tried that).

    I had even read that because I was using USB, that I should try using a PS/2 Mouse and Keyboard connection.

    It took me 2 weeks to get the correct PS2 adapter that worked, which would essentially allow me access to my system again...

    I  Purchased a USB A Female to PS2 (MDIN6) Male Adapter (for Mouse) from http://www.SFCable.com

    This my friends, was a lifesaver. I only have one PS2 port on my system, so I used my mouse to try  every option I had previously read about. Of course you cannot type because the keyboard doesn't work, so you need to know the location of the folder where the programs you are trying to run are.

    So, a little after I got back into my system, and I closed down all programs, the warning screen came up that ALL of my USB Ports failed and could not be updated. I even  Uninstalled every last USB port from the System Properties and restarted, and still that didn't work.

     I had forgotten that during the time when this problem arose, there was a failed install of my AMD chipset drivers, so luckily I had not deleted the source file and I tried to reinstall, and VIOLA! I'm back up and running and my USB ports are restored and everything is working!

    I hope this solution is able to help other people out there.

    JE - Gemini365@GMAIL.COM
    • Edited by Gemini365i Sunday, July 29, 2012 2:35 PM HTML
    Sunday, July 29, 2012 2:34 PM
  • Battery trick helped me with Sony Vaio.

    Thanx, Mark!

    Tuesday, November 27, 2012 8:54 AM
  • I have a toshiba satalite and not only do i have this mouse issue i also have no sound. I can run my usb fan that goes under my laptop but no mouse will work on it. they do work in other laptops tho. they don't even act like they get power to them. This just happened one day. My computer just shut down one day then froze up and then this was the deal. i got the puter working but still no sound or usb mouse. i am in process of trying shut down battery drain method but i don't have faith it will work.
    Saturday, July 06, 2013 2:59 AM
  • My thanks as well! Who would have thought this was a solution (You, I guess!). Same story, and thankfully same success with the powering down.
    Tuesday, January 28, 2014 6:51 PM
  • I saw all the success with the battery removal from other users and while I'm sure that works for some people I thought I'd share that I simply removed the mouse using Device Manager (highlight and hit delete key) and then forced it to scan for hardware changes (Action, Scan for hardware changes).  That fixed me right up.  
    Thursday, February 27, 2014 1:33 AM
  • I too have this same problem on my Dell Inspiron laptop computer. First my Ipod wasn't getting recognized, than external hard drive, than mouse, than, thumb drive. 

    I have deleted and installed new drivers to no avail, I have changed the USB power setting so that the USB is always on. I have tried some registry fixes, I have restarted a billion times.  I tried restore points.  I have NOT tried pulling the battery but I will tonight.

    For now if I turn on the computer I have about 1-2 minutes where my device is recognized but then it stops and pretends it can't find it anymore.  This is a step up from when it stop recognizing things completely all the time.

    I personally think this is a windows 7 error.  If pulling the battery doesn't work along with reinstalling drivers I will try re-installing windows 7.  If that doesn't work I'm going to try to "up?"-grade to windows 8.  After that I'm never buying Microsoft again, on to Apple, this is ridiculous that there is no easy solution.

    Monday, January 12, 2015 1:33 PM
  • I had the same problem with a Toshiba Satellite running Windows 7 Ultimate. The battery removal trick did not work for me. I ended up uninstalling ALL items under the USB section of the Device Manager (do NOT also delete drivers!!!), then rebooting. At first, Windows would not re-boot, and the only boot options I saw were Start Normally, or Repair Startup. I forced power-down, then used the F8 key while powering/rebooting to get to the boot options page. I then booted in safe mode, no networking, and that seems to have worked. My mouse is now working again.
    • Edited by DTB Radio Tuesday, March 31, 2015 12:30 PM
    Tuesday, March 31, 2015 12:24 PM
  • OK, I had a similar one... I just did a reinstall of Win7 due to some issues, and my USB 2.0 port would not work with my mouse. It worked with everything else, and the 3.0 ports worked with the mouse. Nothing in Device Manager had the standard warning about being "unknown". No yellow exclamation point.

    However, when I opened up "other devices" just out of curiosity, I had 2 different "unknown devices". They still didn't have the warning symbol. I believe Windows saw them and was able to figure out what they were, but nothing more than that. Even running an app I use called 'Unknown Device Identifier' didn't show any errors. I had Windows search for the best driver, and it fixed both. One was extra features on my Bluetooth radio, and the other was the mouse itself. SO anyone with a similar issue where some devices work on a USB port, and others don't, but they work on the rest may just find they have an "unknown device" that isn't really "unknown".

    Just thought I'd add my 2 cents, as this was a very odd fix for a problem. 
    Tuesday, April 12, 2016 6:07 PM