none
No Internet? Please read and try to help... RRS feed

  • Question

  • Hey,
    I just changed my windows PC to Windows Seven Beta 32 bit. And everything is working fine, except my Ethernet Controller. When i go to Device Manager there is a question mark at Ethernet Controller (The drivers are not installed for this device). Meaning that i can't get the internet to work either. I need to install the drivers for the ethernet controller. I have my CD what came with my nVidia Motherboard and i installed Vista x32 Bit Chipset one which contains the ethernet controll drivers...But it still does not work, and Device Manager still says that the drivers are not installed for this device..I need help. Pleasee, Thanks.

    BTW: My CD is the XFX GeForce Series Motherboard Installation CD.
    Sunday, January 25, 2009 10:42 PM

Answers

  • Go to the website of the manufacturer of your motherboard (like ASUS, etc.), browse to the Support/Download page and find the latest Vista 32-bits/64-bits drivers for the network adapter of your motherboard. Unzip if necessary and run the installer in Vista compatibility mode and as an administrator. Right mouse click on the executable -> Properties -> Compatibility (tab) -> Check both 'Run this program in compatibility mode for: Windows Vista' and 'Run this program as an administrator'.
    • Marked as answer by TnTShadow Monday, January 26, 2009 12:38 AM
    Sunday, January 25, 2009 11:01 PM

All replies

  • Go to the website of the manufacturer of your motherboard (like ASUS, etc.), browse to the Support/Download page and find the latest Vista 32-bits/64-bits drivers for the network adapter of your motherboard. Unzip if necessary and run the installer in Vista compatibility mode and as an administrator. Right mouse click on the executable -> Properties -> Compatibility (tab) -> Check both 'Run this program in compatibility mode for: Windows Vista' and 'Run this program as an administrator'.
    • Marked as answer by TnTShadow Monday, January 26, 2009 12:38 AM
    Sunday, January 25, 2009 11:01 PM
  • Nope. I tried that. It did not work. :(

    Any other suggestions?

    Sunday, January 25, 2009 11:21 PM