none
Windows 7 Burn ISO option not available

    Question

  • This isn't a major thing for me, but I'm curious as to why I do not have the option in Windows 7 to burn an ISO?  If I right-click on an ISO file, the option is not there and double-clicking just brings back that there is no application associated with the file extension.  The isoburn.exe is in its proper location. 

    Does anybody know how to enable this option again?

    Any ideas would be appreciated.

    Wednesday, September 23, 2009 9:02 AM

Answers

  • Hi, Digital P:

    I've created a registry file that will restore the default .iso association in Windows 7.

    Copy and paste the following code in Notepad and save the file as "ISO.reg" (WITH QUOTATION MARKS):

    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\.iso]
    @="Windows.IsoFile"
    
    [HKEY_CLASSES_ROOT\Windows.IsoFile]
    @="Disc Image File"
    "FriendlyTypeName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\
      00,6f,00,6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,\
      32,00,5c,00,69,00,73,00,6f,00,62,00,75,00,72,00,6e,00,2e,00,65,00,78,00,65,\
      00,2c,00,2d,00,33,00,35,00,30,00,00,00
    
    [HKEY_CLASSES_ROOT\Windows.IsoFile\DefaultIcon]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
      00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,69,00,73,00,\
      6f,00,62,00,75,00,72,00,6e,00,2e,00,65,00,78,00,65,00,2c,00,2d,00,31,00,30,\
      00,31,00,00,00
    
    [HKEY_CLASSES_ROOT\Windows.IsoFile\shell]
    
    [HKEY_CLASSES_ROOT\Windows.IsoFile\shell\burn]
    "MUIVerb"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,\
      6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,\
      00,69,00,73,00,6f,00,62,00,75,00,72,00,6e,00,2e,00,65,00,78,00,65,00,2c,00,\
      2d,00,33,00,35,00,31,00,00,00
    
    [HKEY_CLASSES_ROOT\Windows.IsoFile\shell\burn\command]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
      00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,69,00,73,00,\
      6f,00,62,00,75,00,72,00,6e,00,2e,00,65,00,78,00,65,00,20,00,22,00,25,00,31,\
      00,22,00,00,00
    
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.iso\UserChoice]

    Hope this helps.


    Microsoft MVP Windows Desktop Experience
    • Marked as answer by Digital P Wednesday, September 23, 2009 5:31 PM
    Wednesday, September 23, 2009 2:26 PM
    Answerer

All replies

  • Hi, Digital P:

    I've created a registry file that will restore the default .iso association in Windows 7.

    Copy and paste the following code in Notepad and save the file as "ISO.reg" (WITH QUOTATION MARKS):

    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\.iso]
    @="Windows.IsoFile"
    
    [HKEY_CLASSES_ROOT\Windows.IsoFile]
    @="Disc Image File"
    "FriendlyTypeName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\
      00,6f,00,6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,\
      32,00,5c,00,69,00,73,00,6f,00,62,00,75,00,72,00,6e,00,2e,00,65,00,78,00,65,\
      00,2c,00,2d,00,33,00,35,00,30,00,00,00
    
    [HKEY_CLASSES_ROOT\Windows.IsoFile\DefaultIcon]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
      00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,69,00,73,00,\
      6f,00,62,00,75,00,72,00,6e,00,2e,00,65,00,78,00,65,00,2c,00,2d,00,31,00,30,\
      00,31,00,00,00
    
    [HKEY_CLASSES_ROOT\Windows.IsoFile\shell]
    
    [HKEY_CLASSES_ROOT\Windows.IsoFile\shell\burn]
    "MUIVerb"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,\
      6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,\
      00,69,00,73,00,6f,00,62,00,75,00,72,00,6e,00,2e,00,65,00,78,00,65,00,2c,00,\
      2d,00,33,00,35,00,31,00,00,00
    
    [HKEY_CLASSES_ROOT\Windows.IsoFile\shell\burn\command]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
      00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,69,00,73,00,\
      6f,00,62,00,75,00,72,00,6e,00,2e,00,65,00,78,00,65,00,20,00,22,00,25,00,31,\
      00,22,00,00,00
    
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.iso\UserChoice]

    Hope this helps.


    Microsoft MVP Windows Desktop Experience
    • Marked as answer by Digital P Wednesday, September 23, 2009 5:31 PM
    Wednesday, September 23, 2009 2:26 PM
    Answerer
  • Thanks!  That fixed the issue.

    I was testing a burning program and I didn't test the basic Windows' functionality after the uninstall.  It obviously left certain extensions without any file associations. 

    I really appreciate the help.  Thanks again!
    Wednesday, September 23, 2009 5:34 PM
  • You're welcome.
    Microsoft MVP Windows Desktop Experience
    Wednesday, September 23, 2009 8:40 PM
    Answerer
  • Thanks for this, saved me some time. For me I assume this was caused by uninstalling a third-party application that I had previously associated the .iso file type with.
    Wednesday, March 31, 2010 5:03 PM
  • This happened on 2 of my Windows 7 Ultimate (x86) installations. I think its a bug in the installer in ultimate, because all my installations of ultimate 6+ for clients and on my personal machine do not have the file association or the Burn files to disc option. Someone should let Microsoft know.
    Tuesday, April 13, 2010 5:16 PM
  • Great, worked perfectly, thanks very much for that!
    Saturday, January 22, 2011 2:30 PM
  • Thanks a million!  This also happened to me.  Win 7 Pro.
    Sunday, February 27, 2011 3:56 PM
  • Worked! nice one.

     

    Win 7 Pro SP1

     

    />L

    Tuesday, September 20, 2011 6:21 PM
  • This worked for me as well. Thanks very much.

    But I still don't understand why Burn option was not available by default? Can it be a installation issue?

    Wednesday, March 21, 2012 1:45 PM
  • SPOT ON!!!!

    This re-added the option for me aswell. :D

    • Proposed as answer by Amitsaxena_it Thursday, September 13, 2012 7:45 AM
    Friday, June 15, 2012 9:42 AM
  • Found this after doing a quick search after having the same problem. Worked a treat.
    Sunday, September 16, 2012 1:46 PM
  • Thank You Very Much!
    Friday, October 05, 2012 8:25 PM
  • Where would you save this document?

    I copy and paste your script on notepad and save it as reg on my desktop. I then went back on it and click on it but is giving me an error. Is there a specific place we should put the doc? Thanks.

    Saturday, October 13, 2012 2:21 PM
  • An easy fix is to go to

    Control Panel > Default Programs > Set your default programs > Windows Disc Image Burner

    Select 'Choose defaults for this program' at bottom of page, then recheck boxes for .iso and img.

    Click Save and changes are immediate. No reboot required.

    Thursday, October 31, 2013 10:29 PM
  • An easy fix is to go to

    Control Panel > Default Programs > Set your default programs > Windows Disc Image Burner

    Select 'Choose defaults for this program' at bottom of page, then recheck boxes for .iso and img.

    Click Save and changes are immediate. No reboot required.

    This is the best solution.
    Saturday, August 09, 2014 10:13 PM
  • My association is with a CDBunerXP, and wish to keep that way. My workaround is right click > Open with > Choose default program. At this point you should have the option of choosing Windows Disc Image and selecting Always use the selected program to this kind of file. Or, not making it permanent by unchecking the box. 
    Tuesday, September 09, 2014 2:46 AM