SimpleTech (Hitachi) USB disk won't work on Windows 7 x64 system


  • I'm having a problem with a SimpleTech 2 TB USB hard disk part number 96300-41001-305. I have a freshly installed copy of Windows 7 Ultimate on a Dell Optiplex 755 computer with 4GB RAM and an ATI Fire display adapter. I was able to use the drive to install files on the computer initially but it stopped working after a few reboots. Here's what I've found so far:

    The drive works on a different Windows XP Pro system.

    The drive works on a Dell Inspiron with Windows 7 Home Premium (32 bit)

    The drive works on the target system if I boot Win PE.

    Other USB devices, including a differend USB hard disk drive, work correctly on the target computer in the same or any other USB port under Windows 7 x64.

    This drive has some sort of power management capability in which the drive spins down if the computer is shut down or sleeping. There is a light on the front of the drive that comes on when the drive is up and blinks when reading or writing data. On the XP system or the target system under Win PE the light stays on all the time while the computer is in use.  Under Windows 7 the light comes on then toggles off and on in a several minute cycle. This appears to be as Windows makes additional attempts to read the drive but that may be an incorrect conclusion on my part.

    When the drive is plugged in to the target computer the "chime" is heard after a longer than normal delay. The drive does eventually appear in Device Manager as a Hitachi drive and is shown as working. Eventually the "drive needs to be formtted" window pops up but attempts to format fail. The driver is a Microsoft driver and is reported as up to date if you try to update it. All of the USB drivers are also up to date. All Microsoft updates have been installed but there is some chance that the drive stopped working after one of these updates.

    The drive does not ever appear in the Disk Management MMC plug in. I've tried uninstalling several times with no success. I also tried running through a USB hub with no better luck althouth the symptoms changed slighty with a pop up message indicating "parameter error".

    On SimpleTech's recommendation I updated the chipset drivers to the latest Intel supplied drivers replacing the drivers supplied by Microsoft with Windows 7. The symptoms remain the same. The drive still fails to work when Windows 7 Ultimate x64 is running. All other USB devices are still working on the same machine. SimpleTech tech support and they had no suggestions other than to replace the drive under warranty. Since at least one other person appears to have a similar problem I'm suspicious that there mey be some hardware incompatability with this drive and the driver in Windows 7. A replacment may not work any better. I am debating whether I should send the drive in for an exchange, but that could take up to two weeks and it works normally on other systems.

    Does anyone have any more troubleshooting ideas on this?

    • Edited by Bill Staehle Monday, June 28, 2010 8:25 PM typos
    Monday, June 28, 2010 8:23 PM

All replies

  • Since nobody had any suggestions I did return the drive to Hitachi on RMA. It appears that they must know there is a problem with this hardware because they returned a completely different unit, a 4 TB, 2 drive unit that runs either RAID 1 or RAID 0 and also has Firewire and ESATA interfaces. There was, however, no explanation from them. The new drive seems to be working fine on the Win 7 64 system. 
    Tuesday, August 03, 2010 12:09 AM
  • I have the same problem with a SimpleTech external HD. Hitachi recommended that I reformat the drive using Win 7. However, I need to get everything transferred so that I don't loose my files.
    Wednesday, August 24, 2011 5:52 PM
  • Just try another USB port... make sure it is a usb2.0 + port.

    That resolved both the recognition and format prompts for me.

    The funny thing is, after using it in one port successfully, it works on any port after that.


    Thursday, January 10, 2013 4:34 PM