Med-V Error at "Initializing Communication With the Workspace"


  • Hello,


    I am having a problem setting up MED-V in my environment.  I set up my MED-V server (actually reinstalled it too) and everything seems to be working on that side of things but when I download an image from the server it will hang on "Initializing communication with the workspace".   It will run all the way through my setup script (because sysprep was ran on the image) which includes renaming the workstation, joining the domain and disabling auto logon but then when it tries to acctually start it will hang.  I have actually left it running from 3pm-9am (18 hrs) and it has eventually errored out and said something about a failed handshake. 

    Along with this test I also created another test that did not join the domain or anything (users would just logon) and I am getting the same error.

    If anyone can help out it would be greatly appreciated.


    Gerad Bottorff

    Tuesday, May 18, 2010 4:35 PM

All replies

  • Gerad,

    Three quick questions to begin:

    1. Did the workstation actually join the domain?

    2. Can you check the IP address on the client, to make sure that was set properly?

    3. Did you perform the communications (ping) testing?



    Wednesday, May 19, 2010 3:47 PM
  • I, too, am seeing this problem.  The details in the Workspace Setup dialog are as follows:

    Importing the workspace image, Verifying system requirements, Preparing for Workspace setup, Renaming workspace, Restarting Windows in Workspace, Joining domain 'my.domain', Disabling Windows auto-logon, Restarting Windows to complete Workspace setup, Initializing the Workspace, Initializing communication with Workspace.

    Time from workspace startup to Initializing communication: 17 minutes

    Time Initializing communications has been running: 22 minutes and counting

    Opening Diagnostics and Enabling diagnostic mode shows the XP startup screen hung at Applying your personal settings.

    I have verified the virtual machine has joined the domain in the correct OU specified in the MED-V script editor.  Active Directory reports the correct operating system and service pack level.  The VM network is configured for NAT and using the host's DNS servers.  All this worked in proof of concept.  Now ready to put into production and this is kind of ruining my day. :(

    TIA for all comments and suggestions,



    Thursday, May 20, 2010 2:54 PM
  • 1.) Disable Slow Link Detection inside of image


    For Windows 7 Hosts:



    2.) Also force Kerberos over TCP in the guest OS. Use the registry setting in this article: KB 244474

    Often a network trace will reveal existing connections especially if the share you are trying to connect to is also a domain controller. With SMB direct hosting, when a new connection is established to a server, the server checks for previous connections from the same client IP address and deletes any previous connections. Because NAT acts as a proxy for the SMB protocol by using the same IP address from the two client connection requests, the earlier connection is terminated.


    Thursday, September 09, 2010 4:32 PM