Easy print won't show up


  • Easy print not showing up between 2 Win 7 systems. I've read tons of tech notes and posts and double checked requirements but I cannot get printers to redirect with Easy print. This is in prep for workers at home using RDP to their office systems. I have here two systems to test.

    Both Win7 Pro SP1, up to date. Each has a couple of Brother printers set up that all use different drivers, so they don't just redirect by using the actual driver.

    I have access to a cloud server that I can RDP into from either of these W7 systems and all printers show up and show as using Easy print as the driver. 

    When I try to RDP from one W7 station to the other the printers don't redirect and event log shows it didn't have a driver for these.

    Local Policy settings for RDP printer redirection are default, no set, meaning "don't redirect" is not enabled. Obviously I have things set in the RDP client itself or I wouldn't see my printers redirected when I go to the cloud.

    MS docs say a W7SP1 system already has .NET3.5 and RDP 6.1, and I've checked RDP. And they say W7 to W7 meets all requirements (

    So what the heck else does it want?

    Oh, and it works fine going from either of these W7 systems as client to a W8 system as host.

    • Edited by Njem2 Sunday, January 27, 2013 4:01 PM
    Saturday, January 26, 2013 9:44 PM

All replies

  • Hi,

    I'm trying to involve someone familiar with this topic to further look at this issue. There might be some time delay.

    Appreciate your patience.

    Tracy Cai

    TechNet Community Support

    Tuesday, January 29, 2013 8:08 AM
  • Hi,

    Please refer to the best practice and general troubleshooting steps in the following articles:

    Using Remote Desktop Easy Print in Windows 7 and Windows Server 2008 R2

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, January 30, 2013 11:17 AM
  • Ruby,

    Yes, those are some of the docs and troubleshooting I've done, as well as some 3rd party blogs and numerous posts on these forums. I feel like I've become a near expert on a topic I never wanted to. As noted it works going to one cloud server I have access to, and going to a W8 system so the clients are all set. To my knowledge the only setting that should be able to block a W7 system as host from providing Easy Print is the local policy settings on printer redirection and choosing Easy Print and those are both set to allow. The EP driver is one of the print server drivers available. What else is there that could block a W7 system as host from allowing it? By the way printer redirection does work. The one printer that the host has a driver for gets redirected with the native driver. All the other printers show in event log as no driver found/

    • Edited by Njem2 Thursday, January 31, 2013 7:16 PM
    Wednesday, January 30, 2013 6:01 PM
  • Tracy or Ruby, I'm still banging away on this. Any other ideas of what could get in the way?
    Friday, February 01, 2013 5:18 PM
  • Tracy or Ruby, I'm still banging away on this. Any other ideas of what could get in the way?
    Friday, February 01, 2013 5:19 PM
  • Hi,

    Based on my experience, the issue could be mostly caused by printer redirection configuration. Please perform the following general checking operation to narrow down the issue:
     1. On the problematic client
    Please confirm that we have allowed to use the printer in RDP session under local resource when connecting to the Remote Desktop Server in Remote Desktop Connection/Local Resources/Local devices and Resources/Check Printers.

    2. On the Remote Desktop Server
    Please make sure that we have not disabled the printer redirection via RDP-Tcp Properties via: Start->Administrative Tools->Remote Desktop Services->Remote Desktop Session Host Configuration.
    Then double click RDP-Tcp. Make sure we did not disable printer redirection
    3. Make sure that we have not enabled the following group policy settings:
    Computer Configuration->Administrative Templates->Windows Components->Remote Desktop Services-> Remote Desktop Session Host->Printer Redirection->Do not allow client printer redirection
    By default, these settings are configured to allow client printer being redirected except that we have manually set them. This GP is corresponding to registry key HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\DisableCpm
    4. Make sure that we have checked the following settings:
    Logged on to Domain Controller and checked User Properties –Environment.Check if check box "Connect client printers at logon" has been checked
    After checking that, if the issue still persists, please make sure that the corresponding printer driver has been installed on the server. Then check the issue again.
    Note: If the client and server are cross architecture, please make sure that the driver name is the same.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, February 07, 2013 1:18 PM
  • Ruby,

    I was waiting to have a clean, new W7 system to try, which I have now. 

    Thanks for your previous suggestions. Most of the issues listed have to do with a failure of printer redirection. I don't have that problem. Printers that the RD host recognizes get redirected, like XPS document printer and one HP it happens to have the driver for do get redirected. The last suggestion is to make sure the RD host has the drivers for the printers, but that's the whole idea here is to have them recognized via EasyPrint and not need all those other drivers installed.

    So on this brand new W7 system I remote into it and get the same result, printers fail to redirect that don't have drivers, and even the ones that do redirect are not using EasyPrint driver. As a new W7 system it of course has current RDP software, .NET 3.x, and the local policies are default which should allow for EasyPrint to engage. The only thing I had to setup was to add the EasyPrint driver to the ones the print server had in its active list. 

    So, this just ain't working as documented by MS. Now what?


    Just to clarify the picture. I have 2 systems with different set ups of W7 but they give the same results so I'll just call them W7. I have one W8 system. I have access to a 2008 server. Here's what they do:

    W7 client -> server: EasyPrint works (note this means the W7 systems will work as clients)

    W8 -> server: EP works

    W7 -> W8: EP works (note this means PC-to-PC can work and I know how to set it up.)

    W7 -> W7: EP doesn't work

    W8 -> W7: EP doesn't work


    addition 2-13


    I tried a number of other W7 to W7 setups today. Also spent about 1.25hr bouncing around among MS support groups on the phone and never got anyone who could even comprehend what the problem was. 

    It may be that MS never really had W7 set up to HOST EP, just use it as a client. I hope that's wrong. This is a non-profit and I'm going to have a bunch of volunteers from home working remotely and I can't possibly deal with all their printer needs in a timely way. MS docs say this should work and I'd like to see them get it to work. Same question. What now?

    • Edited by Njem2 Thursday, February 14, 2013 1:04 AM
    Tuesday, February 12, 2013 10:20 PM