Stuck at "Restoring your previous version of windows" after latest Windows 10 update RRS feed

  • Question

  • Windows 10 Home with latest patches, received an update (looked a lot like the original Windows 10 update, "Prepare for the latest version of Windows features yadda,yadda,yadda) over the weekend and on reboot it gets stuck in "Restoring your previous version of windows".

    Couldn't get into safe mode, booted off a Windows 10 recovery USB and can access the windows install drive no problem, chkdsk returns no errors, tried to do an offline SFC but I get "Windows Resource Protection could not start the repair service" (does this require an actual running windows environment now? ugh gross), troubleshooting recovery and restore options don't have any snapshots or images available. Tried running a repair install but apparently that needs to be run from a loaded windows system also.

    Any ideas? Places I can look for logs for upgrade failures? Any way to actually rollback versions?


    Wednesday, May 31, 2017 9:53 PM

All replies

  • Hi,

    I want to confirm that did the issue occur before? Have you made any changes before the issue occurred?

    First of all, we could try turning it on in clean boot with networking first, then try restart the update.

    Windows updates and service packs may fail to install if there are corruption errors. For example, an update might not install if a system file is damaged. The DISM or System Update Readiness tool may help you to fix some Windows corruption errors.

    Try fixing Windows Update errors by using the DISM or System Update Readiness tool:


    To automatically reset Windows Update components, run the appropriate Windows Update diagnostic, and then follow the on-screen instruction.

    How do I reset Windows Update components?


    For more about windows update issue, this articles can also help you.

    Windows Update: FAQ


    Best Regards,


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 1, 2017 4:22 AM
  • It has not happened before.

    I cannot get the system to boot at all, immediately goes to "Restoring your previous version of windows" even when smashing F8.

    I can access the file system when booting from a Windows 10 installer USB.

    Is there any steps I can take from the perspective of an offline file system?

    Thursday, June 1, 2017 2:31 PM