none
Can only print to print server as admin RRS feed

  • Question

  • Hi, I'm running an 08R2 print server. I have the printers installed with drivers from the manufacturer (WHQL), and I have both x86 and x64 drivers installed. I've set the print processor to 'winprint'. I can print successfully from the server.

    When I send a print job from an XP 32-bit client, the user has to be an administrator for the job to complete (all domain users, client & server on domain).

    When a non-admin tries to print, an error appears in the Roles -> Print & Document Services error log: Event ID 372 - Win32 error code returned by the print processor: 5. Access is denied.

    I've given "everyone" "full control" of C:\Windows\System32\spool, afterwards, the error sometimes appears as code 126: the specified module could not be found. I've tried googling, but haven't found much success.

    Does anyone have any tips? Thanks!

    Wednesday, August 10, 2011 6:49 PM

All replies

  • Could really use some pointers if anyone out there has any! :)
    Friday, August 12, 2011 2:35 PM
  • Bump
    Monday, August 15, 2011 8:15 PM
  • Since you are getting access denied to the print processor, and you setup the print processor as winprint, does the Domain Users have read access to C:\Windows\System32\spool\prtprocs and all the subdirectories?

    If that still returns error 5 it's possible the driver is writing to a restricted area on the disk.  You can use process monitor to determine the writes and where you are getting access denied. 

    I would setup a compatible driver included in windows until you determine where the failure is so your users can perform basic printing to the device.

    Which device?


    Alan Morris Windows Printing Team
    Tuesday, August 16, 2011 6:54 PM
    Answerer
  • Hey Alan, thanks for your reply!

    To answer your questions, I've given "everyone" "full control" over "C:\Windows\System32\spool\", and replaced child object permissions.

    Interestingly, I'm seeing more of the Error 126 - The specified module could not be found.

    I ran procmon, and I found a handful of circumstances where something was denied access. I modified permissions on the affected files, and the "Access Denied" errors disappeared. But the print jobs still fail with Error 126.

    The affected devices include an HP printer using the HP Universal driver, and a Xerox printer using the Xerox global driver. It's only appearing on Windows XP clients. Windows 7 clients seem to print without any problems to these affected printers. Additionally, only some user accounts are encountering these errors. UserA can't print to the Xerox, but UserB can.

    In the meantime, I've manually installed the printers on these devices via IP ports. But obviously, there's quite a bit more overhead with that approach.


    Tuesday, August 16, 2011 7:49 PM
  • It sounds like the the XP machines do not have the print processor installed.  The HP and Xerox drivers are package aware drivers.  The driver package contains the print processor file from the vendor (and any other files needed by the driver).  Windows 7 can install the package driver so the print processor gets installed.  XP was developed before the implementation of package drivers so will only pickup the files exposed in Legacy mode driver installation.  If you install the driver onto the XP machine first, (yes you will need to do this as admin) then log onto the machine as user and create a connection to the share, will this work?

    You could also force rendering on the XP client by unchecking Enable advanced printing features on the Advanced Tab of the shared printer, but you may lose some of the functions included in the print processor.

     


    Alan Morris Windows Printing Team
    • Marked as answer by JosephFisher Wednesday, August 17, 2011 12:58 PM
    • Unmarked as answer by JosephFisher Friday, September 9, 2011 2:20 PM
    Tuesday, August 16, 2011 10:48 PM
    Answerer
  • Well this problem resurfaced today. A couple Windows 7 clients are now unable to print. They are trying to print to an HP printer using the HP universal driver and have been set to use the Winprint print processor instead of HP's. Again, googling turns up next to nothing (and now this thread sits atop the results, heh).

    The error I'm receiving is "Win32 error code returned by the print processor: 126. The specified module could not be found."

    Most of my computers/printers work fine, though. Right now, this problem is localized to only a few workstations. The workstations are frozen with DeepFreeze, though, so nothing should have changed on them in the last few weeks.


    Friday, September 9, 2011 2:22 PM
  • Delete the connections and readd if you have made queue configuration changes since taking the snapshots.

    If the printer is COLOR, check that the color profile files exist usually under

    C:\Windows\System32\spool\drivers\color

    normally specified in the printer definitions or by the driver.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers\PRINTERNAME\CopyFiles

    The next exhausting task is determing the file set the driver uses.  HP typically writes the driver with 50+ files

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments

    I assume there was a reason to change to winprint, but did these problems exist prior to that change?


    Alan Morris Windows Printing Team
    Friday, September 9, 2011 5:10 PM
    Answerer