Fujitsu Lifebook T1010 Tablet Buttons no longer work in Win7 Ultimate


  • I bought a refurbished T1010, which I love. Everything worked great until I upgraded to Win 7. Now the tablet buttons dont work, autorotate doesnt work, and I cant figure out any other way to get my screen to switch from landscape to portrait. I've seen that other Fujitsus have this problem with Win 7. I tried downloading the Vista button drivers and button utility from the fujitsu website, but that didnt work. I've seen that in some other Fujitsus, theres a super secret order to use when installing drivers, that much like the Konami Code, gives you 99 lives and makes all the buttons work. 

    If anyone has a step by step solution for my stupidity, that'd be way super awesome!

    Does anyone think getting a different version/update of Win 7 would be helpful?
    Friday, September 24, 2010 2:30 AM

All replies

  • Hi,


    Try downloading the drivers and software for Windows 7 from Fujitsu driver download site to see if the issue can be resolved.


    If the issue persists, you can contact Fujitsu Support directly to confirm if this is a known issue.


    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, September 27, 2010 8:07 AM
  • Yes, I tried using the drivers on their site. First I tried the Windows 7 drivers, they didn't work. Then I tried the VIsta drivers, they didn't work. Then I called Fujitsu support. They had me try all that again, didn't work. Then they said the best thing I could do was to reinstall Windows Vista using the cd that came with my computer :(


    While doing some internet research, there was another model of Fujitsu computer, the Lifebook U810 and 1010 that had the same problem. Someone found the fix by installing and uninstalling and reinstalling specific drivers in a specific order. Do you know anything about something like this?

    Scroll down to the 6th post.


    Wednesday, September 29, 2010 12:11 AM
  • Click Start=>Control Panel=>Programs=>under Programs and Features select Turn Windows Features on or off. Then scroll down and confirm that the Tablet PC features category folder is checked. If yes, click on the folder and confirm all of the features are checked. Select OK.

    Fujitsu does have Windows 7 drivers, updates and utiliites for the T1010.

    The "magic sequence" typically would be

    1. BIOS

    2. Chipset

    3. Video Adapter

    4. Ethernet Nic

    5. Button controls\drivers(try the system extension driver and then utility here, before others)

    6. Audio

    7. Modem

    8. Wireless Nic

    9. Touchscreen, Touchpad, keyboard, mouse

    10. Other devices, no specific order

    That's a reference that I have used, nothing official.

    Any success?

    Thursday, September 30, 2010 11:40 AM
  • Do I need to uninstall the drivers before reinstalling them? How do I get Windows 7 to let me install a Vista driver? When I try to do it, it tells me somethng like "No change was made because the driver was not better than the one already installed" or something like that.

    BTW i just checked and the Tablet PC features are checked, thanks for that.

    Thursday, October 07, 2010 10:04 PM
  • The message actually says "The device driver installation wizard did not update any of your software for your hardware devices because it was not better than the software you currently have installed."
    Thursday, October 07, 2010 10:06 PM
  • Just try the button drivers and button utilities first. Everything is here for Windows 7, no reason it shouldn't work. No need for Vista. Notebook PC=>T Series=>T1010   Windows 7 32 or 64-bit

    Friday, October 08, 2010 12:57 AM
  • Yeah I tried the WINDOWS 7 button drivers and button utilities and they didnt work. SO i then tried the Vitsa ones, and they wouldn't install because "The device driver installation wizard did not update any of your software for your hardware devices because it was not better than the software you currently have installed."
    Sunday, October 10, 2010 3:07 AM
  • But Windows 7 is so awesome!!! Its fast and super reliable, never crashes... why does God hate me so? :(
    Monday, October 11, 2010 9:57 AM
  • perhaps it's time to try the Fujitsu Driver Update Client from the Windows 7 downloads. That should connect to Fujitsu and find what is missing.

    Monday, October 11, 2010 11:19 AM