Can no longer see NAS icon in Network Folder - Can not read or write files


  • A few days ago on my main PC, the NAS (server name) icon dissappeared from the windows network folder, and I can no longer read or write access files on the NAS.

    I connect via a Huawei 3G wireless router.

    It was working OK before and I have not changed anything.

    Have tried the \\servername\folder method, and also the IP address method and all fail saying "windows can not access \\[serverename]\[foldername]"

    The NAS does not show up when I try to map a network drive. The following troubleshooting has been done...

    1. On this PC, I can see other PCs on the network and DO show the icon for those, but can not connect to them with the same error.
    2. If I connect my laptop, wired or wireless through the router it can access the NAS and read/write as normal. The NAS shows in the network folder as normal.
    3. On the problem PC, I can see the domain for the NAS in my network folder, and I can access the NAS to log in for settings etc.
    4. I thought it might be the ethernet port hardware fault on the PC, but I can see other computers on the network and surf the net.
    5. I have swapped network cables and ports on the router with different ones but still the problem persists with my main PC.
    5. I can ping to the NAS using the IP address set up as virtual server in the router.
    6. I have uninstalled Norton internet security and still have the problem. Currently no 3rd party securioty or antivirus is installed. Still a problem
    7. Windows network troubleshooter fails...I get the foillowing:-

    "A problem is preventing the troublshooter from running"
    Package ID: NetworkDiagnosticsFileShare
    Path: c:\windows\diagnostics\system\networking
    Error Code: 0x80070426
    Source: engine
    User: [computername]\[username]
    Context: Restricted

    8. All users on the PC have the same problem
    9. All users are administrators

    10. File and print sharing is turned on
    11. Network discovery is turned on 
    12. I have created new test user, and still have problem with that user 

    Can anyone help how to resolve

    I use Windows 7 Home Premium

    Friday, April 06, 2012 12:01 AM