none
Turn Windows Features On or Off Box is Empty

    Question

  • So last week, i purchased Sony Vegas HD Version 10. Needless to say it wouldnt install beacuse it needs to have .net Framework 3.5. So i took the liberty of downloading .net framework 3.5.

    While i was installing, an error box appeared saying that i needed to uncheck or check the .net framework box under "Turn Windows Features On or Off" under Control Panel, I then attempted to open the "Turn Windows Features On and Off." After watching the "Please wait phrase for about 30 seconds" that later dissapears and the box is blank.

    For the past few days Ive been trying to figure out why that is, some forums are saying that it has to do with the Registry Size Limit (RSL). Needless to say, ive spent days trying to figure out this problem and i do not really want to do anything to mess up my computer until i know exactly what i can do to fix this problem.

    Basically, i need that box to show its contents so that i can install Sony Vegas properly. Help would be greatly appreciated.

    Friday, March 18, 2011 3:59 AM

Answers

All replies

  • Hi,

    please check this KB article:

     

    The "Windows Features" dialog box is empty in Windows 7

    best regards
    André

     


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Friday, March 18, 2011 1:56 PM
  • Yeah that doesn't work in my case. At thi point it look like re-installing Windows 7 and ALL the other apps is all I can do.  Windows 7 is starting to form some ugly habits. I support it for a large company 700+ computers in my office and some of the things that are showing up mean that this old dog needs to learn new tricks.
    Thursday, March 31, 2011 7:10 PM
  • Sorry to hijack your thread but perhaps it will bring it back to life.

    I too have tried the procedures in the link shown above without success.

    I have not received the error code "0x80073712" however - just the Windows Features Turn Windows features on or off dialog box remains blank.

    I have also tried running sfc /scannow /offbootdir=E:\ /offwindir=E:\windows (where E: is my system drive).

    This was run by booting to the Windows 7 DVD repair utility and opening a cmd prompt.

    That utility returned that no corruption was found.

    Rollback does nothing to help.

     

    All I want to do is install IIS 7.

    My computer shop always has the same fix-all response: reinstall windows.

    But since this is the 3rd time I have reinstalled Windows 7 since I have had it, I'm not going to do that. I would rather buy an Apple and start life over.

    Any help would be much appreciated!

    Tuesday, July 12, 2011 1:58 AM
  • I found the answer to my problem after a lot of searching and thought I'd post it here for any others that can't resolve the issue with the "standard" fixes proposed.

    The problem seems to be with the registry and possibly with ArcGIS or Visual Studio adding long lines that cause issues with the registry (I'm not a tech so I will leave it at that).

    Answer found at http://www.sevenforums.com/performance-maintenance/40511-set-registry-size-limit-unlimited.html

    original source seems to be http://forums.esri.com/Thread.asp?c=93&f=1148&t=287391#902480 (thanks Jim!)

    Sven

    • Proposed as answer by SvenFish Friday, August 05, 2011 3:58 AM
    Friday, August 05, 2011 3:58 AM
  • Hi everyone.  I think I found a fix for it which involves installing the Windows System Update readiness tool.  Here is a link for a website I found.

     

    http://www.raymond.cc/blog/archives/2009/03/06/fix-blank-or-empty-list-in-vista-turn-windows-features-on-or-off-optionalfeaturesexe/

    Friday, September 30, 2011 2:50 PM