WD TV Live Media Player Can't See My Windows 7 Computer


  • I have posted this problem in forums strictly related to the WD TV Live player but haven't had any luck.  A few of the forum members think it might be a Microsoft issue so I'm hoping someone can help me.  I got Western Digital involved with the issue and they walked me through very basic troubleshooting steps and weren't very much help.

    I have a WD TV Live player that simply reads any shared folders on a network, automatically lists the computers that have shared files, asks for credentials (if needed) and the player allows me to view the media on my TV.  The product was working great with zero issues until a month or two ago.  For some reason, I now can't see my Windows 7 Ultimate x64 tower that all of my media is hosted on.  None of the folder permissions have changed, a few updates may have been applied to the operating system but nothing major has changed that I know of.  I have verified my network settings, changed them and changed them back but nothing has helped.

    As I mentioned, the list of computers that have shares on the network is automatically created and there isn't a way to manually search for a machine on the player.  The issue that I'm having is that I can't even get my tower to show in the list.  Whether or not I can access the files is a different story because I have to be able to see the machine first.  To troubleshoot this issue, I brought my work laptop home (Windows 7 x64 as well) and shared a folder with some media in it.  Without a problem, the machine was visible and I was able to play the files in the folder.  Every machine that I test with works fine except my tower.

    I just reformatted my tower drive today and installed Windows 7 all over again because I was having some other issues.  I don't have any firewalls on except the standard Windows firewall and I have disabled that to troubleshoot.  Still, the computer does not show in the list on the player.  My Advanced Sharing Settings are as follow:

    • Network Discovery: On
    • File and Printer Sharing: On
    • Public Folder Sharing: Off
    • Media Streaming: Off
    • File Sharing Connections: 128-bit
    • Password Protected Sharing: On
    • HomeGroup Connections: Use user accounts and passwords to connect to other computers

    The settings above are exactly what I had set before when everything was working.  Media Streaming doesn't need to be enabled because I'm not using my tower as a media server; this is a simple file sharing issue.  I prefer to keep Password Protected Sharing enabled to keep my files protected as much as possible.

    Does anyone have a clue what might be the issue?  The shared folders on my tower are completely visible on other computers in the network.  I honestly don't think accessing the files will be a problem but I need the machine to be listed first.  Any help is appreciated!

    Monday, August 02, 2010 1:35 AM

All replies

  • Hi,


    I would like to confirm that can you access the shared files on Windows 7 tower from the Windows 7 laptop?


    You may refer to WD website, download and install the software or firmware update for the WD TV Live HD Media Player.


    Note: The third-party products discussed here are manufactured by companies that are independent of Microsoft. We make no warranty, implied or otherwise, regarding these products' performance or reliability.


    If it does not work, I also would like to suggest you try the following steps to share the media files.


    Check the NTFS and sharing permissions


    1.     Right click on the folder you want to share and click “Properties”.

    2.     Click the “Security” tab and “Edit” button.

    3.     Click “Add” button, type “Everyone” and click “Check Name” and “OK” button.

    4.     Highlight “Everyone”, check “Full Control” for “Allow” and click “OK”.

    5.     Click “Sharing” tab and “Advanced Sharing” button.

    6.     Check “Share this folder” box, click “Permissions” button.

    7.     If “Everyone” is listed, please highlight it and check “Full Control” for “Allow”

    8.     If “Everyone” is not listed, please click “Add” button, type “Everyone” and click “Check Name” and “OK” button.

    9.     After that, please repeat the Step 7.


    If the issue persists, I also would like to suggest you disable Password Protected Sharing and run the following command with elevated privilege to enable the guest account:


    net user guest /active:yes


    Does it work?




    Arthur Li

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 03, 2010 1:41 AM
  • Arthur,

    It's working!!!  I promise you on everything that I already had all of those settings checked.  I could see the shared folder from other computers on the network and access the files just fine but I couldn't even see the computer at all on the media player to get access to the folder.  I already had the most recent firmware on the player and Western Digital wasn't much help at all as I mentioned earlier. 

    This simply proves to never overlook the simple and easy steps, no matter how confident you are.  I clearly goofed on something easy and it made my life complicated.  Thank you very much for your help!

    Thursday, August 05, 2010 1:06 AM
  • I knew it was too good to be true!  Again, nothing has changed on my tower yet I can't see any of its shares on the Western Digital player again.  I have verified that the firmware is up to date on the player, I haven't changed a thing on my tower yet this is happening again.  I'm still running a fresh installation of Windows 7 Ultimate (x64) with hardly any additional programs installed.  Something is changing that is making the visibility of the tower intermittent.  Any ideas?  I'm desperate here.
    Wednesday, August 11, 2010 4:45 AM
  • I've let this one sit for awhile.  Does anybody have any thoughts on this?  Does anybody know what might have caused such a change?  Would this be a driver or firmware issue of some sort?  I'm just trying to think of why this randomly happened.

    This is honestly mind-boggling to me because I don't know how to troubleshoot this issue.  I can see my files from other computers but the WD player is useless to me right now.  I would really love to get this working.  Any help is appreciated!

    Sunday, September 19, 2010 1:03 PM
  • Hi

    I have this problem too, for months my WD live player played great, few probs but overall happy with it.


    Just recently when the new firmware came out now I cannot access all my folders ??

    I never changed ant settings on my computer and can access everything from there but now the WD player will not see all the network folders.


    This sounds very similar to you ? Did you ever get it fixed ??



    Tuesday, December 07, 2010 3:33 AM
  • Same problems as you only recently had to make some changes in order to see my folders again.

    My folders are on my back up drive had to go into advanced settings on Configure ( on the WD back up drive to access the set up ) and make the folders public so the WD drive would see them.


    Strange because it worked perfect before and the settings where read only ?

    Maybe the new firmware ?


    hope this works for you, I could not connect to my folders for about a week until I tried this.

    Thursday, December 09, 2010 1:36 AM
  • Have you checked the workgroup name settings on both the tower and the WD device? They must match, and it is entirely possible for firmware updates to have reset things to defaults.

    • Edited by Sheldon Dyck Wednesday, January 18, 2012 4:50 PM
    Wednesday, January 18, 2012 4:49 PM