none
problem with floppy drive in Win7?

    Question

  • Hi,

    I just set up with a new computer on win7, Unfortunately, I can not get the floppy drive to work. The system recognizes the floppy as Drive A: but when I try to read or write to the floppy the f. drive light turns on and does not go out, and the cursor remains that little circle and never returns. Any ideas what is wrong? the Bios has the floppy set to drive A: and when I check systen info it reports no problem with the floppy and that the controller is enabled.

    Please help.

    I am running a i7 920 (not overclocked) on a Gigabyte EX58-UD5 with 6 GB RAM under Win7 RC

    thanks

    PS I checked to see if the cable is loose - and found it is well seated.

    Hankman
    Tuesday, July 28, 2009 8:24 PM

All replies

  • New build, correct? 
    Common build mistake:  installing the floppy cable backwards (we've all done it...) will cause that exact problem. 
    Verify that the 'twisted' end of the cable in plugged in to the drive; 'straight' end to the motherboard.

    And, yes, the system (both at the BIOS and OS level) will 'see' the drive if the cable is reversed; however, it won't work at all, and the drive-activity light will be permanently 'on.'

    HTH,
    Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Tuesday, July 28, 2009 10:40 PM
  • Dude,what are you still doing using Floppy drives in this day and age?Rather move on and get yourself a usb flash drive which you know won't give you any hassles
    Wednesday, July 29, 2009 6:52 AM
  • Hi Chris,

    I am a newby. Can you detail how I look at the cable and tell if the cable is "reversed" and how do I know which end is the "twisted" end  of the cable? I presume one end of the cable is male and the other is female so it can only plug in one way. Do I need to check the connection at both ends of the cable?

    Thanks for the help,

    Hankman
    Sunday, August 02, 2009 3:46 PM
  • I have a flash drive, this is for a lot of old floppies I still have.

    Hankman
    Sunday, August 02, 2009 3:47 PM
  • (@ Tyronzn:  there are still a good many legit uses for a floppy drive.  Creating "F6 floppies" is one; many motherboards still require BIOS flashing from floppy, as well. 
    Please don't troll.)

    hank:
    Check out this build howto.  You're using a standard 'flat' floppy cable, yes?  Scroll down to where he's connecting the floppy drive - see (in this picture) how there's a twist in the cable at one end?  That end goes to the floppy drive.
    If you're using a 'round' floppy cable, and it isn't marked "this end floppy" or "this end motherboard", then swap it end-for-end.
    And, no - both ends are male, and have identical connectors.  It's the pin assignments that change.

    -Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, August 02, 2009 6:18 PM
  •  I know that this is not my discussion, but thanks for posting this info.  I came upon this forum after giving up on using any of my old floppy drives.  I felt certain that my floopy controller was the problem.
    Sunday, August 02, 2009 10:39 PM
  • Check first if your floppy is working with your old operating system. Mine works with my old o/s but not with Windows 7. Seems to be a problem with Windows 7. Found no cure yet. Hope this helps, i.e. isolate hardware problem vis-a-vis software problem.
    Monday, August 17, 2009 4:51 PM
  • I've got a new twist on Windows 7 not reading and/or corrupting floppy drive.   I have purchased and installed Win7 on a New (2 months old) PC that has a New floppy drive.  The first time I used the drive I inserted a disk and opened it up to see what was on it.  Explorer showed files and allowed me to open one for viewing.  I then deleted all files from the disk and attempted to copy other files to the disk at which time I got a device not readable/disk not formatted.  I attempted to format the disk numerous times with no luck.  I used another PC (WinXP) to check/format the disk and again put the disk into the Win7 PC and opened it - showed disk empty (Good).  I then copied some files to the disk, they did copy this time, then closed all windows and reopened explorer to the F. Drv again at which time I could See and Open the files.  HERE'S WHERE THINGS GET FUNKY.    I close explorer window, remove the disk and reinstalled the disk, open explorer to F. Drv and now the disk is EMPTY .  When I try to again copy files to the disk I get the disk not formatted ____ but it will not format the disk and keeps giving a bad media message (I've tried 15 disks).  I figured it was the drive (HW) even though it's new so I obtained another New drive and it did the same thing.  I changed cables 3 times (one cable is new) - NO CHANGE.  I tried an old but good drive - NO CHANGE. 

    Each time I try to read a floppy disk and then try to read the same disk on my WinXP PC I'm told the disk is not formatted.  The disk(s) are good and work as advertised in the XP machine but not with Win7.   

    Kicker - my USB floppy drive works very well with Win7 and no issues.

    Bad drivers?  Any thoughts? 

    Thanks.  
    Saturday, October 31, 2009 11:59 PM
  • Having the same problem with Win7 32 as described by Impala (internal floppy)

    Floppy drive is working fine booting a MSDOS disk created on an old XP laptop, also floppy drive reads fine other floppies not created in Win7.
    Most definitely a W7 driver problem as you can not format/write any floppy in Win7 - the quick format pretends to be successful but it's not. The full format (uncheck quick) fails and consequentially the create DOS disk fails too.

    The problem is fairly famous on the Internet some people suggesting to use the Vista or XP floppy driver - however, it's an unstable "solution"!

    There was no such problem under Vista!

    We, the affected, would really appreciate to get a working driver from Microsoft! It appears the problem affects mostly AMD based systems but there are Intel based problems reported as well.

     
    Thursday, January 07, 2010 11:50 PM
  • I was able to access my USB-connected 3.5" floppy drive by installing XP mode and using the copy of Windows Explorer that is provided in the XP virtual machine.  There is no drag-and-drop but copy and paste work for moving files from Windows 7 into and out of the XP copy of Windows Explorer. 
    Wednesday, May 26, 2010 10:04 PM
  • Various people seem to report issues with formatting floppy disk drives under Windows 7, particularly where it is a USB disk drive.

    In my own instance, it  is particularly worse when trying to format DD disks (720K) - Windows 7 doesn't even offer you the option to format these any more, so that may be linked.

    I am running old emulators under Windows.  When they try to format a disk, they sometimes succeed, but sometimes don't even find the disk in the USB disk drive.

    Windows seems to have the same problem.

    If I remove the USB cable and plug it back in, this sometimes cures the problem, but may take a few goes before it does.

    Any suggestions?

    • Proposed as answer by Ramblin'Dan Friday, September 24, 2010 3:51 PM
    Monday, June 14, 2010 3:52 PM
  • Here is a solution that worked for me:

    http://ramblindan.org/?p=1616

    Update your BIOS...

    Friday, September 24, 2010 3:53 PM
  • You said: " My USB Floppy Drive works well with Windows 7 and no issues " ?

    What manuf. are you using for your USB Floppy Drive.... which brand, model ?

    I have been going crazy trying to find one that will work with Windows 7..... I have an Iomega that is virtually new only used about 9 times, but only works with XP and all other attempts to make it work with Win 7 have been uneventful.  Pls e-mail me and let me know what USB flpy drive you have:  nh19926@yahoo.com

    Thanks,

    NH

    Saturday, October 09, 2010 4:36 PM