Windows 7 SP1 x64 network printer offline


  • I've got a interesting problem within my newly installed windows server 2008 r2 domain. the environment is like this:

    all the servers were installed as windows server 2008 r2 with sp1 already integrated and got patched up to date. after the domain was running just fine and the best practice analyzers got peased i turned towards the clients. all of the clients got installed as windows 7 professional x64 with sp1 already integrated.

    one of the servers has the file and print roles with the latest whql compatible drivers for various models of hp and canon printers.

    everything works fust fine but every two to three days a random windows 7 client insists that the printers on the print server were offline - which is not true, in fact they work just fine. anfter i restart the spooler service on that client it takes some seconds and then - oh wonder! - recognizes that the printers are not offline. until now there were never more than one client at once which had this problem but there were various client in total which had the problem.

    please spare me advices like "update the printer driver" or "install the latest windwos updates" or "make a system restore" because as already stated i have

    • the latest x64 windows server os only recently installed with up to date service pack and updates
    • the latest x64 windows client os only recently installed with up to date service pack and updates
    • the latest whql printer drivers i could get from the vendors

    on a last note: i'm not inclined to disable snmp on the printers to avoid false positives - i'm on the search for the cause so i can fix that problem instead of hiding it.

    thanks in advance

    Wednesday, May 11, 2011 1:09 PM

All replies

  • Hi,

    Please run the printer troubleshooter first and check if it helps.

    I suggest to perform these tests you can try:

    1 Temporally disable firewall on Windows 7

    2 The problem may be caused by the printer change its IP address itself. Please set the IP address of the printer to a static address.  If you add the printer again by browsing the network, the Standard TCP/IP port will only work as long as the printer retains the same IP.  If the print device support DNS or WNS name registration you can add a Standard TCP/IP Port using the hostname rather than a transient IP address for DHCP enabled print devices. 

    3 If the printer changed IP address, go to Devices & Printers --> Printer Properties --> Ports --> Standard TCP/IP Port for your printer --> Configure Port. Then change the IP address where it says “Printer name or IP address” to the new IP address that you found. 


    In addition, sometimes disable SNMP could fix the issue. You can make a try to check if it will avoid the same issue occurs.


    Furthermore, this link may helpful to you:


    Hope that helps.




    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, May 12, 2011 8:52 AM
  • Hey Leo,

    thanks for your advices. unfortunately none of them helped,

    • the troubleshooter didn't find anything
    • all printers have fixed IPs from the beginning
    • the firewall is well configured, but oh well I've tried disabling it too, but to no avail

    let me make one point more clear: up till now it was always one - and only one - random client from over 50 which had the problem. every two or three days it was another client. if the problem is present and i go to devices&printers on an affected client i see all of the network printers offline - the virtual printers for PDF and XPS sometimes too but not every time.

    After i restart the spool service on the affected client everything works again as if nothing ever happened.
    any other ideas i could give a try?


    Friday, May 13, 2011 9:25 AM
  • Hi Dom,


    If restart spool service can solve the problem, I think the issue should related with the driver of printers. If one of the printer’s driver is not compatible with Windows 7, the issue will random occurs.


    So what model of printers did you use? I suggest to remove all drivers of printers on both server and clients, get and make sure the drive is support to Windows 7. And re-deploy these drivers to clients to see the result.





    Leo   Huang


    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, May 13, 2011 9:59 AM
  • Hi Leo,

    as stated in my first post, I already have the latest whql drivers for all of my printers be it the canon ir-adv5030c or one of the hp (color) laser jet models clj3700 / lj4100dtn / P3020 / P2025 / ...

    all in all I've got only two whql drivers in use: one is for the canon ir-adv5030c and the other one is the hp universal whql driver matching all models in question - and I specifically chose the whql drivers over the other versions the vendors offer to avoid any driver problems.

    furthermore i don't think this is driver related at least not exclusively - for if it were the problem would exist only on clients with the malfunctioning driver installed. I have cases where only one of the drivers is installed on a client and not the other and vice versa and cases where both drivers are installed. whatever the case the problem is existent. if it still were a driver problem it would mean that both whql certified drivers had a problem - and i don't believe the whql certification program to be so lax - furthermore both drivers are relatively common and fairly often used so i can't think by any stretch of the imagination that if it were a problem with the driver that i was the only one to have that problem.

    Oh, I almost forgot to note the most irritating fact: I've yet to find a way to reproduce the problem. As of now I was unable to narrow down the problem and isolate the trigger - it just happens

    So Leo, do you have any other options left for me to try before I have to open an support request?


    Sunday, May 15, 2011 6:33 PM
  •  I've yet to find a way to reproduce the problem.

    Hi Dom,


    Did you find a way to reproduce the issue? Could you please describe the steps how to reproduce the issue?


    There’s other test you can try on Windows 7:


    1 Click “Start”

    2 Input print management in Search box and press ‘Enter’

    3 Go to Print Management\Custom Filters\All Drivers

    4 Right click a driver, set driver isolation, isolate it.

    5 Set same option to all drivers


    You can set this configuration on 5~10 of PCs on your domain to see the result.



    Leo   Huang


    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, May 16, 2011 9:25 AM
  • Hi,


    Did your issue solved? Please feel free to give me any update.





    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, May 19, 2011 7:14 AM
  • I am also experiencing the same problem Dominik is.

    Print Servers: Server 2008 R2 with SP1

    Printers: Xerox 7335/7435 with latest PS/PCL drivers available 5.99.11

    Clients: Windows 7 Enterprise x64 with SP1


    Randomly a client running Windows 7 Ent x64 SP1 will have their network printers go 'Offline'. Restarting the local clients printer spooler brings the printers back online. When the printers went 'Offline' I tried adding another printer from the print server that all the printers were offline and I receive Errror 0x00000002. Interestingly enough though when this happens I'm able to add a printer from a different print server. I have noticed that this seems to happen more frequently with users that remote into their Windows 7 machine from another computer. Hope some of the information will help narrow down a culprit. Like Dominik I have been unable to reproduce the issue. Looking through event logs hasn't narrowed down a culprit either.


    Friday, May 20, 2011 11:12 PM
  • Hi Leo,

    I've been out of office for a week of holiday. I will try your last suggestion after I've read into the function you proposed tomorrow morning but as far as I've read on the internet in the last five minutes this is a server option - nothing regarding the client. I'll dig further into the matter tomorrow morning.

    I've yet to find a way to reproduce the problem. When tracking stubborn and persistent problems it is quite easy to get empiric evidence on the culprit - but this one is giving me headaches. Whatever I tried to provoke the problem - nothing helped in a reproductive fashion. In fact I wasn't even able to provoke it at least once. So whenever it happens - it just happens and it still seems to happen on a random client.




    Sunday, May 22, 2011 8:22 PM
  • Hi mrbsl

    Do you also use the office 2010 x64 platform on your clients? What antivirus product/version do you use? I'm trying to collect some similarities in our environments, maybe that helps cracking this hard nut.


    Sunday, May 22, 2011 8:23 PM
  •  I will try your last suggestion after I've read into the function you proposed tomorrow morning  

    Hi Dom,


    Please kindly update the result whatever the last suggestion work or not.


    Thank you.





    Leo   Huang


    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, May 23, 2011 1:57 AM
  • Clients run: Office 2010 x32 (we don't use Office 2010 x64), Microsoft Forefront Endpoint Protection 2010

    Print Server: HP ProLiant DL360 G7, Server 2008 R2 with SP1. We are NOT using group policy to deploy printers. When I first acquainted myself with the the print server I noticed we were setup using WSD ports. I have since moved them to Standard TCP/IP (I did not completely remove the shares and recreate them just pointed them to new TCP/IP port). We use PCL and PS drivers. A majority of the users who have this problem also RDP to their Win7 desktops from other Win7/XP machines.

    Monday, May 23, 2011 8:20 PM
  • Hi Leo. After testing your last suggestion I'm still experiencing the problem, so your last note seems to be inapropiately marked as an answer. Please fix that so others may find this thread more useful. Back to topic: Do you have any other suggestions on how to tackle this problem? Thanks Dom
    Friday, June 03, 2011 8:16 AM
  • Thank you for your update.


    I will escalate this case. Another senior engineer will help you to solve the issue.


    Thank you for your understanding.




    Leo   Huang


    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, June 03, 2011 8:58 AM
  • This used to be an issue with W2k3 that was later fixed. I havent seen much issues with printers offline in w2k8R2
    There is only one other reported case with w2k8R2 that i found where the customer decided to disable SNMP and hence was not investigated further.
    Reading through your notes, you will most likely need to open a support incident to investigate this in detail.

    Before that you can try installing the follwing hotfixes on a client to put the binaries to QFE/LDR and see if the issue goes away.

    Article ID: 981070    "Windows can't open Add Printer" error in a 64-bit version of Win7 or of Windows Server 2008 R2

    Article ID: 2526028   Printing performance decreases in Windows 7 or in Windows Server 2008 R2

    Article ID: 2493115  "Access is denied" error when you try to open the Properties dialog box of a shared printer that is connected to a computer that is running Windows 7 or Windows Server 2008 R2

    Article ID: 2466040  Post-install customization does not start after you use Group Policy to configure a deployed printer in Windows Vista, in Windows 7, in Windows Server 2008, or in Windows Server 2008 R2

    I'd also like to know what is the frequency of the issue within the same machine.

    Do you see a print job failure in eventviewer just before the printers go offline?

    Do you see any other events in event viewer?

    To rule out SNMP, if you disable SNMP on a given box, does the issue reappear in that PC?


    Sumesh P - Microsoft Online Community Support
    Monday, June 06, 2011 4:34 AM
  • Were you able to go through the steps above?


    Sumesh P - Microsoft Online Community Support
    Thursday, June 09, 2011 1:00 PM
  • Hello Sumesh, seems like we experienced this vice vesa: I've never had this problem on my w2k3 boxes. For your questions: 1. I've three notebooks where the problem occured more than once. the time span between two occurances varies alot. on one notebook i had a difference of less than 5 days, another with about 10 days diference and the third had a difference of something short of three weeks. so nothing in common here. 2/3. the eventlog is as clean as it could be 4. I will try disable on a single box - for test purposes only because as is stated initially i do no want to hide the problem, i want to solve it 5. Just to give a complete picture: as suggested by Leo I'be put some drivers in isolation mode on a few boxes - but the problem still exists Thanks so far Dom
    Friday, June 10, 2011 8:59 AM
  • Also try out the hotfixes i mentioned on one of the boxes.


    Sumesh P - Microsoft Online Community Support
    Friday, June 10, 2011 9:23 AM
  • Dom\mrbsl,

    Experiencing the same issue myself.

    Print Servers - Windows 2008 R2

    Printers - Xerox WorkCentre 7556, Xerox Phaser 6500 & HP LaserJet 4515

    Client PC's - Win 7 64bit with Office 32bit

    New virtual Windows 2008 R2 print server, SP1 and patched every month.  The server containers mutliple print queues for HP and Xerox devices, all whql compatible drivers.  Our client machines are Win 7 64bit with Office 2010 32bit (as recommended by Microsoft).  The print queues on our server are pushed via group policy to all client machines.

    On a very small propotion of the win 7 client machines i have witnessed the printer "offline" issue (not at the same time) which is resolved by restarting the print spooler on the client machine.  Like yourself, not been able to work out the cause of this issue or reproduce.  Once the client PC experiences the issue i'm unable to add any other queues from this server.  I am, however, able to add a queue from another print server (same issue as mrbsl).  I have seen this issue both locally and when a user remotes into another machine (queues are fine on their local machine at the time though).

    Interestingly enough, i see a GPO error in the affected client PC's application log when the issue occurs.  Event ID 4098 -  "Group Policy object did not apply because it failed with error code '0x800706ba The RPC server is unavailable.' This error was suppressed."  There is also the following "error" in the "Microsoft-Windows-PrintService/Admin" log.  Event ID 808 - "The print spooler failed to load a plug-in module C:\Windows\system32\spool\DRIVERS\x64\3\UNIDRVUI.DLL, error code 0xc1".

    Keen to understand and resolve this issue - not very efficient running around restarting spooler servers on clients PC's.

    Saturday, June 11, 2011 7:59 PM
  • Can you try the hotfixes listed above?

    Does this happen with all OEM printers or just with specific printers?



    Sumesh P - Microsoft Online Community Support
    Monday, June 13, 2011 9:26 AM
  • Thanks for the information Jaydubya1980. I just had another user experience this. I checked the Event Viewer and found four of the following ERRORS in succession:
    Source: Print Service
    Event ID: 808
    Task Category: Initializing
    Logged 6/14/2011 1:58:37PM to 2:00:13PM
    General: The print spooler failed to load a plug-in module C:\Windows\system32\spool\DRIVERS\x64\3\PS5UI.DLL, error code 0xc1. See the event user data for context information.

    Any other error or warnning logged in PrintService/Admin is three weeks away 05/25/2011. So there may be a connection with that error.

    Tuesday, June 14, 2011 10:44 PM
  • Can you please get me a dump of the spooler when the issue occurs on one of the clients?

    Use the procdump tool with the procdump -ma spoolsv.exe


    You can upload the dumps along with the following details in a zipped format: Event logs, network trace from client when selecting a printer, time of issue, print server name, IP, one or more of printer name showing offline


    Password: @5RKVnm)[aDQw


    I will run a preliminary check on the dumps to see if we can find the cause.


    Sumesh P - Microsoft Online Community Support
    Wednesday, June 15, 2011 6:26 AM
  • Hello Sumesh,

    I've read through the mentioned KB articles and confusingly found that non of 'em addresses the problem I and the others are experiencing. Despite this I requested the fixes and tried to download them. I was only able to download the first one mentioned. Trying to download the other three I only got "HTTP 500 Internal Server Error" messages.

    As for the question of which printers are affected: I do think I've already answered that question. I've various models from HP, Canon and Kyocera Mita. I chose the whql driver for each printer model. As it turned out, the whql printer drivers are universal for all printer models of each vendor so I have three printer drivers in total. As already stated: Until now I was unable to rule out one of the drivers. I have various combinations of printers on the client machines but I have yet to find a driver combination that is not affected by this problem.

    To make the confusion even more complete I seem to have exactly one client where the driver isolation mode seems to work - the other clients still have the problem. I've downloaded the procdump tool and will upload the requested information as soon as the problem reoccurs. Until then I will try to read through some more event logs on other machines. Maybe I can find some similarities that will give us a hint.

    Thanks so far Dominik

    Wednesday, June 15, 2011 11:50 AM
  • Hi Sumesh,

    seems luck is on my side today. the one client which was supposed to function normally again after enabling driver isolation just came back with the error - and presented me the perfect opportunity to collect the infos you requested. I'm assembling them at the moment and will upload them directly afterwards. Hope you can track it down.


    /update: upload is complete

    • Edited by Dominik Gauß Wednesday, June 15, 2011 2:21 PM update
    Wednesday, June 15, 2011 2:06 PM
  • Hello Sumesh,

    were you able to to take a look on the files I've uploaded? Did they give a hint on the problem?



    Tuesday, June 21, 2011 10:50 AM
  • Yes.

    We looked at the spooler dump and see 12 network printers connected to \\CSR|FP0001 with client side ports all in the off-line state with the PRINTER_SERVER_OFFLINE status set. The problem is this snapshot is after the fact so there is no “smoking gun”.  The issue needs more indepth troubleshooting.

    I would request you open a support case because this is going to take some digging.

    Things to investigate during a support incident-
    1. Check the System Log for network disconnections.
    2. A TTT trace (in circular mode) with a Procmon, and netmon trace during the problem would be very beneficial. 3. Check if you have anything in the Admin PrintService Analytical log ? If not, you should  enable the Debug or Operational logs (Actions-> Enable Log) for the Print Service.


    Please visit the below link to see the various paid support options that are available to better meet your needs.;en-us;offerprophone



    Sumesh P - Microsoft Online Community Support
    Tuesday, June 21, 2011 5:10 PM
  • I have the same problem, but maybe a more acute version. I am pretty sure the problem started when I installed SP1 on Windows 7 about one week ago on a virtual machine on my laptop. All network printers are consistently offline. Restarting spooler service returns them online, but only temporarily. After every job I print, they all go back offline. Restarting spooler service restores them all. One of the network printers is a direct TCP port connection. Another goes through a print server (not sure what the server is running). Different makes and models of printers.

    I do have a variant of the error quoted above repeating periodically in my print service error log:

    The print spooler failed to load a plug-in module C:\Windows\system32\spool\DRIVERS\x64\3\UNIDRVUI.DLL, error code 0xc1. See the event user data for context information.

    I do not see any other interesting clues related to network events in the system log.

    Wednesday, July 06, 2011 11:01 PM
  • Can you try this on one of the clients?

    To disable SMB1 client functionality run the following commands:
    sc config lanmanworkstation depend= bowser/mrxsmb20/nsi
    sc config mrxsmb10 start= disabled


    Sumesh P - Microsoft Online Community Support
    Thursday, July 07, 2011 11:19 AM
  • Still having this issue. None of the suggestions above helped. Printers are still randomly going offline for no reason. This is getting really annoying.
    Tuesday, August 02, 2011 12:05 AM
  • We've contacted MS Support about this issue.
    So far we've gone through two action plans but to no avail.
    As soon as I#ve got news I will let you know.


    Tuesday, August 02, 2011 6:59 AM
  • Thanks for keeping us up to date Dominik (I check this thread weekly for updates). I'm am still having this issue crop up from time to time as well (in my case it really seems to show up with individuals that use RDP heavily to remote into their machines from home and lab PCs on a separate network). If I find anything I'll let you guys know.
    Tuesday, August 02, 2011 10:47 PM
  • I've been communicating with Microsoft Support directly as well. Provided several logs and installed various hotfixes, but nothing solid so far. Latest batch of NetMon logs I provided might have something, so I will update this thread if I have anything new.
    Wednesday, August 03, 2011 12:44 AM
  • so far we've installed a dozen hotfixes and patches, submitted dozens of logs and dumps and also had a few remote sessions. so far nothing worked.

    on friday we got another email with with instructions and links to a kernel hotfix. i will let you know whether on not that did the trick.

    -- Dom

    /edit: one thing keeps nagging me: listening to your problem tells me i#m not the only one with this problem and as far as it seems this problem also is NOT linked to a specific printer or printer vendor. this hardens the impression that we're dealing with some kind of internal windows bug. let's see if that kernel hotfix does the trick or if we've gotta dig even deeper
    Monday, August 08, 2011 9:58 AM
  • To people who are experiencing this: What antivirus are you guys running? We're running Sophos and MS reckons that's what might be blocking network traffic to the print server.
    Wednesday, August 10, 2011 1:03 AM
  • We are using Microsoft Forefront Endpoint Protection 2010.
    Thursday, August 18, 2011 4:54 PM
  • Has anyone tried disabling the SNMP status on the print server ports?
    Thursday, August 18, 2011 5:16 PM
  • Also seeing this:
    client: Win 7 enterprise x64 no sp1,
    print server: server 2008r2 (someone else manages the print server so not sure on the patch level)
    printers: Xerox 7435, and large format plotters Xerox 6605 and HP Designjet T1200ps
    drivers: primarily postscript newest version.

    antivirus is SEP 11.0.6300.803
    windows firewall is off, UAC is on
    We aren't using any universal drivers (all model specific)
    don't want to turn off snmp as we run a snmp suite which gives our network team a lot of useful info.

    we also run xp 64bit and it has no problems.

    • Edited by MattH83 Friday, August 19, 2011 10:49 PM added in full sep verison
    Friday, August 19, 2011 10:13 PM
  • Hello Dominik,

    We just started having the exact same problem as everyone else in this forum is having today during our Windows 7/Office 2k10 deployment.  It is really sad Microsoft is having issues with something as simple as printing to network printers.  It is totally unacceptable as well that it has taken them, from what I can tell, over 4 months to address this issue.  Too bad for Microsoft as a company.

    At any rate, I am not sure if this solution might work for you but it is worth a shot.  Check out this tech article and let the group know if you have any success:  This fix work for us today (who knows if this really is a long term fix).  Hopefully this works.


    Tuesday, August 23, 2011 5:36 PM
  • Hi Dom

    We are also having this issue with our Ricoh 1107 printer in our Windows 7, Server 2008R2, Office 2010 environment. so far having tried pretty much all the steps listed above to no avail.

    it's quite annoying knowing the fact that it's not an exclusive problem to anything but the OS.

    A fix at some point would be lovely, until then telling the staff that the printer is online despite saying otherwise is the way forward


    John Miller MCTS
    Friday, August 26, 2011 9:56 AM
  • Hi,

    The solution for an offline error of a printer is to check the proper connection of the printer.

    Two options exist to turn off the offline mode.

    If you choose the first option to change the offline state of the printer, then go to Control Panel and then ‘Printer and Faxes’ option on the Control Panel.

    Double-click on the printer you want to change to online mode from the displayed window.

    A pop-up window will open and you need to select ‘Uncheck Printer Offline‘ option from the menu bar.

    Get more information to fix windows 7 printer offline error :


    Hope this information helps you.



    Monday, August 29, 2011 4:37 AM
  • Hi,

    The solution for an offline error of a printer is to check the proper connection of the printer.

    Two options exist to turn off the offline mode.

    If you choose the first option to change the offline state of the printer, then go to Control Panel and then ‘Printer and Faxes’ option on the Control Panel.

    Double-click on the printer you want to change to online mode from the displayed window.

    A pop-up window will open and you need to select ‘Uncheck Printer Offline‘ option from the menu bar.

    Get more information to fix windows 7 printer offline error :


    Hope this information helps you.



    Monday, August 29, 2011 4:37 AM
  • Hello SophieMartin,


    reading your answer I think you missed the whole topic.

    Don't get me wrong - I don't intent to start a flame war - but your "solution" is as far away from the topic as possible.

    Please try to understand a problem before posting mindless "answers".


    For the rest of the folks interested in the problem:

    we still have no working solution from mircosoft despite working on the fifth or sixth action plan we recieved. As soon as we make any progress i will let you know.


    Have a nice day


    • Proposed as answer by Phil Whittaker Wednesday, August 31, 2011 11:36 PM
    • Unproposed as answer by Phil Whittaker Wednesday, August 31, 2011 11:37 PM
    Tuesday, August 30, 2011 4:06 PM
  • Hi All


    New to this but may have a solution, I have just turned off the SNMP Status enabled tick box in the port properties and my printers are now working again.




    Wednesday, August 31, 2011 11:39 PM
  • Hi Phil,


    thanks for your contribution. Unfortunately that's only a solution if you don't need SNMP.

    If you do need SNMP e.g. for monitoring purposes - there's still no valid solution



    Thursday, September 01, 2011 11:09 AM
  • I was checking out SBMattB's posted link to With a user that has their printers go offline everyday I found entries on our their Windows 7 64-bit machine under HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\ pointing to our old printer server that had been decommissioned nearly a year ago. The user was RDPing to his Windows 7 box from a Windows XP machine that still had old entries under "Printers and Faxes". I removed the old printer entries on the Windows XP box and Windows 7 64-bit box. I'm hoping that somehow those old entries that had been created on the Windows 7 64-bit machine were the cause of the problem. FYI I had already completely rebuilt this user's Windows 7 64-bit box and he was still having printers go offline so I'm hoping this is it. Time will tell. I'll let you guys know.

    • Proposed as answer by Rodjev Friday, September 09, 2011 4:11 PM
    • Unproposed as answer by Rodjev Friday, September 09, 2011 4:11 PM
    Tuesday, September 06, 2011 11:18 PM
  • I have been reading over your posts and let me start off by saying that I trully understand the problem at hand as we experienced this with the Windows 2003R2 server. All attempts to resolve based on MS suggestions failed to render any solution. As a result we rolled that one problem server to Win2008R2 Standard. We made sure that all drivers were Win7 compatible and loaded matching versions of x32 and x64 drivers. For that client the server has been pretty stable for over three months now (knock on wood) with the exception of one Xerox 252 which continued to have the problem This device is one of three 252's in that office so after Xerox reloaded the software that issue has since stopped. That environment is running a trully mixed environment consisting of XP, Vista and Win7 x32 and x64. The server is not running SP1. The way we work is that unless the SP1 renders a true fix, we won't move to it.

    In any case, when we first saw this problem we upgraded the firmware on all printers, attempted to disable snmp (which didn't work), isolated print drivers, checked for unused protocols (IPX/SPX, Appletalk) and turned them off, ran windows updates till there were none left (including the dumb optional ones), reset IP's, set DNS and host names, I mean we dotted every 'I' and crossed every 'T', we even dotted the lower case 'J's...

    We manage well over 300 servers internationally. Only a selected few are virtual servers. By chance, how many of you are running virtual print servers? Not saying that has anything to do with it but I am just curious to know if that may have anything to do with it since the only 2008 server we are having this problem with is a Virtual Machine. All dedicated servers are running fine.

    After reading this I called up the IT from the mixed environment to see if they are running Win7 SP1 and he says that they are but the only problem they've seen is RPC error that Jydubya1980 mentioned above when removing and adding printers through GPO. We have another user that does the same thing with GPO, 2008 server, and no issues.

    Now, on the client side, the workaround seems to be to restart the spooler but what troubles me is that if the spooler failed it wouldn't list any printers in the printers and devices pane. If the spooler isn't hanging I don't see how it pertains to the connection to the server. Perhaps we're targeting the wrong service? Feel free to 'edumacate' me as we are all fighting the same cause...

    BTW any updates from MS since Tuesday?

    One last question, are all of you running on a mixed environment or is anyone of you experiencing this on a full x64 environment?

    One final thought, with the 2003 server there was a registry edit we tried that also failed...haven't tried it with the new server having the problem. When I find the kb article I will share with you all.
    Friday, September 09, 2011 4:52 PM
  • All of our printer servers are running off Hyper-V, we've only experienced it on Win 7 clients, none of which have SP1.


    We've temporarily turned off SNMP and so far it's been ok, but we aren't excited about this "fix".

    Friday, September 09, 2011 7:19 PM
  • After posting we researched the Print Service Event log of some of the users that reported the problem. We found that most of the users reporting the problem have Adobe CS Suite installed. We also found another common entry which refers to CSRImportFailed ErrorCode 800f0247. The enty points to the 7345's driver and cab file. Since this was a common variable we upgraded the driver for this device over the weekend. After running test pages we reviewed the log again and see that the error is still being logged although the spooler has not hung, nor have the printers gone offline.

    On the server, we have the jobs set up to render on the client side. By default SNMP has been disbled. We have not had any printing issues so we will be leaving SNMP disabled. For now all we can do is monitor it.

    On another environment we noticed that Adobe ReaderX caused Adobe conflicts and hung the spooler. Event log would display an application hang error though instead of the spooler. Not ruling this an application issue though since it also happens with Microsoft Office Suite. I am curious to ask if those users within your networks (A) have CS Suite installed (B) reflect any printer driver error logged within EventVWR>Applications and Services>Microsoft>Windows>PrintService>Admin.

    Perhaps we can find a common variable between our networks that lend a helping hand to a solution.

    Monday, September 12, 2011 5:11 PM
  • Hi guys.   Similar issues here.   Just to start - I don't think I've seen a better well written or managed thread in a forum, ever.   Everyone is collaborating, adding their two bits and only a few mindless answers.   I'll try and continue the tradition ...


    Win7 PCs and Laptops, 64-bit, every once and awhile one printer goes 'offline'.   Print Server is Win2008 R2 64-bit SP2 - VM, ESX 4.1.

    We have Lexmarks, both Universal and model specific drivers, and bunch of Sharps, all model specific drivers.   On the print server, there are a number of queues in Offline status - remove the SNMP and they show Ready.   That cures that.  


    But Win7 clients are still randomly getting queues offline.   No events in the Applications and Services>Microsoft>Windows>PrintService>Admin log.  Doesn't seem to affect Win XP users.  


    We run TrendMicro OfficeScan 10.5.   PCI states Firewall needs to be on when off the domain, so we have GPO specifying both Standard and Domain settings for our laptops.

    • Edited by JCinBC Thursday, September 15, 2011 7:01 PM
    Thursday, September 15, 2011 6:58 PM
  • Same problem here with our Windows 7 (x64 and x86) sp1 clients with 2008 R2 server (x64) printers.. at random.. no solutions thus far i take it?
    Wednesday, September 21, 2011 5:01 PM
  • It may be to early to tell but a potential workaround may be the following (it invovles disallowing printer redirection for RDP sessions):

    0. On the machine having printers go offline...

    1. Goto HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\ remove all keys ending with "(redirected #)". Note: on the machines I'm working on all the keys have "(redirected #)" so no keys are left under HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\

    2. Run gpedit.msc. Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Printer Redirection\ "Do not allow client printer redirection" - ENABLE


    *I've had a week go by and three machines I've done this on no longer have printers go offline. If the issue crops up again on one of these machines I'll remove this post as a potential workaround but I figured someone else might want to give this a try too.

    • Proposed as answer by Geenoo Tuesday, April 01, 2014 5:09 PM
    Thursday, September 29, 2011 4:53 PM
  • I haven't had any issues with printers going offline once I disallowed printer redirection for RDP sessions. I still do not know the root cause but sometimes when our users RDP into their Windows 7 64-bit machine and their client printers are mapped during Remote Desktop Services sessions it can cause network printers to a specific print server to all go offline (I have not determined if all network printers from multiple print servers would go offline because our users only use one local print server). When this happens you cannot add another printer from that specific print server or print to any printers from that print server until you restart the printer spooler (interestingly I was able to add printers from another printer server when this happened). I have also not heard of this issue cropping up at other office locations with users that RDP into their Windows 7 64-bit machines. I'll still continue to check in on this thread from time to time.

    • Edited by mrbsl Monday, October 10, 2011 4:00 PM typo
    Monday, October 10, 2011 3:59 PM
  • Thanks for the suggestion mrbsl, I'll give it a go on some of our machines.  We have been leaving redirected printers on and our users remote into machines a fair bit.

    Fingers crossed!


    Tuesday, October 18, 2011 4:32 PM
  • After installing a dozen hotfixes, registry changes and other modifications according to the action plans from microsoft we now have a potential solution.

    We're going to figure out wether a single hotfix may be a stand alone solution for the problem or if the whole bunch of fixes and changes needs to be processed to reach a solution.

    As soon as i reached a conclusion I will let you guys know.


    Thursday, October 20, 2011 9:10 AM
  • Exactly the same problems here. Print queues are reported to go randomly offline. On a server side everything is fine. Print spooler restart on client helps. SNMP is used in print ports. Various print drivers. Hard to debug of reproduce. No common denominator found so far. Problems have started at some point before summer and seem to be on a client side, not server.

    Problematic clients: Windows 7 x64 SP1 (maybe SP0 also; Windows XP x86 have no problems)
    Print Server: Windows Server 2008 x86

    Thank you Dominik for doing the really hard work fighting against the support and not settling for "disable snmp"-solution.

    Mikko Järvinen

    -- Mikko Järvinen Computing Centre University of Turku Finland
    Sunday, October 23, 2011 6:42 PM
  • Great news Dominic,

    Even after turning off SNMP I've still had issues with my site, just maybe less (or maybe I think it's less).

    mrbsl's solution wasn't an option for us in the end.  If you want help with testing hotfix combinations you can list out a couple and I can install them to see if they make an immediate change or not.

    Thanks for your hard work!

    Wednesday, October 26, 2011 5:01 PM
  • Dominik, 


    Thanks for such a great thread. Did you ever find the correct solution to this problem? We have seen the same problems with various Windows 7 SP1 64-bit clients.

    Monday, November 14, 2011 4:57 PM
  • After reading through this thread and other similar ones, I was able to resolve my issue after trying nearly every suggestion posted to no avail (unless you count the cheap and temporary band-aids such as system restore and/or reinstall of printers) - it turns out to be some sort of permissions issue that decides to rear its head at different times on different computers, perhaps after a specific update?

    My environment/Problem: All users on Windows 7 64bit SP1, old print server is Server 2003, new print server is Server 2008R2.  Almost randomly, users would report not being able to print anymore - the easiest resolution for me would be install the printer locally, but this is obviously not ideal.  On my personal computer, I was able to print for months to shared printers on both print servers, but recently all shared printers through both the 20003 server and the 2008r2 server went offline on my computer, although I could still print to any of those printers after installing them locally on my box.

    My fix: I made my user account a local admin on my 2008r2 server and now the printer shared through that server is online and works just fine.  The same printer shared through the 2003 server, however, shows as offline still.  Local admin rights, therefore, provides a satisfactory fix for me.

    This works as a resolution for my company as we can give users local admin rights for our new print server (it's dedicated for this purpose, unlike the 2003 server from which we're slowly migrating away as it did nearly everything at one point), but I'm sure there is a more specific permission that one of you can find to resolve the issue without giving basic users too much power.

    I hope this helps you,


    Friday, November 18, 2011 4:02 PM
  • Having the same exact issue over here.

    AdamD, glad that worked for you, but unfortunately not an option for us.

    Dominik, would really like to hear if you got this resolved with Microsoft?

    Friday, November 18, 2011 8:27 PM
  • I have the same problem with the status of a network printer showing offline after a brief period of time (often within minutes of booting).

    I do not think I have an option of disabling SNMP status as the drive in question is on port USB001 (a virtual printer port for USB) and the  Configure Port is not supported.

    Both machines are running Windows 7 x64 and are connected via a wireless LAN.

    The fault can be cleared (for a period of time that seems variable) by restarting the Print Spooler Service on the client side.

    There are no problems on the server side (i.e. the printer status reads Ready all of the time even when the client shows it as offline).

    I had a Windows2000 system that hosted the same printer and it ran without causing any problem.

    I'm not an IT specialist but it looks strange to me and its just plain sad when 2 machines running the same OS cannot get along.

    Edit: 21/Nov/2011Update    The interval between off-line occurances is variable but it happens frequently (i.e. time interval in minutes not days)

    • Edited by rdreeves Monday, November 21, 2011 8:01 PM
    Saturday, November 19, 2011 11:20 PM
  • Hey guys!

    I've (almost) literally gone through hell and back to track that...BUG(!)...down with the patches, hotfixes and instructions provided from Microsoft wich allowed us to resolve the problem on the one client we used for the case we opened.

    Unfortunately I've not been able to isolate a single setting, patch or hotfix wich would resolve the issue on its own despite all the cominations we've tried.
    At the moment I'm clutching at the last straw before retreating to disabling SNMP. I'll keep you updated on the result.

    As for now, If anyone of you is willing to try out youself here are the steps we've done on the Win7SP1x64 clients:

    1. We installed the following patches in the order listed:
      • Windows6.1-KB981070-v2-x64.msu
      • Windows6.1-KB2462317-v2-x64.msu
      • Windows6.1-KB2480118-x64.msu
      • Windows6.1-KB2493115-x64.msu
      • Windows6.1-KB2494427-x64.msu
      • Windows6.1-KB2526028-x64.msu
      • Windows6.1-KB2254637-x64.msu
      • Windows6.1-KB2444328-v2-x64.msu
      • Windows6.1-KB2465772-x64.msu
      • Windows6.1-KB2534366-x64.msu
    2. We made changes to the TCPIP settings via registry:
      • Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters] "EnableTCPChimney"=dword:00000000 "EnableTCPA"=dword:00000000 "EnableRSS"=dword:00000000

    I'll try to gather the steps we've done on the server within this week for you.

    Good Luck!

    Tuesday, November 22, 2011 6:23 AM
  • Hey Dom!

    Thanks for the post, I'm going to play with those updates and see what I can find. 

    Tuesday, November 22, 2011 10:47 PM
  • Looks that in our case the offline problem may have been caused by an excessive load or amount of network connections on a print server and how SMB2 or RPC connetions on Windows 7 react on that. We've run Microsoft Network Monitor on a client (Windows 7 x64 SP1) and examined the network dump at the time when problem occurs. We have been able to reproduce the problem by launching e.g. Word 2010 and selecting File, Print. Then

    We've also indications that computers with static ip address (non-dynamic) and/or dns-name matching the name of computer account in AD seem to be immune to the problem as well as Windows XP (or SMB1).

    Here's a small part of the dump. Two last rows show 10 second timeout before client makes a new connection. This pattern repeats again after about 30 seconds and then client's printers come back online.

    Date Time Time Offset Process Name Source Destination Description
    17.11.2011 13:57 0.1240795 spoolsv.exe client server TCP:Flags=...A...., SrcPort=51190, DstPort=DCE endpoint resolution(135), PayloadLen=0, Seq=3556645384, Ack=2234976660, Win=63220
    17.11.2011 13:57 0.4360844 spoolsv.exe client server TCP:Flags=......S., SrcPort=51204, DstPort=51208, PayloadLen=0, Seq=1324957217, Ack=0, Win=8192 ( Negotiating scale factor 0x8 ) = 8192
    17.11.2011 13:57 0.4393355 spoolsv.exe server client TCP:Flags=...A.R.., SrcPort=51208, DstPort=51204, PayloadLen=0, Seq=0, Ack=1324957218, Win=0
    17.11.2011 13:57 0.9509055 spoolsv.exe client server TCP:Flags=......S., SrcPort=51204, DstPort=51208, PayloadLen=0, Seq=1324957217, Ack=0, Win=8192 ( ) = 8192
    17.11.2011 13:57 0.9518289 spoolsv.exe server client TCP:Flags=...A.R.., SrcPort=51208, DstPort=51204, PayloadLen=0, Seq=0, Ack=1324957218, Win=0
    17.11.2011 13:57 10.8735453 spoolsv.exe client server TCP:Flags=...A...F, SrcPort=51190, DstPort=DCE endpoint resolution(135), PayloadLen=0, Seq=3556645384, Ack=2234976660, Win=63220

    -- Mikko Järvinen Computing Centre University of Turku Finland
    Friday, November 25, 2011 12:41 PM
  • One of my users who had experienced the problem near daily has so far gone 2 days without issue with the following subset of Dom's solution:


    + registry key's he mentioned

    "We made changes to the TCPIP settings via registry:

      • Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters] "EnableTCPChimney"=dword:00000000 "EnableTCPA"=dword:00000000 "EnableRSS"=dword:00000000"

    Not all of these may be necessary but so far they seem to be working, I'm going to expand them to a few more machines and see how it goes.

    Monday, November 28, 2011 7:52 PM
  • Quick update: I just had it reoccur twice to 2 users with my subset of Doms patches. pretty annoying back to square 1.
    Thursday, December 08, 2011 9:51 PM
  • Not an option - we want to solve the problem - not to hide it

    -- Dom

    Sunday, December 11, 2011 11:39 AM
  • Hello guys,

    I just found this thread after some weeks of searching a solution for the mentioned problem, which is exactly the same I have. As a IT pro I have the effect not only in my network but also in the networks of my clients.

    Here are some statements and conclusions which might be helpful to find or develop a definitive solution:

    - The effect of network-connected printers which are shown as "offline" after a while NEVER happens if the print-host is a Windows Server 2003 computer and client running under Windows 7 (32 Bit).

    - The effect occurs (like mentioned from the thread-opener) if the print-host is a Windows Server 2008 R2 and clients running under Windows 7 x64.

    - The effect never happens if the client is running under Windos XP.

    - The effect HAPPENS ALSO, if there is NO SNMP configured (SNMP not checked in the printer driver). So the solution to uncheck SNMP is not working for me and my clients.

    - The effect happens not generally for all clients nor it happens only for virtualized clients. It happens on physical clients ("fat clients") as well as on virtualized clients, connected by RDP. ALL clients are running Windows 7 x64 and ALL clients are connected to a Windows Server 2008 R2 Host where the printers are installed and shared.

    - Interestingly I switched recently in my own network some printers from an old (virtualized) Windows Server 2003 to an (also virtualized) Windows Server 2008 R2. From that day on I exactly have the problem where the printers on clients go offline.

     - Network Printers always go offline on clients, never on servers where they are installed and shared.

    Now I will install all mentioned patches and inform you later, if the problem will occur again.

    Best regards

    • Edited by Techtalker Saturday, December 17, 2011 7:01 PM
    Saturday, December 17, 2011 6:57 PM
  • Techtalker, how did it work with the patches?

    We do have same problem... surprise surprise... have tried a few things in the past with SNMP and so on, but it didn't help. We just changed from Xerox printers to Sharp printers and I had a small hope that the problem would go away, but unfortunately not. For now we just tell our users to restart the local spooler service if their printer shows as offline when they try to print.


    Friday, December 23, 2011 9:20 AM
  • Out of curiosity how many others have affected clients with intel gigabit nics?  One of microsofts suggested steps was to update nic drivers, not holding my breath but...
    Friday, January 06, 2012 1:09 AM
  • After a couple of hours to try nearly all suggested solutions I can say that no solution is working for me except to install printers locally. I had also no effect to install all patches suggested by Dominik. I also have no INTEL NICs who could play a role in this scenario. So until now there's no solution. Where are the cracks from Microsoft who can solve that issue?
    • Edited by Techtalker Sunday, January 08, 2012 8:43 PM
    Sunday, January 08, 2012 8:41 PM
  • We have had this problem for quite some time now and it really needs to be sorted.

    Have many people opened a support case with Microsoft? The more cases they have about the same issue the higher they will prioritize fixing it.

    Also are any of the people experiencing this issue using only ip addresses to connect? For example connecting to the ip address of the server instead of using a dns name like \\print\printer. Because i have read posts saying that while it is offline the DNS name of the server will no longer resolve so i am thinking of using this as a possible workaround. However none of our users are back for a couple of weeks so i will be unable to test.

    Wednesday, January 11, 2012 2:12 AM
  • Thanks for the trying and telling the truth. That's annoying to restart the computer everytime, just for to reconnect the printer. You can try to reconnect the printer server using ip address instead of print server domain name. Hope the problem can be fixed soon!
    Wednesday, January 11, 2012 3:29 AM
  • Are these client and print server machines using ipv6?  If they don't have a ipv6 addresses assigned, has all of the automatic ipv6 tunnels and addresses been disabled so that things like ipv6 6to4 tunnels are not trying to be used?
    Wednesday, February 01, 2012 7:20 PM
  • IPV6 and all associated adapters/tunnel adapters have been disabled for our site.

    I have another registry key people can test, so far it appears to be working but my sample size is small and it's only been a week.

    Disable Asynchronous
    RPC on the Windows 7 client by adding the following registry entry:


    Type: DWORD
    Data: 6

    Tuesday, February 07, 2012 11:08 PM

    Try the following:

    On client - apply update 2457866 and test.

    If the behavior continues after the update - apply the following changes:

    Disable Client Side Rendering via policy on Windows 7 client- Enable the "Always render print jobs on the server" policy setting in the following Local Group Policy container: Computer Configuration | Administrative Templates | Printers


    On the client machine, set the DestinationReachablePollingInterval = 5 seconds   (default is 30 seconds if it is not set)

    Registry location: HKLM\software\policies\microsoft\windowsnt\printers

    Disable Asynchronous RPC on the Windows 7 client.

    Registry location: HKLM\Software\Policies\Microsoft\Windows NT\Printers\EnabledProtocols      Type: DWORD    Data: 6

    Wednesday, February 15, 2012 3:27 PM
  • Hi All,

    Has anyone any update on this issue?
    What about the problems raised with MS, any comeback?

    We are seeing this with a bunch of W7 clients.

    Thursday, February 23, 2012 3:26 PM
  • Microsoft is aware of this issue and currently investigating.

    As a possible workaround, follow the steps below on the Windows 7 SP1 client and let me know if this resolves the Offline printer status.


    1. Install Fixes.

    2. Assuming client is Windows 7 SP1 - Create Registry Key TdxPrematureConnectIndDisabled described in the following KB Article.  If client is Windows 7 RTM, install the Hotfix below and create the registry key.;EN-US;981344

    • In Registry Editor, locate the following registry subkey:
    • If you are running a 32-bit operating system, perform the following step:
      Right-click the Parameters registry subkey, point to New, and then click DWORD Value.
      If you are running a 64-bit operating system, perform the following step:
      Right-click the Parameters registry subkey, point to New, and then click DWORD (32-bit) Value.
    • Rename the new registry entry to TdxPrematureConnectIndDisabled and set the value to 1.

    John Dickson Microsoft Platforms Core Team

    Thursday, February 23, 2012 4:52 PM
  • @John: Is ist neccessary to apply this modifications also for the Windows 2008 Server(s) if printers on the client-side are shared printers?
    Friday, February 24, 2012 6:16 PM
  • We opened a support case in October 2011,because we had the same issue on our print servers. The solution jdickson289 posted above,is the solution for this support case. But we did the mentioned changes onlyon our print server (Windows 2008 R2 SP1), we didn’t touch the clients.

    In our exchange environment,we had a similar issue (RPC timeouts, connection wasn’t stable). We did the same changes there and the problem was gone away.

    I hope,that someone may find this fix useful - we spend a lot of time and effort in investigating, delivering logs and testing to/for Microsoft.

    Wednesday, March 07, 2012 9:59 AM
  • Hi All,

    Since my last post we have installed this workaround on our W7 clients and they are not seeing the issue again.

    About 2 weeks now so keeping fingers crossed.


    Wednesday, March 07, 2012 12:59 PM
  • This is good news to see this is working.. we will be trying it here in our environment soon too and will report back.

    Tech, the Universe, Everything:

    Wednesday, March 07, 2012 3:33 PM
  • @Tynaarlo: We applied the mentioned fixes / changes like you only on our print server (W2008R2SP1) and had NO success with it. Like before we had to restart several times per day the printer spooler service on the workstation to enable printing again (all printers are network printers, connected to the W2008R2SP1 print server / domain server). Now we will test to apply the changes also on the Win 7 Workstations. I will report the result here.

    MORE RESULTS: After a few tests in our own and our clients enviroments we can NOT confirm that the mentioned fixes and registry changes from user "jdickson289" are working for us. IN NO CASE the problem disappeared. As soon as there's a W2008R2SP1 server is used as print server the problem is starting.

    • Edited by Techtalker Friday, March 09, 2012 12:15 PM
    Friday, March 09, 2012 10:24 AM
  • @Techtalker: Could you try the following procedure to find out, if we are talking about the same problem:
    1. Determine on which random RPC high port the spooler service is listening
      portqry.exe -n [IP/Name] -e 135 -p TCP
      Search the output  for “Spooler function endpoint”
      Download Portqry:
      Reference for the RPC high ports:
    2. Ping the RPC high port
      you have to use a 3rd party tool because you can’t ping on a specified port with “ping”. I recommend this one:
      tcping.exe -t -d [IP/Name] [RPC-Port]

    In our case the RPC-Port wasn’t reachable all the time. When the RPC-Port is “offline”, the printer queues in “Devices and Printer” went also offline.

    Monday, March 12, 2012 2:10 PM
  • @Tynaarlo: Is this RPC-Port not being reachable somehow tied into the issue with the firewall on the machine not knowing its location correctly. 

    Information on issue and the hotfix for it is:

    Monday, March 12, 2012 5:45 PM
  • @sjbauer: I suppose there is no relation between the "RPC-Port not reachable"-problem and the "wrong firewall profile"-problem. In our case the RPC-Port was not available once per 3 minutes for 9-12 seconds. In case of a wrong firewall profile, the RPC-Port wouldn't be reachable until the profile switch back (my assumption). For testing purposes you could turn your firewall off.

    How to configure RPC dynamic port allocation to work with firewalls:

    Tuesday, March 13, 2012 7:42 AM
  • Hi All,

    I've been following this thread with interest. Is there a proposed solution yet? We are having similar issues and had the feeling it was the HP universal print driver but we cannot confirm that.

    Monday, March 26, 2012 10:13 AM
  • We have a Canon network printer shared on a Windows 2003 Server R2 print server. On the Windows 7 clients the printer sometimes shows offline. This happens daily and randomly on the clients. Sometimes it helps to reboot the client. The problem occurs only on the clients with Windows 7 SP1 installed. All the clients with Windows XP installed can print without any problems.

    What I have already tried:
    - Reinstalling the printer
    - Install other printer drivers
    - Disabled SNMP on print server ports
    - Disabled firewall and anti-virus software
    - Installed latest Windows updates
    - Installed fixes mentioned in this topic

    The problem still persists.

    Wednesday, March 28, 2012 9:50 PM
  • Hi Guys

    Same problem SBS 2011 (2008R2 SP1) and Win 7 64x with Office 2010. Printers are all Konica Minolta. 

    Wednesday, March 28, 2012 10:09 PM
  • We have the same problem in citrix with session printers. Our printers go offline in existing citrix session and if a new user logs into the same citrix servers she doesn't get her printers mapped in the session. Manually adding the printer fails also with the same error described in this topic.

    The only way to fix this is to restart the print spooler and citrix print management service.

    We have 2008R2 SP1 citrix servers and a 2008R2 print server.(150printers)

    Our printers are mostly HP printers but we have few multifunctionals from Canon,Ricoh and Sharp. We use Universal and native drivers but we are going to try to put everything on universal.


    Thursday, April 05, 2012 1:44 PM
  • This may be relevant to the Offline problem.

    Several users saw their networked Canon iR C copier/printers as 'Offline' after I experimented with disabling SNMP v1 protocol in the Additional Functions (Add.Func. > Custom Settings) of the Canon printer's own web configuration. The change does not take effect until a power off-on of the printer; a soft restart is not enough. It seems that the printer driver is using SNMP rather than TCPIP to determine whether the printer is online. Although the printer can be pinged, it still appears offline. Enabling SNMP v1 and power-cycling the printer immediately restored the print function.

    This problem affected both Win 7 SP1 and Win XP SP3 clients.

    I thought it worth adding this as everyone on this thread has concentrated on the SNMP flag in the printer driver on the PC. Maybe the printer's own config should be checked. And don't always trust Ping.

    Wednesday, April 11, 2012 4:51 PM
  • Hi All,

    Bad news.
    Since my last post 2 months ago I have had a W7 client with fixes installed show the printers offline problem this morning.
    Re-booting printer was only way to get it to show online for this user.

    Thursday, May 03, 2012 10:42 AM
  • David

    Did you find a solution yet?

    we are experiencing the same problem, W7 x64 and Server 2008 R2

    all patches were installed but no luck

    Thanks in advance

    Wednesday, May 23, 2012 5:11 PM
  • Hi All,
    I have just opened a case with Microsft Premier support over this - I'll let you know how I get on.  MS have been made aware of this thread.

    John Tirocchi

    Wednesday, May 23, 2012 7:43 PM
  • Hi Nicolás,

    No solution in fact more clients are experiencing the problem now that have had the workaround applied.

    It seems to cure the problem temporarily but it has returned.

    Lets hope John has better luck with MS but it needs escalating.


    Thursday, May 24, 2012 8:35 AM
  • Just to note:

    I have built and fully patched a new Server2008r2 SP1 VM.
    Patched client (Win7 SP1 x86)
    Latest Canon WHLQ driver (copier is IRAdvance C5045)
    TWO printer queues using this driver and one virtual for Uniflow Secure print
    SNMP is OFF on the TCP/IP ports
    There is no driver isolation/sharing set on the drivers

    I experienced the online/offline issue myself for the first time yesterday.  This occured to only MY workstation after rebooting the server.  After around 20minutes the print queues stabilised on my laptop.  During this time other users were able to print OK.

    I'll let you all know what MS come back with.

    John Tirocchi

    Thursday, May 24, 2012 7:06 PM
  • Just to add my instance in - we are getting the same symptoms with slightly different results. Tried most of the things in this thread with no success.

    Setup: Win2k8 R2 RDP Server

    WinXP/Win7 Clients via RDP

    Printer is Canon IR-ADV 5030i installed on the RDP server

    The printer was working fine for the first couple of weeks, but now the jobs go through the spooler, get to the printer but don't print out - they error in the printer device queue with #099, #857 or #860 errors which aren't very helpful errors. To get it working we have to reset the printer and the spooler - many time per day.

    We're now at the stage of replacing the printer with another model - not easy for an £8000 device. And we're not even sure if that will resolve the issues as this thread reports it is afflicting many different makes and models.

    The reason why I found this thread was the 808 error messages in the event log on the server.

    UPDATE - I believe I've resolved my issue - the printer traffic was travelling over a VPN (site-to-site). I've put in a temp/test solution to go through external firewall/nat rules (ports 515&9100) to avoid the traffic from being encrypted and the prints are going through now reliably. Not sure if this was the same issue but it might help some people.

    • Edited by BenLuckman Tuesday, May 29, 2012 8:29 AM Updated
    Friday, May 25, 2012 12:41 PM
  • Hi All ...

    Just a quick one ... I came here because I was looking into the same problem ... but I've managed to sort mine by simply checking the Bindings on My LAN Card ... the file and Printer Sharing for Microsoft Networks bindings were not selected in my instance .. enabling  this brought all my printers back online while printing thru Outlook for example ...

    So just as a suggestion ... check your bindings ... Network Sharing Center, Advanced Adapter Settings, Press ALT, Advanced, Advanced Settings .. .Bindings ...

    Thursday, May 31, 2012 10:29 AM
  • The following update from MS did not fix the problem described in this post:

    Article ID: 2647753 - Last Review: May 23, 2012 - Revision: 2.0
    Description of an update rollup for the printing core components in Windows 7 and in Windows Server 2008 R2

    Too bad. I had false hopes of a fix.

    Thursday, May 31, 2012 11:40 AM
  • I am also having the same issue - have also opened a support case with Microsoft and mentioned this thread to the support engineer - so far nothing outside of other suggestions I've seen on various threads....  Here is what we've tried so far:

    1) KB2647753 -> no change

    2) opening printers and devices and hitting F5 to refresh when they are showing offline and see if they return without a spooler restart -> their suggestion, no change.

    3) Disable Asynchronous RPC

    Client side key:(Office machine)

    HKLM\Software\Policies\Microsoft\Windows NT\Printers\EnabledProtocols

    Type: DWORD

    Data: 6

    Server side key: (Print server)


    REG Value: "DisableRpcTcp"


    **Making the server side change and restarting the print server caused most of our Windows 7 clients the next day to show their printers as offline - restarting the Print Spooler service corrected the issue.

    4) Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Printers]


    This changes the spooler behavior for polling the print servers for the print queue status. Default is 30 seconds, this changes the polling to 5 seconds. Some customers have reported this resolved the issue)


    So far the only thing that have had a positive effect in our environment (so far anyways...) is disabling asynchronous RPC and changing the polling interval for the print servers.  It's only been a few days so I'm still skeptical.

    Thursday, May 31, 2012 5:55 PM
  • Hi Rustee12,

    Can you email me at with your case number?

    John Dickson Senior Support Escalation Engineer Microsoft Platforms Core Team

    Thursday, May 31, 2012 6:02 PM
  • Nice I haven't seen the polling change yet.

    Our site is still broken, nothing has really made a difference.  I'm going to adjust the polling interval and see if theres any difference.

    Friday, June 01, 2012 9:07 PM
  • Seeing the exact same symptoms & errors between a Windows 2008 R2 Terminal Server & a network printer (not shared, straight TCP/IP), which I'm assuming is a related (/the exact same?) issue.  Been keeping tabs on this thread for a while, would love to hear if anyone's devised a set of patches that are confirmed to work.

    • Edited by Dlayknee Wednesday, June 06, 2012 7:17 PM clarification
    Wednesday, June 06, 2012 7:12 PM
  • Good afternoon,

    I have an update - Microsoft are now aware of the issue and have issued me a private hotfix for test.  Looks like a public hotfix is due in July.  I've installed it on a few test PC's in my network and will be rolling it out to a few more tomorrow.  I should be in a position this time tomorrow to say ifd its been successful or not.

    Unfortunately as this hotfix is not yet public I am not able to share it with anyone.  Suffice to say if you have a case open with MS prem support you should be able to recieve this fix for testing purposes.  MS have made it clear to me that this fix is not yet a production fix as it is still undergoing testing at MS.

    John Tirocchi

    Monday, June 11, 2012 4:06 PM
  • Hallo John,

    May i refer to your casenumber as i like to receive this fix.

    Tuesday, June 12, 2012 9:28 AM
  • the KB / Hotfix number will be 2713128  and it's expected to be public avaliable 10th July.
    Tuesday, June 12, 2012 12:14 PM
  • Its bad news for me I'm afraid.

    Hotfix has been installed - relevant reg fixes mentioned above have also been installed - all to no avail.

    John Tirocchi

    Tuesday, June 12, 2012 12:50 PM
  • Nothing new to contribute however I am experiencing the same problem:

    Server 2008R2 print servers.

    WIN7 SP1 (64-bit) workstations.

    Users randomly report that their printers show "offline" or "server offline" when the printers are not, in fact, offline.  No reports of same from Windows XP users who may be on the same or different (Win2003) print servers.

    Restarting local print spooler on a user's workstation resolves the problem for the moment.

    Event logs for PrintService show nothing - Admin, Operational, Debug.

    Printers are almost all HP laserjets, print queues on servers are standard TCP/IP ports, drivers are the HP UPD PS and PCL5e, both versions 5.1 and 5.4 (depending on exact server and queue).

    I have opened a support case with MS and will direct them to this thread as well.  Love to see this fixed.

    Wednesday, June 13, 2012 10:23 PM
  • Hooooray!  I've resolved (well, identified) my issue.

    Cisco WAAS WAN accelerators....... Working with Microsoft we had some netmon logs taken from the server and client whilst we were seeing the issue.  What we can see from these is an intermediary device (Cisco WAAS) is inserting rogue packets into the data stream - this is generating an unexpected response to the client and hence breaks the communication.  Comms will timeout and retry. IF a successful set of packets is sent and subsequently received the print job behaves.

    Symptoms to look for specifically are:
    Printer online/offline when using a remote print server,
    Generic "unable to connect to printer" errors when attempting to map,
    Strange print behaviour - long time to print/unable to print multiple copies/only one copy printing when selecting multiple copies.

    We have proved by isolating our client VLAN and server VLAN from the accelerator.
    ALL issues ceased immediately.
    Upon re accelerating the issues returned.

    Unfortunately we use the WAAS devices to shape our traffic so at this junction we cannot simply turn them off so we have resorted to using a local server for the time being until Cisco TAC have a fix.

    I hope this all helps for everyone and hopefully the patch thats on its way will help everyone else.

    Peace out folks.

    John Tirocchi

    Friday, June 15, 2012 9:29 PM
  • I have also installed all the updates client/server and still no luck!

    I'm glad yours is fixed John, however your issue wasn't related to this thread.  Anyone starting to think that Microsoft will just wait to fix it in windows 8?

    Wednesday, June 20, 2012 6:10 PM
  • I'm afraid I can't really contribute anything particularly useful to this thread but I thought it'd be helpful to add weight and say that we're another institution also experiencing this same issue.

    The environment at our campus for users experiencing the issue: Windows 7 Enterprise X64 SP1 clients  running MS Office 2010 32bit. Windows 2008 R2 Print server. The machines almost all solely use the two managed print queues which run the HP UPD (5.1), affected machines have been checked to ensure all print driver files are the correct versions and cleaned up where there may have been inconsistencies. Literally every registry setting and update roll-up mentioned in this thread has been tested and almost all pushed out en-mass to anyone seeing this behaviour - with the exception of the registry setting "[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print]\"SNMPLegacy"=dword:00000001". I tried this on some systems and it certainly had yielded no positive effects but on one system actually seemed to make things worse, a print spooler restart no longer fixed the issue after making this change on the first system I tested it on and with no positive results I decided not to pursue this any further.

    We don't have any WAN accelerators or do any traffic shaping or indeed anything that could interfere with the network between the clients and print-server.

    Monday, June 25, 2012 3:28 PM
  • joined this post for help

    have     printer status is "Offline"

    you blokes seem to be working for a solution

    ours is a mixed site brother printers

    server 2008 with the service pack

    some win7 pro

    some xp pro

    our only fix is to stop and start the spooler   LOL

    I'll keep watching you, waiting for THE solution

    Tuesday, June 26, 2012 12:36 PM
  • Opened support case with MS 3rd tier.  They provided a hotfix which I installed on the workstation of a user in a small office which has this problem a lot, problem persists so hotfix doesn't seem to be the answer.  The nature of the "server offline" issue is such that I haven't been able to reproduce it on demand and it tends to fix itself (temporarily) within a few minutes of a user noticing it, so getting traces while the problem is going on is very tough.

    John T, we also have Cisco WAAS in use and that was implicated in an earlier problem (unrelated - users getting prompted whether they trust the print server when they attemp to map printers and download the driver).  AFAIK all of our print servers are exempt from WAAS acceleration but I wonder if there could be an issue with individual offices (the one I mentioned before is a small local office) using it for other traffic.

    Monday, July 02, 2012 11:27 PM
  • Hi Microsoft,

    Still no news regarding that issue .... Would you please kindly investigate and provide us the correct explanation in order to fix that issue asap ?

    A lot of users have been impacted and that "case" has been opened in 2011. We expect to receive the real fix very soon.

    Thanks very much in advance,




    Thursday, July 05, 2012 9:39 AM
  • Hi John,
    Cisco have confirmed to us now that there is a bug in the current version of the WAAS software that wil be fixed in the next release (god knows when that will be).  In the meantime they have suggested we turn off CIFS accelleration as a workaround. This was 100% successful for us and we now have no issues.  I was seeing the driver install issue that you described also and that problem has also gone away.

    John Tirocchi

    Friday, July 06, 2012 6:59 AM
  • Hi Japester79,<o:p></o:p>

    Do you have any simultaneous network traces from the Print Server and Client when the Offline Printer issue occurs due to the Cisco CIFS acceleration?<o:p></o:p>

    If so, I would like you to contact me and send the trace files. You can contact me via email at<o:p></o:p>


    John Dickson Senior Support Escalation Engineer Microsoft Platforms Core Team

    Friday, July 06, 2012 2:45 PM
  • Hi John,

    I MAY have the trace files still on my laptop at work however Mike Warrington from MS Premier Tech should have all the data.  I will have the case ref number for certain if thats any help.

    And yes, we did take netmon logs from both client and server whilst we were experiencing the issues.

    John Tirocchi

    Saturday, July 07, 2012 6:13 PM
  • Hello everyone, my name is Craig Marcho and I am a Senior Support Escalation Engineer in the Microsoft Platforms Core Team, and I work with John Dickson.

    John has moved to a different team, and I am one of the engineers that has been working on this offline printer issue for many months now.

    I'm happy to announce that we released a hotfix today that addresses this issue.

    If all of the previous troubleshooting has not provided relief, then there is a good chance you are hitting the issue this hotfix addresses. We found that this issue occurs because a restricted client thread detects an offline print server. When a client thread detects that a print server is offline, Windows registers a polling loop to check the status of the print server. After the polling loop is registered, Windows queries the print server periodically to check whether it is back online.

    In rare cases, a client thread that has a restricted token detects that a print server is offline. In this situation, Windows registers the polling loop in the context of this thread. However, the thread does not have sufficient rights to query the print server. Therefore, the polling request fails. Restarting the spooler or the client machine will obviously kill this thread running under the restricted context and will query the server with the correct security.

    The hotfix is available here:

    Please download the hotfix and let us know here if this resolves your issue.

    Thank you.

    Craig Marcho - Senior Support Escalation Engineer Microsoft Platforms Core Team

    • Proposed as answer by cmarcho Wednesday, July 11, 2012 5:32 PM
    Wednesday, July 11, 2012 5:32 PM
  • We've been running the fix on a few machines for a few weeks.

    So far so good.  Fingers crossed!

    Thanks Craig and Team

    Wednesday, July 11, 2012 8:59 PM
  • Unfortunately, 2713128 is not a fix here.

    Here is how I have narrowed down the issue:

    This issue is only happening on regular user accounts, domain admins are OK.

    It only happens after the first logoff following a reboot, and only for network printers on a print server in another domain (another forest).

    This does not occur on 2008 (32 bit) terminal server, only 2008 R2 terminal server.

    • Edited by GNCA Wednesday, July 11, 2012 9:22 PM
    Wednesday, July 11, 2012 9:18 PM
  • Same issue, same environments, long time listener, first time caller. (I am "tech support" for Canon Authorized Dealer in Manhattan.)

    The printer going "offline" on client stations is not random at all, at least not for me. I've had this issue in environments of up to 30 different printing devices, and up to 500 client workstations. I'm writing in hopes that immediately being able to recreate the issue will help in solving.

    How to recreate the issue immediately:

    On the printer, set the sleep mode to occur after one minute. 

    1. Add the printer to the print server as you normally would, share as normal; I won't go in to detail here as not to offend anyone. 

    2. Add the printer to the workstation via the print server, I always use this method (start -> run -> \\server, double click on the newly installed printer, driver is installed, printer will print from workstation)

    3. With the printer asleep, restart or power cycle your client workstation. 

    Problem recreated. Printer will appear offline from the workstation, but obviously is online and functional from the server. From workstation, printer can be pinged, RUI can be hit.

    The issue occurs when the client workstation boots while the printer is asleep. I hope this is relevant to solving this issue. I have this issue in multiple environments, and is presently "randomly" affecting a combined total of about 1,200 users that I'm aware of.

    Thursday, July 12, 2012 2:29 PM
  • cmarcho,

    When you described the situation in you post you talk about a print server being offline.  Is this print server a Windows 2008 R2 server and not the device in the printer (jetdirect, etc.) itself?  The reason I am asking is that several of the posts seem to refer to the connection between the network attached printer and a print server while that start of the thread talked about the connection between the say a Windows 7 client to a Windows 2008 R2 server acting as a print server.

    Thursday, July 12, 2012 2:33 PM
  • Applied hotfix to client workstation (win7x64), issue seems to be resolved. I cannot recreate the problem on the workstation after the hotfix was performed. Thank goodness.

    Thank you very much for your help.

    Thursday, July 12, 2012 3:53 PM
  • If hotfix 2713128 has not worked, this fix might help:

    Had similar problem: Windows 7 x64 SP1 laptop, networked printer. Worked fine for a few months when printer was first attached to the network, then recently the printer would show as offline. After re-start/re-boot, printer would again show offline.  Remove-then-add the printer would not work; jobs would not print, and printer would very quickly show as offline again.  Tried hotfix 2713128 and disabling SNMP, no avail.

    A 2nd laptop connected to the network runs Windows Vista, and has no problems printing to this same networked printer, with same connection settings on both laptops.

    Fix: Both laptops are running McAfee Total Protection.  The Windows 7 laptop had unintentionally set Spooler Subsystem App to "Block" in McAfee. [Open McAfee Total Protection, select Firewall Settings > Internet Connections for Programs > look for Spooler SubSystem App]  Changed the access setting to "Full" (or "Outgoing"), then added the printer back to the Windows 7 laptop, and now the printer shows as "ready", and does not go "offline".  Jobs print immediately rather than only during re-start or re-boot.

    • Edited by pbteddy Monday, August 20, 2012 2:46 AM
    Monday, August 20, 2012 2:45 AM
  • So, after having read this entire thread and trying a million things, I finally tracked down (kind of) what was causing the problem in my environment.

    Our setup:

    SBS 2011 Standard, serving 4 printers (a Ricoh, a Kyocera, and two HP Plotters).  These printers were deployed via Group Policy using a Per Machine policy, not Per User. The clients were a mix a x86 and x64 Windows 7 SP1 and Vista SP2 workstations.  Some workstations worked fine, some had the printer offline issues.  The divide wasn't along bit lines or anything, with some x86 machines exhibiting the issue, and some x64.  If I restarted the print spooler everything was fine, but if the machine rebooted, all of the printers would display offline until I restarted the print spooler again.

    I discovered that this issue was caused by the Group Policy.  For some reason, when GP tried to refresh the printer on reboot it would fail and that would make the printers go offline.  If I had 2 printers deployed through GP and the other two manually added to the machine, ALL of them would go offline with a reboot, but if I turned off the GPO for the printers than the two manually added would work through a reboot.

    The workaround I found was to make the Group Policy a per user policy instead of a per machine.  With this change our printers no longer went offline.

    Hope this helps someone!

    Friday, October 19, 2012 8:10 PM
  • Hi Dom,

    Just curious to know if you actually found a solution to your issue regarding the offline printer queues. 

    We seem to be having a similar thing happening here on campus for us now. I went through this whole forum but nothing that was provided has worked for us.

    We have applied the HOTFIX Microsoft provided as well as turning off SNMP to see if that helps. Its all been hit and miss, so just wondering if you did eventually find a solution to this issue and if so what it was.

    We even applied the following REG hack on one machine

    1.  Click Start, click Run, type regedit , and then click OK .

    2.  Locate and then click the following registry subkey:


    3.  On the Edit menu, point to New, and then click DWORD Value.

    4.  Type SNMPLegacy, and then press ENTER.

    5.  Right-click SNMPLegacy, and then click Modify.

    6.  In the Value data box, type 1, and then click OK.

    Note:This hotfix does not work if the SNMPLegacy registry entry is set to 0. If this registry entry is set to 1, the print queue status is displayed as "Ready" instead of as "Offline" when a printer device does not respond to SNMP commands.

    7.  Exit Registry Editor.

    Any response would be a great help.


    Monday, July 29, 2013 3:55 AM
  • The following hotfix was tried but was not effective. Networked printer still goes offline after a few minutes.

    Also tried the REG hack to set SNMPLegacy to 1. This also was not effective.

    Tuesday, July 30, 2013 4:32 PM
  • Hi fellows!

    Last year I opened a case with Microsoft Premier Support and it took two different PFE's, a lot of debugging, testing, emails, phone calls and over two months of time to finally come up with a working solution. In our environment the problem was that for some reason asynchronous RPC traffic sometimes failed between print server and the client and print queues on the client went offline. Print jobs were also failing if the error occurred during printing. Since Vista/Server 2008 Windows has used asynchronous RPC for print services instead of synchronous RPC which was used in XP/Server 2003. We never found out what exactly causes this problem in our environment. Could be anything in the network. Even with the help of Premier Support this problem was horrible to debug, though I was quite sure that the problem is some way related to the RPC traffic.

    In the end only one registry setting was needed on the print server to turn off the asynchronous RPC.

    HKLM\SYSTEM\CurrentControlSet\Control\Print\DisableRpcTcp=0x00000001 (REG_DWORD)

    After the registy setting has been added Print Spooler service (on the print server, again) must be restarted. This has an unfortunate negative effect that on all clients using asynchronous RPC at the time (Windows Vista and above) print queues will go offline and stay offline until Print Spooler (on the client) has been restarted and the client begins to use synchronous RPC. Reboot works just as well.

    Hope this helps some of you!

    Best regards,


    Wednesday, July 31, 2013 7:56 AM
  • Thank you so much for this.  Since moving printing from a 2003 to a 2012 server Ive had intermittant issues where Vista (Not windows 7/8, no XP machines around) machines would have all their printers on the 2012 server go offline, a client print spooler restart fixes it in the end, but thats not a nice fix.  Wireshark showed that RPC sessions were failing at an interval of 5 minutes, generally 5-15 minutes, of a Vista machine sending its first print job to the server.  Went through so much testing of port access, configuration, drivers, firewalls, etc

    So far so good with this change (DisableRpcTcp on just the server), the next week or two will be the true test though.

    Sunday, September 08, 2013 11:30 PM
  • In the end only one registry setting was needed on the print server to turn off the asynchronous RPC.
    HKLM\SYSTEM\CurrentControlSet\Control\Print\DisableRpcTcp=0x00000001 (REG_DWORD)

    Hope this helps some of you!


    Brilliant Mikko. Thanks.

    I had spend weeks sorting out one windows7 to windows7 printer that worked when set and then stopped when either machine was restarted.

    This Registry setting seems to have finally fixed the issue.

    Wednesday, September 11, 2013 8:40 PM
  • Disabled SNMP fixed the issue.....Thank you...Thank you
    Thursday, September 19, 2013 1:02 PM
  • Have the same problem. 2012 R2 Print server & windows 7 x86 client.Cannot reproduce problem. Once catch this issue in such situation: We're using tokens, and printer become offline after locking out station (from first logon passed about 20 hours). In this moments WireShark tells that on DCERPC Protocol  86 Fault: call_id: 9, Fragment: Single, Ctx: 1, status: nca_s_fault_access_denied . But as I understand, this error only happen when I'm using certificate, and out users log in using password.
    • Edited by Kerberrus Thursday, March 13, 2014 10:52 AM edit
    Thursday, March 13, 2014 10:24 AM
  • I have the same problem on one single machine

    All network printers are shown offline. After you restart the spooler service, they work very well for a random amount of time up to several hours.
    All other clients using the very same printers or printserver have no problems.

    Thursday, May 08, 2014 4:24 PM
  • I'm having the same issue.  I have two identical machines and one looses connection the to printers and the other doesn't have any problems at all.  Both are Win7 SP1 x64 and the printers on on SBS 2008.
    Wednesday, July 02, 2014 10:00 PM
  • We still don't resolve this problem. I began to believe that it can be a network issue :). Set async RPC - do not help, added to clients task to reboot spooler every 7 AM and 2 PM - it helps partly (we got 25-40% less incidents). But still no solution. Interesting, what print server on 2012 R2 works without any probles, although i cannot compare it our main production server (200 vs 1300 clients)
    Thursday, August 14, 2014 2:01 PM
  • Wow, it's insane that this has had no resolve yet...I came across this page searching for the answer...much to my dismay.

    Anyway, same situation here. I've gone through every single one of these steps, and to no avail.

    I have experienced this once before, and the only resolution was to wipe the machine. It fixed that user, at least.


    Thursday, October 09, 2014 9:15 PM
  • Interesting, it is in fact an intel gigabit nic. 

    There are month-old drivers. I will give this a shot. Not holding my breath either.


    Thursday, October 09, 2014 9:21 PM
  • I have been banging my head against the wall with this problem. And have a solution.

    Back ground information

    We have a windows 2008 r2 Sp1 print server

    Majority of the clients have windows 7 but i've seen this issue on windows 8.1 clients as well.

    Printers going offline even though the Print server Spooler is online and the local client spooler is online. Printers added via a different print server will also show as online. Printers show as offline for only one user at a time never at the exact same time. Printers come back online after 30 to 60 seconds or with a reboot or with restarting the print spooler on the client desktop. Turning Off SNMP didn't help but would lower the frequency of problems. Updated all print drivers and consolidated to Universal drivers for a mix of HP and Xerox printers and still had the same issue. Over 370 print queues on this one server.

    I finally talked to Microsoft and they had me install the following patches.


    We now have 100% uptime on our printers. SNMP is turned on for all our print queues and zero problems!

    I hope this will solve your problems as well.

    Best regards


    Tuesday, November 25, 2014 3:50 PM