none
SMB 1.0/CIFS File Sharing Support (Windows Features) RRS feed

  • Question

  • We have a large amount of computers running Windows 10 x64 Pro on a domain, that have the SMB 1.0/CIFS File Sharing Support option disabled after a recent update.  The issue is that we have some older Ricoh Copier/Scanners at our location that scan to a shared folder, and need this option enabled to complete their scans.

    If I go in to each computer that has the issue, "Turn Windows features on or off", and Enable SMB 1.0/CIFS File Sharing Support the issue is resolved after a reboot.  I was just wondering if there is a way to turn this on, or enable it, with Group Policy so that we don't have to do it for every computer.  I have seen various was to disable it, however I wasn't sure if there was a way to enable it.  I don't see an easy way to reverse the various ways listed to disable it either.  Thanks.

    Thursday, March 15, 2018 11:59 AM

All replies

  • Should be able to enable it using PowerShell:

    Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol
    Put it in a script and deploy it to the necessary machines.
    Thursday, March 15, 2018 1:25 PM
  • I tried this locally before adding it to our everyday login script, and it did not work as we had hoped.  I turned the feature off, and rebooted to verify that the option was disabled.  I then ran a batch file I set up that was pointed at the powershell script, and saw that it ran. . . however there was no change to the SMB status, even after a reboot.
    Thursday, March 15, 2018 2:17 PM
  • Did the PowerShell script run with administrative rights? If not, it won't work.


    Please remember to mark the post(s), which answered your question.

    Thursday, March 15, 2018 2:26 PM
  • Yes.  I ran the batch file as an Administrator, but I don't know if that in turn runs the PowerShell script it is referencing in the same manner or not.  Not sure how I would verify that.
    Thursday, March 15, 2018 3:53 PM
  • Well, part of the issue was my fault. . . I was referencing a PowerShell script I created "Enable_SBM1.ps1" in the batch file as "Enable_SMB.ps1". . . no 1.

    When I run the batch file as Admin, it works as it should, and asks me to reboot the sytem.  I don't know of a way to make a batch file run as admin.  I have run into this in the past, and as a work around we make a shortcut to the batch file, and run the shortcut as Admin.  I don't think that will in this case.

    Thursday, March 15, 2018 4:04 PM
  • Hi,

    How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server

    https://support.microsoft.com/en-us/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 16, 2018 6:34 AM
    Moderator
  • This is helpful.  It has the same PowerShell commands HardcoreCheese gave.  That works, but it isn't transparent and we can't really integrate it with Group Policy in an easy way.

    Reading the article you linked to was helpful, but it seemed to be geared more towards older versions of Windows as far as the registry entries.  If I could find out which entries to change in the registry to enable SMB1, I can make those changes with GPO.  I'm going to look for those now.

    Friday, March 16, 2018 12:41 PM
  • Hi, 

    There is no simple registry for what you would like, we can try to run powershell scripts in Logon scripts (GPO) to do so. 

    Refer to the sample here: 

    http://www.computerperformance.co.uk/powershell/powershell3-logon-script.htm

    Please Note: Since the websites are not hosted by Microsoft, the links may change without notice. Microsoft does not guarantee the accuracy of this information.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 27, 2018 5:50 AM
    Owner
  • When I run this command it asks for sources. I Tried EVERYTHING. Downloaded a Windows 2016 ISO, pointed to the sources\sxs, pointed to the install.wim on all four indexes, extracting the install.wim with DISM and pointing to that file. NOTHING WORKS. It always says the source files are missing.

    Any idea / help?

    Thanks a lot!

    Monday, July 1, 2019 7:53 PM