none
Disable 'Monitor Off' detection, how? RRS feed

All replies

  • I went through that whole thread a few months ago trying this and that to get my situation to work.  I have a laptop and and a TV that is connected via DVI cable, so this may not apply to you, but it DID work for me:

    1. Open Device Manager
    2. Under "System devices" find "ACPI lid"
    3. Open "ACPI lid" properties, and go to "Driver" tab.
    4. Select "Update driver"
    5. Choose "Browse my computer for driver software" and "Let me pick.."
    6. Uncheck "Show compatible hardware"
    7. Under "Manufacturer" select "(Standard system devices)" and model: "Volume manager" (yes, "Volume manager")
    8. Press Next.  Press Next.  Then restart the system

     

    It seems weird, but as I said, it did work for me.  Hopefully it can for you as well.  Good luck.  This is an embarrassment that Microsoft has not provided a fix for this.



    • Edited by Kamin of Ressik Friday, September 13, 2013 4:17 PM
    • Proposed as answer by v-Ada Monday, September 16, 2013 5:05 AM
    • Unproposed as answer by Oleost Saturday, September 21, 2013 2:51 PM
    Friday, September 13, 2013 4:16 PM
  • Well, what your issue is probably when you open and close your laptop lid it detects that and you experience the same issue we all do. What you did is rendering that LID detection "button" unusable since you feed it incorrect driver.

    I dont have a laptop, I dont have lid on my stationary computer and therefore I don't have ACPI LID in properties either.

    • Proposed as answer by Azzle Wednesday, November 6, 2013 8:03 AM
    • Unproposed as answer by Azzle Wednesday, November 6, 2013 8:03 AM
    Saturday, September 21, 2013 2:54 PM
  • SOLUTION (which won't suit everybody).

    As Oleost said, the thread quoted at the top of this page should not have been closed because has not been answered.  There are many people suffering from the same silly thing, so we will carry on here.

    I have an ASUS motherboard with an Intel chipset, and my display is a Viewsonic VA226W with the latest (Win 7) drivers.  I am running Windows 8.1, and I use a DVI cable to connect to the monitor.  When my display wakes up after being turned off by Windows or by me togging the power, all open windows are reduces in size and moved to the top left of the screen - very annoying.  From the internet I see that many people suffer from the same thing.

    My solution is to connect the PC and the monitor using TWO cables.  The computer and the display both have a spare analog socket, so I connected these with the appropriate cable.  Device Manager reports that I have 2 Viewsonic sceens attached.  I set them up so that one is a copy of the other, and my problem is gone!


    • Proposed as answer by JimmyGT Saturday, February 15, 2014 4:20 AM
    • Unproposed as answer by JimmyGT Saturday, February 15, 2014 4:20 AM
    Wednesday, November 6, 2013 10:27 AM
  • You could probably also use a EDID/DDC Emulator / ghost adapter.

    They come for VGA or DVI (not sure about DisplayPort though) and emulate the DDC info for the monitor, probably causing your computer to believe that there always is a monitor connected.

    I know this could be a bit pricy...

    I have just ordered one (VGA) for other reasons and hope it will solve my problems.

    http://www.adder.com/products/adder-ddc-ghost

    http://www.amazon.co.uk/LINDY-EDID-Emulator-DVI-I-Displays/dp/B0042KUKKE




    • Edited by mogidk Thursday, February 20, 2014 7:53 PM
    Thursday, February 20, 2014 7:41 PM
  • bump
    Tuesday, March 18, 2014 8:49 PM
  • Ok so i've gone through this other thread.

    I have had this issue in the past. It is an issue that just popped out of nowhere. I almost ripped my hair off.

    Back then i was on DVI main and HDMI secondary.

    The scenario for every1 is as is mostly. We output on one main monitor and extend desktop. Or the other way is cloning of desktop, both are mainly done by driver and control center for proper setting.

    From what i have gathered so far, op is having the issue where the moment he doesnt use his seconday display everything goes back to his main display and the secondary display appears disconnected.

    first main thing do not ever meddle with surround or eyefinity controls if you have only 2 displays. The moment you do that it will corrupt your driver and make it practically impossible to ever recover except for a fresh OS install. This comes from personal experience.

    This issue from my experience does come with windows but mainly the fault is the hardware driver. The moment the driver gets busted it also messes windows registry keys thus the need to install fresh OS to remove the issue.

    What i recommend is a full driver cleanup, not only uninstalling, reinstalling or update. You have to get special driver cleanup soft ware to dig up the totality of hardware and software related registry entries then try reinstalling after the full cleanup.

    Second thing is to use is the sysprep command which will return your OS to a driverless state, then reinstall and configure.

    Also check your power options. Sometimes just a simple thing as it being on power saving can do this. For laptop uses just changing the power plan setting of lid will keep outputting display and not turn it off as soon as you close the lid. This applies for normal pc use too, set your setting to never turn off and see what happens.

    Last resort is a fresh OS install. The trick to all of that is to setup your graphics extended or clone display properly from the control center and not mess anything else up in the process.

    Hope this can help.

    Saturday, April 26, 2014 4:38 PM
  • Potential solutions from the other thread.

    Mathew-55:

    Open the NVIDIA control panel, under workstation pick "view system topology"

    Hi-light your display port or hdmi port and pick Manage EDID

    Pick export EDID and save the text file to the desktop, "EDID.txt",

    Again, pick Manage EDID, this time click
    Load EDID, and load the text file that you just saved, "EDID.txt". 

    This will force the connection and turn off the auto-detection feature on that port.  Repeat this process for any other ports you want to force.

    Tyler Griffin:

    Came across this discussion and may have a solution for AMD users. Be sure that "alternate DVI operational mode" is UNCHECKED in Catalyst. It's located in My Digital Flat Panels / Properties (Digital Flat Panel).

    I used to be able to turn off my TV and keep HDMI audio running through the receiver. One day it mysteriously stopped working, and I chased it down to this setting. Once you uncheck this mode and turn off the TV, Catalyst will prompt you with a warning about how the connection has now become a "DVI" connection instead of HDMI, but it is this changeover that keeps Windows from treating the display as unplugged and completely disabling the connection. It seems almost like a bug in the AMD driver, but it's a fortunate one that gets around this lovely "feature."

    Hope this is helpful, at least for the AMD guys.

    Ryan Beymer:

    I must say I find this to be a very slick solution. As all the rest I am quite disappointed with the multi monitor
    support in Windows. But, with this simple hack I am able to switch my TV from HDMI to cable, turn it off, back on etc and still keep XBMC running smoothly on my secondary display while using the primary as a normal PC.

    I humbly suggest a minor modification: I used a very thin piece of electrical tape to block pin 19 directly in the HDMI cable and then gently plugged it in. It worked beautifully and I imagine more people would be willing to try this than cutting through the cable. I am trying to post a picture, not sure if it'll stick:

    http://postimage.org/image/2g8p5dwdg/

    If the picture isn't there, pin 19 is on the top right when looking at the HDMI male plug. Look for the pinout in
    wikipedia and notice that it is the female plug there, so you need to flip horizontally for the male one.

    Thursday, July 17, 2014 12:26 AM
  • Really like what a guy wrote in the previous thread, really MS support is being totally USELESS and its unbelievable that it isn't fixed yet!

    QOUTE:

    • The idiotic "answers" by MS Support:

      You were told repeatedly to stop advising people to update Drivers or whatever.  The problem is a documented moronic feature of Windows7, having zilch todo with drivers !!!  hOW MANY TIMES DO YOU NEED TO HEAR THAT YOU ARE DEAF & BLIND, MS SUPPORT GUY?

      There's a "feature" or should we say problem, whereby Windows7 detects any monitor connected via modern digital ports (DP, HDMI, TB) beign turned off, and forces moving entire desktop to monitor still being on, in multimonitor environment - which happens to be prevalent in our industry (Engineering e.g. CAD/Design), Graphics design, Medical, and MANY home users also, these days.

      Use brains when reading bug reports, dear MS idiot.

      Fix the bug and quit blaming nVidia, AMD (ATI), Intel HD, or "drivers".  I hold MSEE degree, near-complete PhD and you tell me I forgot to update da** drivers?

      Read this line again, Microsoft idiot:

      This is a feature (by design) whereby PnP monitor connected via DP/HDMI/TB to Windows7 is being polled for powerOn/Off state, it may or may not use DDC signal by the way, we can't tell.  YOU should know better than us, customers !!

      I tried to disable DDC in my high-end IPS $1000+ monitor, but no effect.  I seroed Registry Keys used in nVidia or ATI monitor status polling - no effect.

      The stupid feature of WIndows7 which moves desktop to another display, when one is turned off in multimonitor setup - is more than retarded, it is actaully a showstopper for professional folks.

      Tired of rearranging desktop everytime one of the monitors is turned off, so tired I don't care to run spell check in this post.
      I am angry.  WindowsXP developed by Microsoft in Israel, was the best OS in history, now that it aged & faded into history, there's no equally well-designed equivalent.

      Tuesday, September 27, 2011 2:00 PM
      Avatar of Mark Gates
      85 Points
    • The idiotic "answers" by MS Support:

      You were told repeatedly to stop advising people to update Drivers or whatever.  The problem is a documented moronic feature of Windows7, having zilch todo with

      drivers !!!  hOW MANY TIMES DO YOU NEED TO HEAR THAT YOU ARE DEAF & BLIND, MS SUPPORT GUY?

      There's a "feature" or should we say problem, whereby Windows7 detects any monitor connected via modern digital ports (DP, HDMI, TB) beign turned off, and forces

      moving entire desktop to monitor still being on, in multimonitor environment - which happens to be prevalent in our industry (Engineering e.g. CAD/Design),

      Graphics design, Medical, and MANY home users also, these days.

      Use brains when reading bug reports, dear MS idiot.

      Fix the bug and quit blaming nVidia, AMD (ATI), Intel HD, or "drivers".  I hold MSEE degree, near-complete PhD and you tell me I forgot to update da** drivers?

      Read this line again, Microsoft idiot:

      This is a feature (by design) whereby PnP monitor connected via DP/HDMI/TB to Windows7 is being polled for powerOn/Off state, it may or may not use DDC signal by

      the way, we can't tell.  YOU should know better than us, customers !!

      I tried to disable DDC in my high-end IPS $1000+ monitor, but no effect.  I seroed Registry Keys used in nVidia or ATI monitor status polling - no effect.

      Disgusting feature of Windows7 which moves desktop to another display, when one is turned off in multimonitor setup - is Disgusting simply b/c user is deprived of

      ability to disable such behavior specifically for DP/HDMI-attached Monitor. Hot PnP is a necessity usually, but NOT always - in the case of monitors, anyone with

      braisn wants to turn them OFF for the night or leaving room for longer than e,.g. an hour.
      SLEEP/STANDBY is NOT equivalent to what we're asking to fix, we are asking (get a magnifying glass you Microsoft guy, if you can't read properly):
      To restore ability to TURN OFF [arbitrary] MONITORS, with a physical/hardware button in a multimonitor setup which is becoming prevalent - w/o fear of Windows7

      autoswitchign desktop to a monitor reamining ON thereby WREACKING HAVOC w/windows sizes, locations, icons, you name it.
      Behavio ris due to a simple fact that movign desktop to different resolution ersizes windows previously drawn on that monitor, you just turned off !
      Do you understand it is a terrible Productivity killer?
      Want a simple example where you always use multimonitor setup?  Here:
      Suppose you're doing serious, professional grafix work on your laptop, which thankfully is adequate in both Processor & Video specs, e.g. my HP EliteBook8540w &

      Elitebook8740w, all you want is to attach an EXTERNAL professional (IPS) display, mostly for size reason (HP ELitebooks include internal LCD which is also pro

      IPS/"Dreamcolor" type but too small for full-scale work).
      What do you think you just got yourself??  Windows7 treats it as a MULTIMONITOR SETUP!  So you canNOT turn off g0* da** external monitor w/o Windows7

      autoswitching internal LCD ON.  Next thing you know your desktop is messed up b/c internal LCD is obviously lower resolution!
      And finally, what adds to the pain, is my professional Videocard in this laptop, which alone costs many hundreds$$$, is configured to drive EXTERNAL display & via

      DPport, when Windows7 stubbornly invokes internal LCD after I turn off external Monitor, this same settings is almost damaging my internal LCD - too bright.  B/c

      external IPS monitor is a professional, medical grade type that is much less bright than cheapo TN monitors.  I rush to turn external back ON and leave it On

      wondering how long will this problem will remain unfixed ??

      Even WindowsVista blamed for many issues comparing to WinXp, even Vista - convenient target of jokes, did not exhibit this stupid behavior.
      No tto mention WIndowsXpo which doesn't wreack your desktop when one display out fo multiple is turned OFF. 
      More than retarded, it is actaully a showstopper for professional folks.

      Tired of rearranging desktop everytime one of the monitors is turned off, so tired I don't care to run spell check in this post.
      I am angry.  WindowsXP developed by Microsoft in Israel, was the best OS in history, now that it aged & faded into history, there's no equally well-designed

    Tuesday, September 9, 2014 4:03 AM
  • This is not a solution, but a workaround that I've employed for my own sanity.

    I noticed that if windows are minimized when my displayport monitor is  turned off and they are not restored until the displayport monitor is turned back on, they restore as if the monitor was never lost as a display device.

    I've documented how I leverage that behavior to provide a 'seamless' experience here:

    http://thelamprechts.blogspot.com/2014/09/a-windows-workaround-to-maintain-window.html

    Sunday, September 28, 2014 4:49 AM
  • Hi, the problem is that some basic video cards like Intel just don't deal well with EDID (comunication protocol with monitor). I had tried alot of settings but nothing worked.

    Look up "monitor detect killer" it works well and it was cheap.

    Friday, January 16, 2015 5:50 AM
  • Deleted
    Thursday, May 14, 2015 5:56 PM
  • Make sure to install the drivers for your display port monitor.  That solved this problem for my Dell monitors with Windows 10.

    Michael Hawker

    Saturday, September 17, 2016 5:38 AM