none
Windows 7 inconsistent search for users using documents folder redirection to server plus offline files enabled (Plus best practices question)

    Question

  • Environment: Windows Server 2008 R2 Domain, 70+ Windows 7 Professional workstations

    Like I said in the title, and in order to save my users any data loss in the event their computer dies, I have redirected all their documents to a file share on a server using the documents folder redirection group policy.  I also have offline files enabled, so that if there is any loss of network connectivity they can still work on their files.

    However, The windows search is really not seeming to work well.  For instance, I have a file called blah.txt in my documents.  When I click the start button and type it in under the "Search programs and files", it finds it.  However, this doesn't work with some users!  If I open windows explorer and go the root of my documents library, any file I search for will return "No items match your search"

    So my questions are:

    1. Is there a better way to ensure users data is accessible and secure than the group policy method I am currently employing?

    2. If I am following a best practices route, what is the best way to enable consistent search with Windows 7?

    Thanks.

    Tuesday, November 8, 2011 8:27 PM

Answers

  • Hi,

     

    Please try to rebuild the index to see what the result is:

    1. Open Indexing Options by clicking the Start button, and then clicking Control Panel. In the search box, type indexing options, and then click Indexing Options.

    2. Click Advanced.  If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

    3. In the Advanced Options dialog box, click the Index Settings tab, and then click Rebuild.  If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

    If this cannot fix this issue, you could check if you have added you offline file into indexed location. Also, check if there is system permission on security settings of user data folder.

     

    For more information, please kindly refer to the following articles:

     

    Libraries: frequently asked questions

     

    Improve Windows searches using the index: frequently asked questions

     

    Regards,

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, November 10, 2011 5:33 AM
    Moderator