none
Windows Media Player and MKV files

    Question

  • I recently installed Windows 7 RC1 and wanted to play some MKV files on it. I tried with Windows Media Player and Windows Media Center however they did not work. Fortunately I did eventually get them to work (by installing FFDShow & Haali Media Splitter and telling WMP to allow it to play them), however for some reason when I now try to play them I get an error "Windows Media Player encountered a problem while playing the file." - "C00D11B1". Looking this up, apparently it's got something to do with my Sound Card drivers however they are up to date and completely working. As I said before I have had the MKV files working already and have not changed anything to do with my Sound Card and/or its drivers since they stopped working. Does anybody know what the problem is?

    Any help will be greatly appreciated.

    Thanks in advanced.
    Tuesday, May 12, 2009 11:02 AM

Answers

  • Dou itashimashite. :]

    That specific suberror (0x80040241) is "Source filter cannot be loaded".  So somehow that MKV filter (Haali Media Splitter) doesn't appear to be loading correctly.  I don't know what might have changed on that site, but that's where WMP thinks it's failing right now. =\
    • Marked as answer by Jealy666 Wednesday, May 13, 2009 5:40 PM
    Wednesday, May 13, 2009 5:30 PM

All replies

  • No, 0xc00d11b1 is "Error File Open Failed".  That's all it means.  Click Web Help on that error dialog - what URL does it take you to?  That will have a spot more information in the URL itself.

    Please note you used FFDShow Tryouts, not FFDShow.  This is an important difference since FFDShow was abandoned in 2004. Totally pedantic on my part, but people using actual abandoned FFDShow run into a lot of crashes, so I try to point out the difference. =)

    32bit or 64bit?
    Wednesday, May 13, 2009 6:11 AM
  • I clicked web, it starts talking about my Sound Card drivers and such.

    I didn't see "0xc00d11b1", I got the error "Windows Media Player encountered a problem while playing the file." and when I clicked Web it said "C00D11B1".

    Yeah I used FFDShow Tryouts, sorry for not saying, a pet peeve huh? :)

    32bit.

    Thanks for the reply!

    Wednesday, May 13, 2009 10:42 AM
  • OK - what is the *URL* itself for that Web Help page?  That should have a touch more data of value. :)

    Wednesday, May 13, 2009 5:02 PM
  • Wednesday, May 13, 2009 5:04 PM
  • Dou itashimashite. :]

    That specific suberror (0x80040241) is "Source filter cannot be loaded".  So somehow that MKV filter (Haali Media Splitter) doesn't appear to be loading correctly.  I don't know what might have changed on that site, but that's where WMP thinks it's failing right now. =\
    • Marked as answer by Jealy666 Wednesday, May 13, 2009 5:40 PM
    Wednesday, May 13, 2009 5:30 PM
  • Ah, I see. I'll try re-installing the Haali Media Splitter and/or finding another MKV filter.

    Thanks again.


    EDIT - Reinstalling it worked a treat, before doing so I tried to open the configuration for it however it had an error, so I just reinstalled. Should have tried that before actually, silly me.

    Thanks a lot, zachd.
    Wednesday, May 13, 2009 5:32 PM