none
Windows 7 x64 Professional - .Net 2.0 Framework Corruption RRS feed

  • Question

  • A user's laptop is reporting the following error whenever they run an application that requires v2 of the .Net Framework as follows:

    .Net Framework Initialization Error
    -------------------------------------------

    To run this application, you first must install one of the following versions of the .NET Framework:
    v2.0.50727
    Contact your application publisher for instructions about obtaining the appropriate version of the .NET Framework

    -----------------------

     So I've tried all the solutions found here:

    http://blogs.msdn.com/b/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx

    I had the run the following from an elevated prompt: sfc /scanow which resulted in no errors.

    I checked all the registry entries to ensure they matched another working Windows 7 x64 machine.  I've downloaded all of the latest updates with Windows Update.

    I ran disk check with chkdsk c: /R with no major errors.

    I've ran the netfx_setup_verification tool which reports the following:

    It says that Product verification has failed.  The log is as follows: https://skydrive.live.com/redir.aspx?cid=19ee88dac55feb7f&resid=19EE88DAC55FEB7F!130&parid=19EE88DAC55FEB7F!127&authkey=!AJnbRcAR1FXyHn4

    I don't see any details of why this failed.  I manually retrieved the NetFx20TestApplication.exe and when run it says the same error as any other app.  No log file is generated.

    I can't find anything in the Windows Application / System logs that are relevant.
    So then I ran Process Monitor and received the following: https://skydrive.live.com/redir.aspx?cid=19ee88dac55feb7f&resid=19EE88DAC55FEB7F!129&parid=19EE88DAC55FEB7F!127&authkey=!AFStzcigkMUsdHA
    I don't see any major errors there that make any sense.  I also used the add/remove utility to uninstall .Net 3.5 from Windows 7, reboot, and then reinstalled again with no luck.
    Lastly I loaded an elevated prompt and went to c:\Windows\Microsoft.NET\Framework64\v2.0.50727 and then ran ngen update which provided the following error:  Failed to load the runtime.  <Exception from HRESULT: 0x80131700>
    I'm really running out of options before having to do a full reload which I'd rather avoid.  I could do an "in place upgrade" but I might as well reload cause I would that's going to wipe out my settings & data anyway and I would feel better about a full wipe anyway.
    Any ideas from the super geniuses out there?

    Friday, January 6, 2012 4:40 PM

All replies

  • Is'nt it application specific error? What application make you problem?

    2. If the error is caused by .NET Framework, then there are at least two possibilities:

    a. Go to the previous restore points or backup, that worked properly

    b. Recover .NET according to the http://support.microsoft.com/kb/976982/en-us

    Regards

    Milos

    Sunday, January 8, 2012 10:33 AM
  • Milos:

     

    Sorry for the delay, was serving jury duty and had no access to a computer or any other technology for that matter.  Here are the answers to your inquiries:

    Q: Isn't it application specific error?  What application make you problem?

    A: The problem is not specific to any particular application and only affects those that require .Net 2.0.  Any application (even the .Net20TestApplication.exe fails to produce any error as it thinks .Net 2.0 isn't installed.

    Q: Have you gone to a previous restore point?

    A: Yes, I've tried even up to a week before the issue started with no change.  The applications that use .Net 2.0 on the computer are used daily so we are aware the issue wasn't there at this restore point.

    Q: Have you recovered .Net according the article?

    A: I have tried all of the steps in the article with no correction of the issue. :(

    Do you have any other suggestions to try before I wipe this thing out and start over?

    Tuesday, January 10, 2012 8:29 PM