none
MSVCR100.dll is missing

    Question

  • I am trying to install Apache web server using wamp on a windows 8 pro machine when it is installing I get the following error: "The program can't start because MSVCR100.dll is missing from your computer. Try reinstalling the program for to fix this problem." I have tried the suggestions on the web to remove Visual C++ redistribution  and reinstall it and that doesn't seem to work.

    Where can I get this dll and what directory should it be in? Should I be installing a newer version of the Visual C++ redistribution pack, like the 2012 pack? Should I also install older versions of the redistribution pack one of the articles on the web suggested to remove all the versions of Visual C++ redistribution packs and reinstall them; I only have 2010 pack installed. Almost all of the articles were related to Windows 7 not Windows 8 is there something I should be doing for window 8 Pro

    Tuesday, September 24, 2013 5:28 AM

Answers

  • MSVCR100.dll = Visual C++ 2010 Runtime, not the 2012.

    32Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
    http://www.microsoft.com/de-de/download/details.aspx?id=8328

    64Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
    http://www.microsoft.com/en-us/download/details.aspx?id=13523


    "A programmer is just a tool which converts caffeine into code"

    Tuesday, September 24, 2013 8:12 PM
    Answerer

All replies

  • MSVCR100.dll = Visual C++ 2010 Runtime, not the 2012.

    32Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
    http://www.microsoft.com/de-de/download/details.aspx?id=8328

    64Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
    http://www.microsoft.com/en-us/download/details.aspx?id=13523


    "A programmer is just a tool which converts caffeine into code"

    Tuesday, September 24, 2013 8:12 PM
    Answerer
  • You can find the Cause and Solution: http://www.steptoinstall.com/msvcr100-dll-is-missing-when-wamp-server-install.html
    Friday, May 02, 2014 7:37 AM
  • For the English version of the 32Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x86) , I would suggest that you use En-Us download from: 

    http://www.microsoft.com/en-US/download/details.aspx?id=8328

    • Edited by catfood40 Wednesday, October 01, 2014 8:57 AM
    Wednesday, October 01, 2014 8:56 AM
  • still the problem persists...
    Tuesday, March 17, 2015 6:42 AM
  • My computer can't open a file because it says there is a problem it said to re-install the file but that didn't work
    Friday, May 15, 2015 3:22 AM
  • I'm still facing the same issue. I have also install the 64 bit version as you said,
    64Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x64) 
    http://www.microsoft.com/en-us/download/details.aspx?id=13523

    but same situation that is "The program can't start because MSVCR100.dll is missing from your computer. Try reinstalling the program for to fix this problem."?

    Please tell me how i can fix it. I'm using Windows 8.1 Pro 64 bit version.

    Saturday, October 03, 2015 4:35 AM
  • I'm still facing the same issue. I have also install the 64 bit version as you said,
    64Bit: Microsoft Visual C++ 2010 SP1 Redistributable Package (x64) 
    http://www.microsoft.com/en-us/download/details.aspx?id=13523

    but same situation that is "The program can't start because MSVCR100.dll is missing from your computer. Try reinstalling the program for to fix this problem."?

    Please tell me how i can fix it. I'm using Windows 8.1 Pro 64 bit version.

    Saturday, October 03, 2015 4:37 AM
  • If the program that won't start is a 32-bit program then you also need to install the 32-bit (x86) version of the runtimes.

    Friday, November 13, 2015 1:55 AM
  • 2016 now. I am running Win 10 Insider Preview 11102.rs1_160113-1800 

    Probably 1st boot up after the new system.

    This error induced to WLM (after prior repair from an update Dec2015?) Installed 32 bit. Then 64 bit. OK. Then rebooted.

    Start WLM and get:

    "wlmail.exe - System error

    The program can't start because MSVCR110.dll is missing from your computer. Try reinstalling the program to fix the problem.

    OK"

    about 3 times.

    Someone keeps messing up the same thing over and over at MS.


    Michael

    Saturday, January 23, 2016 6:55 AM