"Base Filtering Engine Service" Not available in services database list...what do i do and how do i get it back? RRS feed

  • Question

  • So.....I recently started up my computer and got a error telling me that it could not find (or use) the following services:
    The Base Filtering Engine Service, The IKE and AuthIP IPsec Keying Modules Service and The IPsec Policy Agent Service. I tried to start/enable the IKE and AuthIP IPsec Keying Modules and IPsec Policy Agent services but both of them said that they were ether missing or unusable. But then when i tried to find the Base Filtering Engine was nowhere to be seen nor found. question is....what happened to it and how would i get that service back? I am really hoping to do not have to reinstall Windows....because i have a lot of data that i would rather not have to go out and by a External HDD and then backup all of the items that on are this laptop.
    Please let me know what to do.

    Wednesday, December 7, 2011 6:54 PM

All replies

  • Hi Flam1ng, Have exactly the same problem you  indicated. Has anybody advised you how to fix the problem?

    I've did a restore point with no luck, so far have not find how to fix problem. Appreciate if you pass down the info if you were able to fix the prob.



    • Proposed as answer by nimooli Tuesday, March 13, 2012 2:13 PM
    Thursday, December 8, 2011 3:48 AM
  • Hi Flam1ng, Have exactly the same problem you  indicated. Has anybody advised you how to fix the problem?

    I've did a restore point with no luck, so far have not find how to fix problem. Appreciate if you pass down the info if you were able to fix the prob.



    No dude. No one has given me the answer yet. I wish i could help you...but i am still having a issue with the specified service being missing from the service database. The only thing that i can think of is to reinstall my whole Operating system. Unless someone out there knows a different and easier way to do it. Can someone please help us out?



    Thursday, December 8, 2011 4:50 AM
  • I have the same problem. Can Microsoft provide some help on somegthing like this?  How can we get them to help?


    Friday, December 9, 2011 11:32 PM
  • Win 7: I am having exactly the same problem. Tonight I tried to install Norton anti-virus, and the install failed because I have no 'base filtering engine' - the error message link said that I should contact Microsoft.

     I checked the serives list, and the base filtering engine service is not there. I've had problems with the 'win 7 home security 2012' virus lately, and I am wondering if that virus may have deleted the base filtering service?

    Anyway, would sure like to know if there's a simple way to get the base filtering service back without running a restore.  Thanks!

    Monday, December 12, 2011 5:20 AM
  • Hi,


    According the issue,  I recommend that you could use “sfc /scannow” to check the system file first.


    If the issue occurs again, I suggest that you may use the following method to create the service:


    Method 1


    Use sc .exe to create the Windows Service. Sc.exe uses the following syntax:

    Syntax1 (use Syntax1 to run Sc.exe)


    sc [Servername] Command Servicename [Optionname= Optionvalue...]


    Syntax2 (use Syntax2 to display help information, except for the query command)


    sc [Command]


    Please refer


    Method 2


    Also you may backup the Registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\BFE from another computer of same operating system .Then copy to your computer and restore the Registry.


    Hope that helps

    William Tan

    TechNet Community Support

    Monday, December 12, 2011 8:33 AM
  • EDIT:

    I drafted a blog for this issue:


    Note:Modifying REGISTRY settings incorrectly can cause serious problems that may prevent your computer from booting properly. Microsoft cannot guarantee that any problems resulting from the configuring of REGISTRY settings can be solved. Modifications of these settings are at your own risk...

    We reduce your efforts! Click here to find hot issues and resolutions

    • Proposed as answer by danma_ Monday, December 19, 2011 3:28 AM
    • Edited by danma_ Saturday, January 21, 2012 1:28 AM
    Monday, December 19, 2011 3:24 AM
  • danma_...I just wanted to say "thank you" for posting this information. I was having the same problem, and this was a quick and easy solution that didn't involve reinstalling Windows. Great info, and I appreciate it.

    To the others who are encountering the same issue, I can verify that this solution DOES work.

    Thanks again! :D

    Wednesday, December 21, 2011 12:40 PM
  • For some reason when i click on the links and download the files, it saves them as txt document files. If that is correct then how do i import them into the registry.
    Thursday, December 22, 2011 6:31 PM
  • You can rename them to .reg. Or create another BFE2.reg file and copy/paste the content from .txt file to .reg file.


    Thursday, December 22, 2011 8:17 PM
  • Copying the BFE service registry keys from a Win 7 Ultimate 64-bit to Win 7 Home Premium 64-bit machine worked for me.  I also had to grant Everyone full access to the key in the registry in order for the service to start, despite the permission matching that of the source machine (i.e. all the inherited permissions matched).

    I believe the BFE service's key was deleted by malicious software that I just removed from the affected system.

    Friday, December 23, 2011 12:53 AM
  • Trade of Jacks:

    Although I finally decided to restore the factory OS, your experience and solution sound right on.  Before I restored, I was able to edit the Registry to get the BFE to re-appear in the services list, but was unable to start it. That's when I gave up and restored, figuring that something I'd inadvertently done to the Registry might be causing the BFE permissions problem (i.e. a self inflicted quagmire that I didn't have the patience to resolve).  After reading your comment, it makes sense that the 'Win 7 Home Security 2012' virus may actually have deleted the BFE service key altogether, or at least edited its permissions.  Simply adding it back (or editing it, if it was still there) to grant full access would have saved me some work. I'll remember that for next time (although I've beefed up my security so much that I'm counting on there not being a next time !).

    Friday, December 23, 2011 1:09 AM
  • Thank you so much!!
    Friday, December 23, 2011 1:18 PM
  • Thanks Danma. It fixed most of my issues.


    Friday, December 23, 2011 11:03 PM
  • Thanks for this post!  I tried everything including registry repair tools and malware utilities.  This was very helpful!!!  Very good guidelines, it was straightforward.
    Saturday, December 24, 2011 2:10 AM
  • danma, 

    I've the problem described above (BFE service doesn't exist) on my Win 7 Ultimate/32 bits system.

    Please, post your answers to the following questions:

    1. Do the links (to the you posted can be used for my system version - Win 7 Ultimate/32 bits ?
    2. In my system32 folder exists the file BFE.DLL 483 KB. Is that file enough when solving the BFE service problem,
        or other files are also needed? 


    Monday, December 26, 2011 7:52 PM
  • My new personal hero!

    Not equipped for a complete reinstall of my OS just yet, I'm still backing up. Thanks for the fix

    Monday, January 9, 2012 9:21 PM
  • William Tan

    TechNet Community Support

    umm the commands? all it does for me is it asks for help yes or no if i say yes or no it exits
    Monday, February 25, 2013 7:09 PM