none
Connecting 2 Wireless Adapters to 1 Router from 1 Computer

    Question

  • Hey! I seem to have a unique problem (as I've checked the internet and also this site but not found anything similar).

    I have an HP dv6880ee with a built in Intel Wireless G card. I've got a Linksys WAG160N Wireless N Router. I also have a DWA-140 D-Link USB Wireless N Adapter. What I want to do is to connect both my internal AND USB adapters wirelessly to the Linksys router.

    The reason for doing so is that the built in wireless disconnects everytime the laptop lid is put down. So in case that happens at least the USB wireless keeps running. Also, if I only run the external USB wireless it's relatively slower and not as stable as the built in. So I thought, if I could connect both to the same router then it would fix the problem.

    The problem now is that if I do that (with each adapter having it's own IP address) I can connect via both BUT apparently it only uses one (my internal ><). So I tried a bridge... but that just keeps giving me IP address conflicts (even though I manually tried assigning different IP's to both the adapters AND the bridge).

    And as I do port forwarding for running servers I need the final IP to be 192.168.1.150 (which is the IP configured for port forwarding)

    Is there a way I can connect both internal AND USB adapters to the network with ONE IP (192.168.1.150) so both wireless adapters are used?

    I know I won't get extra bandwidth etc but all I want is 2 wireless adapters 1 IP connected to 1 router.

    Please tell me how to get this... Thanks! Big Smile
    Sunday, September 28, 2008 3:48 PM

Answers

All replies

  • nobody know how to fix this? Tongue Tied

    Please help me as my internet is really unstable!
    Monday, September 29, 2008 4:14 PM
  • Hi,

     

    Based on my experience, Microsoft doesn’t have official solution for setting two network adapters with one IP address.

     

    Meanwhile, I notice you said: “The reason for doing so is that the built in wireless disconnects everytime the laptop lid is put down”. Given the situation, I suggest we focus on the problem. If we resolve the problem, you may not need setting two network adapters with one IP address.

     

    This issue mostly can be caused by saving power or third party software. At this time, let’s try to take the following steps to troubleshoot this issue.

     

    Suggestion 1: Disable Saving Power

    ==========================

    1. Click Start, right click Computer and choose Properties.

    2. Click Device Manager.

    3. Navigate to you built-in wireless adapter, right click it and choose Properties.

    4. Choose Power Management tab.

    5. Please uncheck “Allow the computer to turn off this device to save power.”

    6. Restart the computer and test this issue again.

     

    If the issue still persist, please take the following suggestion.

     

    Suggestion 2: Clean Boot

    =============================

    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test the issue.

     

    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".

     

    Please monitor the system in the Clean Boot environment. If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You may use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     

    Does it work? If not, please let me know.

     

    Hope it helps.

     

     

    Tuesday, September 30, 2008 7:12 AM
    Moderator
  • Hey! Thanks a lot for your detailed response!

    Unfortunately I've already tried the solutions you've proposed as well as countless other solutions. My Vista runs on an HP laptop and after tonnes of research I've found that the wireless is built in on the lid and disconnects as soon as you close the lid. In the end I did come up to a conclusion that the lid closing and the built in wireless disconnecting will always go hand in hand. That is mainly why I bought the USB wireless adapter.

    Maybe if you cannot allow one IP address could you just give me a way to allow my PC to use both wireless networks to connect to the router? All I want is a more stable connection whenever one of the wireless connections disconnect the other can keep the internet alive. What happens though is that my external USB wireless adapter is used and the built in isn't used, just connected (I saw via the changes in the packets sent/recieved in the status page of both adapters). Now if this external adapter disconnects all my running internet programs (MSN, uploads, downloads) crash while the internet switches to the built in one. Then the internet starts working.

    Is there a way I can make Vista use both wireless adapters to access the internet to give a more stable (but not necessary faster) connection to the router? 2 IP's will be fine for me I guess.

    Thanks again! waiting for your reply!
    Tuesday, September 30, 2008 9:38 AM
  • You cannot use both wireless adapters to connect to the router at the same time.

     

    --

    Eric Cross

    Microsoft MVP (Windows Desktop Experience)

    http://mvp.support.microsoft.com

     

    Tuesday, September 30, 2008 1:37 PM
  • Thanks... I'll just use my external for now Smile
    Wednesday, October 01, 2008 4:33 AM