none
Gadgets always stay on top RRS feed

  • Question

  • Hello all,
    I have a problem with the gadgets on my desktop. They always stay on top of all application windows, no matter if "Always on top" is selected or not. This is some kind of minor problem on wide screen, but I have 13-inch laptop and sometimes I need all the space.
    Thank you in advance.
    Tuesday, June 23, 2009 9:33 PM

Answers

  •  

    Hi,

     

    Thank you for posting here.

     

    Based on my research, I would like to suggest the following:

     

    1.    If you have more than one gadget, please check if all of them have "Always on top" un-checked.

     

    2.    Disable and re-enable the “Windows Gadget Platform” feature to check the issue:

     

    1)     Go to “Control Panel - Programs and Features”, click “Turn Windows Features on or off” on the left pane.

    2)     In the new window, uncheck “Windows Gadget Platform” and click OK.

    3)     Restart your computer.

    4)     After the computer starts up again, re-enable it in “Turn Windows Features on or off” , reboot the system to apply the settings.

    5)     After the computer boots up, check if it works.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Friday, June 26, 2009 8:41 AM
    Moderator

All replies

  •  

    Hi,

     

    Thank you for posting here.

     

    Based on my research, I would like to suggest the following:

     

    1.    If you have more than one gadget, please check if all of them have "Always on top" un-checked.

     

    2.    Disable and re-enable the “Windows Gadget Platform” feature to check the issue:

     

    1)     Go to “Control Panel - Programs and Features”, click “Turn Windows Features on or off” on the left pane.

    2)     In the new window, uncheck “Windows Gadget Platform” and click OK.

    3)     Restart your computer.

    4)     After the computer starts up again, re-enable it in “Turn Windows Features on or off” , reboot the system to apply the settings.

    5)     After the computer boots up, check if it works.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Friday, June 26, 2009 8:41 AM
    Moderator
  • Easiest solution: go desktop, right click > view > Show Desktop Gadgets. Repeat it to restore them. They will "Show on top" correctly now.
    • Proposed as answer by F4ilGamer Friday, March 30, 2012 2:32 PM
    Friday, November 6, 2009 1:33 PM