Cannot install .Net Framework 4.0

    General discussion

  • I seem to be one of many who cannot install .Net Framework 4.0.  Several programs, including TurboTax, have failed to run because the framework is not installed.  It appears to be installed but can be neither uninstalled nor reinstalled.  I searched the forum and found 308,000 threads related to this problem.  Apparently Microsoft has no answer to this.  Isn't it time for Microsoft to take this seriously?
    Sunday, April 28, 2013 12:24 AM

All replies

  • have you tried the repair tool?

    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Sunday, April 28, 2013 3:10 AM
  • Hi,

    I suggest you try the following steps to test the issue:

    1: Repair the .NET Framework 4 installation

        1. Close all programs.

        2. Click Start, type Uninstall in the Search box, and then click Uninstall a program.

        3. Double-click Microsoft .NET Framework 4 Client Profile.

        4. Select Repair .NET Framework 4 Client Profile to its original state, and then click Next.

        5. When the repair is complete, click Finish.

        6. Click Restart Now to restart your computer.

        7. To install the latest Windows updates, click Start, click All Programs, and then click Windows Update.

    2. Go to the Windows Downloads website, manually download and install the .NET Framework 4 updates

    3. Use to reinstall .NET Framework 4


    Please Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

    For more information about the .NET Framework Cleanup Tool, go to the .NET Framework Cleanup Tool User's Guide blog post

    Hope this helps.

    Vincent Wang
    TechNet Community Support

    Monday, April 29, 2013 7:08 AM
  • Thank you, Vincent.  Shortly after I posted my question I discovered the dotnetfx cleanup tool.  I used it to uninstall .NET Framework 4, which succeeded.  Then I downloaded and installed a fresh copy of .NET Framework 4 Client Profile, and my problem was solved.

    I had previously tried to use the Control Panel to uninstall or repair the .NET Framework 4, to no avail, but the cleanup tool removed it completely.

    I very much appreciate your response, which would have led me to the solution if I had not already stumbled upon it.

    Gary Theall (JeLeDoux)

    Wednesday, May 01, 2013 3:41 AM
  • Hi,

    Glad to hear you have solved this issue.


    Vincent Wang
    TechNet Community Support

    Wednesday, May 01, 2013 7:01 AM