none
Group Policy For Shortcuts on Desktop RRS feed

  • Question

  • Hi All,

    I am trying to add a shortcut to a users desktop. I have tried to add a shortcut to notepad, add a url to Microsoft.com and various other things to try to get the shortcut to appear.

    GPRESULT appears to say the policy is not being applied.

    I tried in my test enviroment and it worked.

    Then to further narrow the problem down I created a new user on the server, logged in as that new user and the policy was applied and the shortcut showed up. It seems to be just existing users that the shortcut is not appearing.

    What could this be?

    To further confusing things, gpresult /r did not show the policy for either the working user or the user that its not working?

    Tuesday, September 17, 2019 6:35 AM

All replies

  • Hi,

    Before going further, I would appreciate your help in clarifying the following situations:

    The new users and the existing users are in the same OU,right?

    If the following gpresult screenshot you provided is for the real product environment ? If yes,the gpo was applied (yellow content).

    If not , please run :gpresult /h c:\gpreport.html and check the details.

    Also,when you run gpupdate /force, any errors happened?

    If possible , please share a screenshot .

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, September 17, 2019 7:51 AM
  • Hi,

    Before going further, I would appreciate your help in clarifying the following situations:

    The new users and the existing users are in the same OU,right?


    Your correct it does show the GP as applied. That is the new user. I have double checked the existing users do no show the policy in GP result.

    Yes, they are in the same users "folder" under the OU.

    The Forticlient software is installed for the user, so the path in the shortcut is valid.



    Tuesday, September 17, 2019 8:05 AM
  • Hi,

    I would recommend you restart the client , and run gpresult /h c:\gpreport.html 

    If possible , please share a screenshot.(Tip: If private information is involved in the screenshot, it is recommended to blur sensitive information.)

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, September 17, 2019 9:04 AM
  • Hi,

    I would recommend you restart the client , and run gpresult /h c:\gpreport.html 

    If possible , please share a screenshot.(Tip: If private information is involved in the screenshot, it is recommended to blur sensitive information.)

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, September 17, 2019 9:48 AM
  • Hi,

    I think it need a reboot.Now it is shown in the Gpresult.

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, September 18, 2019 1:21 AM
  • That is true, but it remains that there is nothing on the desktop.
    Wednesday, September 18, 2019 1:33 AM
  • Hi,

    If possible, please show details of setting for the shotcut gpo in the gpresult /h.

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Wednesday, September 18, 2019 2:27 AM
  • Wednesday, September 18, 2019 3:07 AM
  • Hi,

    Sorry for did not say clearly, could you please show the details of the shortcuts policy under the settings :

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, September 18, 2019 5:34 AM
  • I dont appear to have Settings > Policies > Windows Settings > Security Settings > Account Policies?


    Wednesday, September 18, 2019 8:22 AM
  • Hi,

    Login as a new user and exiting user ,create the the gpresult /h report.html, show the details as following (in my lab)

    

    Check the difference between the new user and the exiting user.

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, September 18, 2019 8:50 AM
  • Ok here is the image side by side for both users.

    I see that a folder redirection on one user is the issue. Is there a better location to use than 'Desktop' ?

    Wednesday, September 18, 2019 9:45 AM
  • Hi,

    Based on my experience, it may related to your failed folder redirection.I would recommend you fix this issue first .


    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, September 24, 2019 5:55 AM
  • Hi,

     

    Just want to confirm the current situations.

     

    Please feel free to let us know if you need further assistance.

     

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, September 26, 2019 8:42 AM