none
Windows 10 & WD My Cloud EX2 RRS feed

  • Question

  • I have been told that the Western Digital My Cloud EX2 NAS probably would not work with Windows 10. After researching it appears a lot of the NAS units are having issues. Is there a general work around or a fix in the process as WD said they did not know when something would be accomplished on there end. This is a real problem as I was planning on taking advantage of the free upgrade offer to Windows 10 and I just purchased this highly rated NAS an fact I haven't even gotten it out of the box. Thanks.
    Sunday, August 9, 2015 1:39 PM

Answers

  • The best way is to find a PC running Windows 10 (if possible and it is safe PC) and try your device and see whether it works or not.

    You may contact the manufacturer's support and check compatibility status, you may take a look at Windows 10 Troubleshooting: Compatibility Issues

    Sunday, August 9, 2015 2:38 PM
  • To Ellisfitz:

    You're not going to know for sure unless you try it like Cyber_Defend_Team suggested.

    To wixboy2189:

    Did you try using a local account instead of a MS account like graye suggested?  If you did and it didn't fix the issue, then try the following:

    Go to "Control Panel -> Programs"
    Select "Turn Windows features on or off" (requires admin rights)
    There you will find "SMB 1.0/CIFS File Sharing Support". Enable it! 

    Try accessing your WD NAS after that and see if it works; you may want to reboot the devices as well after this change.  Let us know if you tried this and what the results were.


    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.

    Friday, August 14, 2015 3:27 PM

All replies

  • The best way is to find a PC running Windows 10 (if possible and it is safe PC) and try your device and see whether it works or not.

    You may contact the manufacturer's support and check compatibility status, you may take a look at Windows 10 Troubleshooting: Compatibility Issues

    Sunday, August 9, 2015 2:38 PM
  • What the heck are you talking about?

    There's nothing in Windows 10 that changes the way you access a NAS.   Every NAS on the planet that supports the SMB protocol should work just fine on Windows 10.

    Are you perhaps talking about the "management console" inside the NAS... that you get to via a browser?  If so, then just use IE11 (instead of Edge).

    Sunday, August 9, 2015 3:52 PM
  • What the heck are you talking about?

    There's nothing in Windows 10 that changes the way you access a NAS.   Every NAS on the planet that supports the SMB protocol should work just fine on Windows 10.

    Are you perhaps talking about the "management console" inside the NAS... that you get to via a browser?  If so, then just use IE11 (instead of Edge).

    My apologies... I see that others are having similar problems.

    This issue appears to be centered around the Win10 account "type".  Folks have discovered that the issue only happens when signing in with a Microsoft account.  I use a local account (or a domain account), so I have never seen these problems.

    So, again... my apologies for my snarky remarks 

    Monday, August 10, 2015 2:28 PM
  • Hi,

    For this problem, it would be better to contact Western to confirm this problem.  

    On the other hand, if NAS problem occurs after upgrade to Windows 10, it would be better to post the detailed error message here. 


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, August 11, 2015 7:59 AM
    Moderator
  • I have a similar issue with my WD NAS. It worked perfectly well under Windows 8.1, but is unreliable since my upgrade to Windows 10.

    The issue is that the network does not recognize it. I can successfully ping its IP.  I can reach the NAS webpage and run diagnostics. I can stream remotely from other devices. However, the NAS does not show up on the network on my Windows 10 Surface. When I try to directly access it, I get the Network Error "Windows cannot access \\10.0.1.141." I am able to access other PC's/devices on the network without issue.

    Also, there have been a handful of times it has shown up in the Network, but it does not stay there.

    I appreciate any help you can provide.

    Friday, August 14, 2015 3:09 PM
  • To Ellisfitz:

    You're not going to know for sure unless you try it like Cyber_Defend_Team suggested.

    To wixboy2189:

    Did you try using a local account instead of a MS account like graye suggested?  If you did and it didn't fix the issue, then try the following:

    Go to "Control Panel -> Programs"
    Select "Turn Windows features on or off" (requires admin rights)
    There you will find "SMB 1.0/CIFS File Sharing Support". Enable it! 

    Try accessing your WD NAS after that and see if it works; you may want to reboot the devices as well after this change.  Let us know if you tried this and what the results were.


    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.

    Friday, August 14, 2015 3:27 PM
  • Thanks for the quick reply!

    I tried the steps you recommended. Unfortunately, the problem exists with a local account or my MS account. The SMB support was already enabled.

    Any other thoughts?

    Friday, August 14, 2015 4:09 PM
  • Right off the top of my head, the only other suggestion I have is to verify if your WD NAS device is up to date on firmware.

    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.

    Friday, August 14, 2015 5:38 PM
  • That worked. The device webpage reported that it was up to date this morning, but after you mentioned it, I checked the WD website to be sure. WD released an update in May (v04.01.04-422). I ran the update and the NAS shows up, now. It required me to reauthenticate a device username/password, and now it seems to be working normally.

    Thanks!

    Friday, August 14, 2015 8:28 PM
  • For the record to whomever is having the same problem in 2019. This is now due to insecure login being blocked by default. Need to run: gpedit.msc and change as follows:

    0. Assign static IP to the NAS otherwise the IP will chaneg every time you reboot even for firmware update
    1. Run: gpedit.msc
    2. Go to: Local Group Policies -> Computer Configuration -> Administrative Templates -> Network -< Lanman Workstation and Enable insecure gues logons
    3. Right-clik on Computer, select Map Network Drive to: \\your static NAS IP\Public

    Sunday, February 24, 2019 11:42 AM