Windows 7 advanced sharing settings not sticking


  • In Windows 7, I can't get my advanced sharing settings to stick. I changed my settings in Public Profile (am trying to turn 'off' Network Discovery & File and Printer Sharing), but they don't stick. The same applies if I try to change the Home profile. I change the settings to 'off' and click save changes, then go back in to check, but they've reverted back to 'on'.

    What I've tried so far is...

    - I tried changing the settings being in a Homegroup but they didn't stick. I then left the Homegroup and tried again, but still no joy - they always revert to 'on'.

    - Ran System File Checker, but nothing came up

    - Created a new user account and tested to see if I could change the settings under this account. Still no joy.


    Please help!

    Thanks in advance :-)

    Sunday, June 26, 2011 6:02 PM

All replies

  • Hi,


    According to your description, the issue could be related with firewall restriction.


    I suggest to perform these tests to troubleshoot the issue:

    1 Logon with Clean Boot on Windows 7


    2 Temporally disable firewall or anti-virus programs


    3 Try to use following commands:

    netsh advfirewall firewall set rule group="File and Printer sharing" new enable=no
    netsh advfirewall firewall set rule group="Network Discovery" new enable=

    If the issue persists, there might be some components corrupted, you can try to perform an in-place upgrade to fix the issue:


    Hope that helps.




    Leo   Huang



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, June 28, 2011 6:11 AM
  • Hello Leo,

    Thanks for the advice, unfortunately I'm still not having any joy with your suggestions.... I'll keep tinkering around for a bit longer and may well do a fresh install if I come up blank. If I find a solution, I'll post it here.



    Sunday, July 03, 2011 8:13 AM
  • Are you certain you are Local Admin?
    MCTS, MCP, A+ Microsoft Partner
    Sunday, July 03, 2011 2:53 PM
  • "Network discovery requires that the DNS Client, Function Discovery Resource Publication, SSDP Discovery, and UPnP Device Host"

    I opened the Services MMC snap-in and saw that the following services were disabled:

    • Function Discovery Resource Publication
    • SSDP Discovery
    • UPnP Device Host

    Enabling and starting these services did the trick and now Network Discovery is enabled and I can see other servers. 

    Tuesday, March 12, 2013 12:55 PM