none
"Open Microsoft Edge with" is grayed greyed out, cannot change RRS feed

  • Question

  • I have some users that cannot change the setting "Open Microsoft Edge with".

    All users are local administrators.

    All users are in the same OU and have these Edge user settings:

    Configure Favorites Bar
    Set default search engine
    Set New Tab page URL

    RSoP confirms that these Edge user settings have been applied.

    There are no Edge computer policies and all computers are build 1809.

    How do I allow all users to change the setting "Open Microsoft Edge with"?

    Thank you in advance!

    Update: Deleting the user profile and recreating it resolves this problem but it is not an acceptable solution.

    • Edited by The Victim Thursday, November 14, 2019 6:05 PM
    Thursday, November 14, 2019 5:38 PM

Answers

  • It must have permanently changed a file setting in the user profile because I fixed it by deleting the profile.

    I need to know how to undo the policy setting or find the persistent file setting in the profile so I don't have to delete the entire profile to fix this problem.

    It seems the corresponding registry entry remain intact and this might have caused the issue. You may refer this article to remove the registry entry and see if that makes a difference:

    https://www.kapilarya.com/fix-open-microsoft-edge-with-greyed-out-in-windows-10

    Regards.

    Note: Included link in this reply refers to blog post by a trusted Microsoft MVP. 


    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    • Marked as answer by The Victim Tuesday, November 19, 2019 5:21 PM
    Tuesday, November 19, 2019 4:59 AM

All replies

  • Hello,

    Please refer this Microsoft documentation and check if related/conflicting policies are in effect:

    https://docs.microsoft.com/en-us/microsoft-edge/deploy/group-policies/start-pages-gp#configure-open-microsoft-edge-with

    Hope this helps!


    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Friday, November 15, 2019 7:11 AM
  • Hi,

    According to your description, you could try to configure the group policy.

    Computer Configuration\Administrative Templates\Windows Components\Microsoft Edge\

    version 1809:
    Please note: When you enable this policy (Configure Open Microsoft Edge With) and select an option, and also enable the Configure Start Pages policy, Microsoft Edge ignores the Configure Start Page policy.

    https://docs.microsoft.com/en-us/microsoft-edge/deploy/group-policies/start-pages-gp

    Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, November 15, 2019 7:25 AM
    Moderator
  • Thank you for your replies.

    I only have the policies I listed above in RSoP for computer and user so there are no conflicts.

    Previously, I enabled "Configured MS Edge to open" but it is now not configured.  It must have permanently changed a file setting in the user profile because I fixed it by deleting the profile.

    I need to know how to undo the policy setting or find the persistent file setting in the profile so I don't have to delete the entire profile to fix this problem.
    Saturday, November 16, 2019 4:19 AM
  • It must have permanently changed a file setting in the user profile because I fixed it by deleting the profile.

    I need to know how to undo the policy setting or find the persistent file setting in the profile so I don't have to delete the entire profile to fix this problem.

    It seems the corresponding registry entry remain intact and this might have caused the issue. You may refer this article to remove the registry entry and see if that makes a difference:

    https://www.kapilarya.com/fix-open-microsoft-edge-with-greyed-out-in-windows-10

    Regards.

    Note: Included link in this reply refers to blog post by a trusted Microsoft MVP. 


    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    • Marked as answer by The Victim Tuesday, November 19, 2019 5:21 PM
    Tuesday, November 19, 2019 4:59 AM
  • It must have permanently changed a file setting in the user profile because I fixed it by deleting the profile.

    I need to know how to undo the policy setting or find the persistent file setting in the profile so I don't have to delete the entire profile to fix this problem.

    It seems the corresponding registry entry remain intact and this might have caused the issue. You may refer this article to remove the registry entry and see if that makes a difference:

    https://www.kapilarya.com/fix-open-microsoft-edge-with-greyed-out-in-windows-10

    Regards.

    Note: Included link in this reply refers to blog post by a trusted Microsoft MVP. 


    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    I just finished deleting and recreating the profiles that were created when this setting was enabled so I don't have anything to fix now.  However, the fix you provide appears to be a viable solution.  Hopefully, I won't need ti but I will give you credit for the answer.  Thank you for sharing!
    Tuesday, November 19, 2019 5:21 PM
  • ^^ Glad to help!

    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Wednesday, November 20, 2019 4:21 AM