Bluetooth Drivers for Vista


  • I installed the drivers for a USB bluetooth dongle. I don't think it's compatible with Vista because it says it's having problems with installing the drivers. I contacted the company (Blue Solei) and they haven't made any new drivers. is there anything i can do to get the bluetooth to work?
    Wednesday, September 27, 2006 12:08 AM

All replies

  • You aren't the only one. a LOT of people can't find drivers and when they do the entire system is known to either freeze or crash into a blue screen. Microsoft need to sort this out ASAP.
    Tuesday, March 06, 2007 8:48 PM
  • I"m using an old Belkin bluetooth usb adapter model f8t003 and I just plugged it in and Vista automatically detected it and installed drivers for it and it works great.

    Monday, March 12, 2007 9:31 AM
  • I don't think it's all bluetooth things that Vista has issues with.  I know that there has been talk of Bluetooth Headsets not working in Vista.  I believe the headset codecs were removed prior to final launch of Vista.

    I, for example, have a bluetooth Dell keyboard and mouse that functions flawlessly on Vista.  However, my bluetooth headset will not work and keeps asking for more drivers.  Drivers that don't exist. :D

    I'm hoping someone will address this issue soon.

    Monday, March 12, 2007 10:41 PM
  • Anyone have an old Vista RC2 (X64 please!) DVD laying around that they can grab all of the bt*.* files from?

    Then we can drop them into the final version and volia! we have support for it!

    Friday, March 16, 2007 5:59 PM
  • I'm having the same problem with a Plantronics headset in Vista. Any news on when this will be fixed? I can't say that seeing the blue screen every couple days is making me excited about Vista.
    • Proposed as answer by guru_paresh Wednesday, April 08, 2009 6:49 PM
    Saturday, March 24, 2007 8:40 PM
  • I bought a new Kensington Bluetooth USB Adapter 2.0 and cannot get it to work.  Are there more drivers somewhere else or is it just the Vista incompatibility issue?
    Sunday, April 01, 2007 8:22 PM
  • I have the same one (Kensington)... Any luck on finding drivers?... Been lookin all over can't find anything!
    Tuesday, April 03, 2007 12:28 AM

    Whith a hard work blue tooth usb adapter can be installed whit a new drv given by Kengsinton
    Sunday, April 08, 2007 12:42 AM
  • - is the posted update from Broadcom
    Monday, April 09, 2007 8:10 PM
  • Yeah, it doesn't work.  Tried it.  The drivers install but aren't signed, so you get tons of popups, and the driver won't load once you reboot.
    Tuesday, April 10, 2007 2:40 AM
  •  -- the new drivers are not signed and have never been or probably never will be signed by Broadcom -- that is another very long story --- however the drivers work fine -- with the 20 unsigned driver prompts you need to go through and voila! your device is ready to use! -- I have paired with several phones and performed file transfers - I have used my b/tooth headset as a gateway on skype -- so with patience they do work.


    My configuration:

    vista/business 3.2 ghz P-4 on MSI m/board with SATA-2 drives

    Tuesday, April 10, 2007 11:07 PM
  • bluesoleil have vista compatible drivers, i got one today for my USB dongle. check out there website
    Wednesday, April 11, 2007 10:45 PM
  • For your information the Vista driver for Kensington 2.0 are supposed to be available the last week of April info from Kensington support.
    Sunday, April 15, 2007 2:49 AM
  • A friend of mine showed me this link when I complained of not being able to use my BT USB adapter with Vista. I've been trying all day to install it. I'm getting a weird error where Vista says my ...


    "Bluetooth device security canot be verified. Please make surethat your device is ot tampered with and try to upgrade again. If you feel this is a legal device then please contact support."


    I bought this new from an electronics retailer. The package had not been opened, and IIRC this same error happened when I used the CD that came with the dongle. Is anyone else getting this error? I'd take it back and exchange it if I thought it would make a difference, but I think it is some kind of error.


    BTW, I called Kensington tech support, and the person there said the Vista driver would be coming out mid-May. This was a few days ago.

    Monday, April 30, 2007 5:07 AM
  • i got the same message after a botched install attempt. i was able to clear it and try again by using system restore to go to where i was before i tried to install it, and it let me try again. boy this is a debacle. i still cant get my thingy to work either Sad
    • Proposed as answer by guru_paresh Wednesday, April 08, 2009 6:49 PM
    Thursday, May 03, 2007 4:24 AM
  • Like the origional poster, ive got a bluesoliel usb bluetooth. Ive been tryin to ge tthis to work since i got vista..founf this link this morning..hope it helps!
    Saturday, May 05, 2007 2:22 PM
  • Do these work with the kensington usb dongle??   I am

    having the same problems as everyone else.. except i have my drivers installed, and i get btstack errors, or it says that it cant find my bluetooth device... I think they are jerking us around on the drivers, they told me in the begining of april it would be available  by may



    Tuesday, May 08, 2007 12:17 PM
  • I am not a techie at all but thought I would share with you a solution many are using to get their MP3 players (et al) working with vista. I was having a heck of a time until i followed this procedure and removed the INFCACHE.1. I was hoping this would do the trick for my Kensington Bluetooth adaptor (which causes everything to freeze when inserted); but it was not the solution. Nevertheless, when the driver is available; i wonder if what is described below will continue to be a problem:



    When trying to install a new device (like a USB mouse, printer, video card, etc.), Windows Vista might report that there is “no driver found for you device [sic]” and/or will not display the pre-installed Vista OEM drivers. Even by manually selecting the driver, you will still get the “no driver found…” error. This also tends to happen with HP printers (as we know their drivers are bulky and complex). You will get a red X at the end or it won’t find the drivers - again.

    This is caused by a corrupted INFCACHE.1 file. This file is hidden, has restricted access, and can be found in “c:\windows\inf”. This file stores the location of drivers and their INF files.

    Delete this file and it will force Windows to rebuild the INFCACHE.1 file the next time Windows searches for drivers.
    To delete this file, you have to set the security permissions of it to allow Full Control for the User Group Administrators or full control for your account. Here’s the complete how-to:

    1. Open a Windows Explorer window (right click Start> Explore)

    2. In the address bar, type c:\windows\inf and press Enter

    3. Right click on the file INFCACHE.1

    4. Select Properties

    5. Click on the “Security” tab

    6. Click “Edit” to edit permissions

    7. Click “Add” to add User Groups

    8. Type “Administrators” in the User Groups field and click ok

    9. Set Administrators to “Full Control” and click ok

    10. Move or delete the file “INFCACHE.1″

    11. Reinstall a device to force Windows to rebuild the “INFCACHE.1″ file (not the one you were having problems with)

    And try again. This can happen several times in a row, but repeat the steps needed to delete the file and try again. Eventually it will work, trust me.

    I wonder if Gates says that to his family members, “Eventually it will work, trust me.”

    Monday, May 14, 2007 12:05 PM
  • Thanks for that CelineH.


    My Belkin Bluetooth Dongle now appears to work perfectly. Only needed to move that file once and everything auto-installed straight away.




    Monday, May 14, 2007 4:51 PM
  • Is there any way to setup bluesoleil dungle without installing the firmware, I look to use it as a network adapter without the application interface, somone has an idea ?
    Wednesday, May 16, 2007 8:45 PM
  • I have the same problem with the same device, and they sell it as windows vista compatible.  I can't believe that is not possible to configurate something so simple, but even worst that HEWLETT PACKARD sells a laptop of 1.200 euro without a simple bluetooth!!
    Thursday, May 31, 2007 9:56 PM
  • I bought a dongle from an etailer it the blue soliel thing and the vista drivers say its pirated and I only get 5mb download. I think this is a method the manufacturers are trying to get us to pay for new updated drivers. Its outrageus. I have found a way around this.
    Friday, June 01, 2007 10:13 AM
  • i have problems with belkin bluetooth usb adapter


    Sunday, June 03, 2007 10:51 AM
  • here drivers for belkin vista
    Sunday, June 03, 2007 1:32 PM
  • I have now went through 4 USB to bluetooth and none work

    I'm ordering a belkin f82012  because it seems to be the only one that works with Vista without problems

    Sunday, June 10, 2007 2:17 AM
  • Thank you thank you Celine, this fixed my issue.
    Saturday, June 23, 2007 4:55 AM
  • Here is the link for the Bluetooth Driver Dongle Driver.

    I downloaded and installed it already. It works.

    Sunday, July 01, 2007 12:23 AM
  • Hi Daviangel, I have the same Belkin USB dongle F8t003 but my does not like vista. can you please advise how u set this up to work? Thanks. GP

    Monday, July 02, 2007 3:18 AM
  • Is there anyth similar for BlueSoleil.. i followed one of the links but still my old USB dongle doesn't work because software itself cudn't be installed because it could not write to a lot of registries.
    Monday, July 02, 2007 4:25 AM
  • I have a DELL M1210 PC running on Vista 32, and found out that my Bluetooth headset needs other drivers to be installed which I have been unable to to locate. Have you had any lock with this issue? If so, please let me know where I could locate neccesary drivers. TKS.
    Wednesday, July 11, 2007 2:39 PM
  • This is a little complicated and it takes some time, but it works.

    Follow the instructions here:

    Saturday, July 14, 2007 1:08 AM

    Hi,  I also need an answer on how to get the drivers for belkin f8too3.  have you had any luck  yet?


    Sunday, July 15, 2007 1:10 PM
  • Thanks a lot Celine, I'm no computer freek as well, got my vista yesterday and just wanted to download my photos from the phone. Tryed downloading all sorts of stuff but nothing helped, and i was afraid i would mess something up and download some ***.

    I actually downloaded bluesoleil, but device didnt work cause it would recognise it....

    When i deleted the Cache file like you said, i pluged the bluetootth out and putting it back in blusoleil picked it up immediately...yupi!

    Thanks again... i reccommend!


    Tuesday, November 06, 2007 10:31 PM
  • thank you turkish dude.
    i am from India.
    i am having vista ultimate edition and all sorts of fancy wista softwares but i didnt found bluetooth drivers anywhere. i downloaded the driver from the link u provided and i tested it on XP . its working!!!
    now i will test it on my pc on vista. hope it works...
    but thank u ance again....
    bye and let us all know about such new downloads..
    bye the way i am also having problem with my kaspersky activation key.
    it is saying that my key is blocked.
    can u plz mail me some links where i can get kaspersky 7.0 keys. if u have have plz do mail me on


    Friday, December 07, 2007 7:24 AM
  • I don't even get that far. After waiting through the download, and "preparing to install" I just get "failed to complete installation".
    Wednesday, December 26, 2007 7:24 AM
  • I had no problem installing Blue Solei, i bought usb last week with vista version, cause my bluetooth speakers and and head set wern't working with my built in blue tooth, but usb works fine now with blue solie make sure you turn bluetooth off when your installing, and dont have dongle in usb till it say's to insert.

    Saturday, January 05, 2008 2:17 AM
  • elder topic.. but any how, this  did the trix for me Wink
    Friday, January 18, 2008 12:11 AM
  • Anybody figure out anything more with the Kensington 2.0 Bluetooth adapters? I downloaded the updated driver installation file from Kensington's page and upon initializing the install wizard it gave an error reading "Your Bluetooth Software license does not include use on this operating system. [-350]".

    I'm using Vista Home Premium, and Kensington's site claimed that the update was for Microsoft Vista operating systems.

    Am I the only one still having problems after the update?
    Wednesday, February 20, 2008 5:42 AM
  • I am glad that I am not the only one, so far I have gone through all the possible Blue Soleil downloads with no success, my Vista 32 Bit system does not even recognise the bluetooth dongle!! Suffice to say that after 4 hours of trying the dongle is no in 4 pieces! Blue Soliel on the other hand dont seem to offer much support for the units that they manufacture. OK what brand of dongle should I buy for compatibility? Any suggestions welcomed, thanks all.


    Saturday, March 08, 2008 5:51 PM

    Its Urgent Friend. I need your Blutooth Drivers


    Thanking you.

    Thursday, July 10, 2008 2:43 PM
  • Ok, after hours of trying to get a new BT USB to work with Vista, it works with a catch.

    Cables Unlimited (and probably all other inexpensive bt usb devices) license the driver from a company called

    BlueSoleil has gotten very greedy it seems. They provide many variations of their drivers (i.e. 1.x 2.x 3.x 4.x 5.x) with countless manufacturers on a small cd. Only thing is that those drivers don't work with any of the current OS's. You probably have to go to win95 or further back for it to actually work.

    They damn well know this as in the USB BT adaptor I bought today at fry's (January 13 2009) has a driver that is more than 4 years old. And guess what? IT DOESN'T WORK. So what does BlueSoleil do? They send you to their website explaining that if you want a driver that works, you have to dish out almost 20 Euros (At the current exchange rate, that would be $26.79)

    So you can download the latest driver as a demo, it's at version and that version works beautifully with Vista.

    I wish there was some programmer that would step up to the plate, or Microsoft. Where are you?

    Wednesday, January 14, 2009 4:43 AM
  • I never thought after 2 days of searching on various threads that i could actually found the solution.  I tried various "worked" solutions and it didn't work for me.  Finally, I search and found out there is something called Bluetooth driver for Vista.  I downloaded it and it worked.  The only thing is, you may have to pay for it.  The reason why you may depends on which version you get.

    Bluesoleil v.5 is free (because it didn't require serial #), Bluesoleil 6 does and it costs like 20 euros. 

    Since I'm using Bluesoleil 6 (Due to a product called Bluesoleil VOIP required v.6), I'll show you how I did it. 

    1. download Bluesoleil 6
    2. extract and find the file "setup"
    3. double click setup file and you are on cruise control
    4. for v.6, they will ask you for serial #, so if you want to use v.6, pay up, otherwise, try v.5

    When I plug in the BT adaptor, it ask to search for driver and it was successfully identify the driver and "happy ever after"

    I use a regular BT headset for mobile phone to pair it with my computer so I can use Skype, I broke 2 corded headset so it was something I really want. 

    DISCLAIMER:  I DON'T WORK OR KNOW ANYONE AT BLUESOLEIL.  My suggestion with this Vista/BT driver problem is to dump Vista and go Window 7... I hate Vista and yes, I dumped all my Microsoft stocks long ago.

    Thursday, May 14, 2009 5:51 AM
  • I have  Vista 32bit and I have enough of the compatibility problems. I also have a Bluetooth Dongle that wont work, I have tried, Toshiba and Broadcom drivers installers and they both crash on setup.

    If Microsoft cant/wont fix this problem, then where does the end user stand. Better yet, if I was computer illiterate, I'd be up @h!t creek.

    My solution, not to give in and buy Windows 7. Buy a Mac or run Linux (IF you have the time to learn a completely different OS).

    My windows days are over. NOTHING WORKS!!! GRRRRRR

    Friday, October 29, 2010 2:49 AM