locked
Receive Window Auto-Tuning Level cannot be changed from highlyrestricted in SP2 RRS feed

  • Question

  • I am running vista 64 home premium and have been suffering from bad internet speeds that i did not get when using a different system running xp...i have tried a lot of tweaks to boost the speeds but have never really been able to get maximum speeds like i could on my old system...

    i managed to get a reasonable speed by doing a couple of tweaks with the tcp global parameters

    anyway here is my problem

    the one that made a most of a change was the 'recieve window auto-tuning level' that i had previously been able to change using a command rompt run as admin...i had set it to normal and my internet speeds seemed improved.

    i upgraged to SP2 and on doing so my download speeds dropped by around 2Mb/s i checked my tcp global parameters just to see if they were still the same and to my suprise the  'recieve window auto-tuning level' had changed to 'highlyrestricted i tried to change the setting to normal using command prompt as admin...i got the ok and checked again, the setting was still set at highlyrestricted, i also tried disabling it using the command prompt...nothing changed, even when rebooting my machine.

    I guessed that it was possibly due to the SP2 so i uninstalled it...as soon as i did the settings could be changed again and speeds increased...just to make sure it definatly was the SP2 i installed again ton find the settings highlyrestricted yet again...

    how can i fix this problem without uninstalling SP2... it is it seems that this is causing my slower connection everytime i install the update
    Friday, June 5, 2009 2:08 PM

All replies

  • below the tcp global parameters i also get this message:-

    ** The above autotuninglevel setting is the result of Windows Scaling heuristics

    overriding any local/policy configuration
    Friday, June 5, 2009 2:12 PM
  • This is definitely a bug! I found plenty of users in the newsgroups asking exactly the same question! Now come on Microsoft, this has to be adressed ASAP!
    regards
    Joerg

    Sunday, June 7, 2009 8:53 AM
  • Did a little trial-and-error-research...GOT IT!

    Before setting autotuninglevel, you have to netsh, interface, tcp and then
    SET HEURISTICS DISABLED

    regards
    Joerg
    • Proposed as answer by 7bit Tuesday, January 5, 2010 1:28 AM
    Sunday, June 7, 2009 9:35 AM
  • Sunday, June 7, 2009 9:50 AM
  • thank you for helping me with the problem, this is extremely useful, i really appreciate your replies
    Monday, June 8, 2009 2:47 PM