windows XP sp3 update error c:\ntldr


  • When I attempt to install sp3 I recieve the error message "error the file c:\ntldr is open or in use by another application.  Close all other Applications and press retry."  I have tried closing all open applications and still recieve the error message.
    Tuesday, June 03, 2008 8:39 PM

All replies

  • Try this:


    - if you have not already done so, download the stand-alone version of the SP3 installer from

    and save it to a known place on hard disk;

    - run "msconfig", select "Diagnostic Startup" and re-boot Windows;

    - run the SP3 installer from the place you stored it on hard disk;

    - run "msconfig" to re-select "Normal Startup" and reboot Windows.

    Tuesday, June 03, 2008 9:44 PM
  • I have the same problem, I tried the suggestion above but I continue to get the same Setup Error message.  Any other ideas?  Thanks
    Thursday, September 04, 2008 9:26 PM
  • Check the permissions on ntldr!  I found that the ownership of the file was wrong . Changing the ownership & giving it to administrators allows you to add full permission for the appropriate accounts. Once I corrected these, SP3 installed. 


    For those who may need the guidance - You'll need to reveal hidden files,  Go to My Computer, double click C:, tools, folder options, view, untick the hide stuff boxes & dot the show hidden, apply & ok. You can scroll down C: till you see ntldr, right click on the ntldr file, properties, security tab, advanced button, Ownership, & choose Administrators. Make sure administrators have full control on the security tab.


    Hope this helps!
    Wednesday, September 10, 2008 7:30 AM
  • I tried both solutions (downloading the installer and doing te administrator thing), but it still doesn't work. So, I have the installer (in my language, Dutch) and everytime I try to install SP3 it shows the same error: "d:\ntldr is open or used by another program, please close... blablabla" (curious tough: the ntldr file is in my c directory under windows-softwareDistribution-download-and a map with many numbers and letters).


    Does someone have another solution (which hopefully works)?



    Thursday, December 04, 2008 1:58 PM
  • I had exactly the same problem as serendib and tried in vain to fix it and finally gave up.   One thing that I didn't do was go in and verify the security settings of the file -- I just looked at the "Owner" attribute in Windows Explorer and verified it was Administrators.

    Recent I though would give it another try.  I finally realized that I had to go into Windows Explorer  Tools->Folder Options->View and scroll down through Advanced list and uncheck "use simple file sharing"

    I then went to the ntldr file and right clicked, selected "Properties" and then clicked on the "Security" tab.   I immediately got an error message saying "The permissions on ntldr are incorrectly ordered, which may cause some entries to be ineffective.  Press OK to continue and sort the permissions correctly, or Cancel to reset the permissions."  I clicked Cancel, and the Security window opened and showed full permission on the file for everyone (I don't know if this is a good thing --- but I left it that way).  I also repeated the process on some of the other files in c:\  such as NTDETECT.COM, NTLDR.PE, and NTLDR.XP

    I was then able to run the XP SP3 update without any problems.

    Hope this helps!
    Thursday, October 22, 2009 8:13 PM
  • I don't have the permissions issue as you describe above.  I get no error messages over permissions, all permissions are correct. I see not microsoft articles over this issue and see this issue all over the internet.  Seems Microsoft knows they have an issue and FFR is not an option.  I am trying to update the Tablet PC and Microsoft also does not make an ISO for this to download.

    Any other Ideas?
    Saturday, November 14, 2009 1:31 AM
  • Hi I know this is an old thread, but i just wanted to say thanks to stressless who posted this, this solution worked for me for those who would like to know and might read the thread later on like me

    i was busy installing sp2 on server 2003

    Tuesday, June 14, 2011 9:09 PM