none
IPP printing problem in Windows 7 SP1 RRS feed

  • Question

  • Dear All,

       I install a linux box to be a printer server by CUPS.
       IPP printing is working in Windows 7 with authentication.

       After upgrading to Windows 7 SP1 IPP printing is failed.

       Key messages are from /var/log/cups/error_log
    D [03/Mar/2011:18:09:16 +0800] cupsdAuthorize: No authentication data provided.
    D [03/Mar/2011:17:16:03 +0800] Returning HTTP Unauthorized for Print-Job (http://printersrv2:631/printers/4F_Computer_room_HP4515PCL) from 192.168.97.74

       After I remove SP1 IPP printing is working again.
       It should be the problem of Windows 7 SP1


       Thank You for help.
    Friday, March 4, 2011 6:22 AM

All replies

  • Hello,

     

     I can confirm that we are finding the same problem, the only difference is that we use https on 433 instead of http on 631.

     

     Uninstalling the service pack seems to resolve the problem.

     

     I have found that the inetpp.dll used by ipp printing is updated in SP1:

     

    Before SP1 (with all updates): 6.1.7600.16385

    After SP1: 6.1.7601.17514

     

     Does anybody knows which changes have been implemented in this library or the ones it uses?

     

     We are still trying to get more info, if we find something more I will post it here.

     

     Thanks for any help.

    Friday, March 4, 2011 8:09 AM
  • Thanks for the post.  Anyone else with CUPS chime in.  I forwarded this port to interested parties but if you have any type of support contract with MS I suggest starting there as well.
    Alan Morris Windows Printing Team
    Sunday, March 6, 2011 10:46 PM
  • Could one of you install this QFE on Windows 7 RTM and confirm if this version of inetpp.dll is the blocker?

    Inetpp.dll 6.1.7600.20757

    thanks 

    http://support.microsoft.com/kb/2280758

    The print job fails when you try to print to a non-Windows-based IPP server on a client computer that is running Windows 7 or Windows Server 2008 R2


    Alan Morris Windows Printing Team
    Tuesday, March 8, 2011 12:32 AM
  • I'm using Windows 7 Enterprise version.

    Is there any hotfixs for it?

     

    Tuesday, March 8, 2011 2:10 AM
  • Hello,

     

     yes, I can confirm that on a Windows 7 without SP1 with the printer running ok as soon as I install http://support.microsoft.com/kb/2280758 I cannot print because of authentication errors. Deleting the printer and reinstalling doesn't solve anything as it fails when it tries to authenticate.

     thanks,

    Ferran

    Tuesday, March 8, 2011 9:25 AM
  • Hello,

    I have the exact same problem, and can also confirm that its related to SP1 (or an included Update).

    Im using Windows 7 Professional.

    Thanks for help

    Friday, March 11, 2011 12:31 PM
  • What type of authentication are you configuring?

    I was able to print from Windows 7 SP1 to CUPS fine.  I was not prompted for a password so I assume some basic authentication or no authentication .

     

     

     

     


    Alan Morris Windows Printing Team
    Tuesday, March 15, 2011 10:03 PM
  • The following are the lines in /etc/cups/cupsd.conf

       DefaultAuthType Basic
       DefaultEncryption IfRequested

     

    The problem is that: IPP in Windows 7 SP1 does not send out authenticationdata.

     

    Thursday, March 17, 2011 3:53 AM
  • The problem is that: IPP in Windows 7 SP1 does not send out authenticationdata.

    I can confirm this. Using wireshark I can't see any authentication headers send by the windows IPP client.

    Did anyone try to manually replace the affected files with an older version?

    Inetpp.dll

    Inetppui.dll

    Wpnpinst.exe

     

    http://support.microsoft.com/kb/2280758 seems to be related but the HotFix doesn't work with SP1.

    Wednesday, March 23, 2011 3:19 PM
  • I tried but it failed.

    I found the way to replace system files, Inetpp.dll and Inetppui.dll

    The printing system was abnormal.

    Even I copied back these files.

    The only way back to normal was uninstalling SP1.

     

    Thursday, March 24, 2011 3:03 AM
  • I tried it too and it looks like it's working again.

     

    wpnpinst.exe and inetppui.dll have version 6.1.7600.16385.

    There's no need to downgrade them, they had the same version on my old (pre SP1) system. Seems like thy weren't upgraded by SP1.

    I had to downgrade inetpp.dll from 6.1.7601.17514 to 6.1.7600.16385.

    After a reboot everything was back to normal (authentication is working) and so far I didn't notice any problems.

    A copy of the old inetpp.dll(6.1.7600.16385) can be found here: http://www.filesavr.com/BXKER093EJ7T8I9


    Thursday, March 24, 2011 9:04 AM
  • Hi Freddy436

       How do you do that?

     

    I do the following

    takeown /f c:\Windows\system32\inetpp.dll
    cacls c:\Windows\system32\inetpp.dll /G %USERNAME%:F
    net stop "Print Spooler"
    copy f:\inetpp16385.dll c:\Windows\system32\inetpp.dll
    net start "Print Spooler"

    It fails. It seems I break some file perms.

    IPP was gone from the system.

     

    Friday, March 25, 2011 2:27 AM
  • I got it.

     

    @echo on

    takeown /f c:\Windows\system32\inetpp.dll
    cacls c:\Windows\system32\inetpp.dll /G %USERNAME%:F

    net stop "Print Spooler"

    copy f:\inetpp.dll c:\Windows\system32\inetpp.dll
    icacls c:\Windows\system32\inetpp.dll /remove:g %USERNAME%
    icacls c:\Windows\system32\inetpp.dll /grant SYSTEM:RX
    icacls c:\Windows\system32\inetpp.dll /grant Users:RX
    icacls c:\Windows\system32\inetpp.dll /grant Administrators:RX

    net start "Print Spooler"

    pause

    Please replace the f:\inetpp.dll to yours.

     

    BTW: X86 and X64 have dfferent inetpp.dll   BE CAREFULLY!!!

     

    Friday, March 25, 2011 5:32 AM
  • Thanks much for the helpful info.  Wonder when we're going to see a Microsoft response on this?
    Thursday, April 7, 2011 3:38 PM
  • Thanks a lot for this ;)

    Regards

    Friday, April 8, 2011 8:42 AM
  • Microsoft has released a hotfix that can be download from their website.

    http://support.microsoft.com/kb/2616471

     


    Brian M. Amira
    Wednesday, December 21, 2011 9:05 AM