none
Printers "Operation could not be completed (error 0x00000709) Double check the printer name and make sure that the printer is connected to the network."

    Question

  •        

    We are migrating from XP to Windows 7 and using USMT offline to migrate user settings etc.

    Network printers are migrated but on the users first login if the user tries to set their default printer they receive the following error message:-

    "Operation could not be completed (error 0x00000709) Double check the printer name and make sure that the printer is connected to the network."  

    The printer is in fact installed and it is possible to print a test print, just not set the default printer.

    The issue is resolved by restarting the print spooler (or logging out and back in or rebooting or re-installing the printer) so is only an issue during the users first login.                                                                                                                                                                                                                                            

    Is there a way this can be "fixed" or mitigated so users have a totally smooth migration experience at first login?   

    Thanks. 

                                                

    Tom



    • Edited by TomB01 Wednesday, February 08, 2012 4:23 PM
    Wednesday, February 08, 2012 3:32 PM

Answers

  • Hi,

    According to the error message, I assume that the spooler service cannot find out the printer on the network.

    You may set the startup type of Printer Spooler service to Manual or Delayed Start for a test.


    Juke Chou

    TechNet Community Support

    Sunday, February 12, 2012 3:47 PM
    Moderator

All replies

  • Hi,

    refer at this thread it can help you to resolve this problem:

    http://social.technet.microsoft.com/Forums/en/w7itproinstall/thread/4979f1a9-f54e-4c5f-8199-c98315dc53cc


    Oussama Oueslati | System Engineer | vNext Consulting

    Wednesday, February 08, 2012 10:14 PM
  • Thanks Oussama but those solutions are not really relevent.

    The issue we are experiencing is only present during the first login following the migration from XP to Windows 7 when the user tries to set a default printer.


    Tom

    Thursday, February 09, 2012 9:10 AM
  • Hi,

    According to the error message, I assume that the spooler service cannot find out the printer on the network.

    You may set the startup type of Printer Spooler service to Manual or Delayed Start for a test.


    Juke Chou

    TechNet Community Support

    Sunday, February 12, 2012 3:47 PM
    Moderator
  • Tom,

     We are having the same issue.  We are scripting our printing and we have a users thatwhen they loging on they get the same error and if we have them log off and log back on he issues seems to be resolved.  Have you found a fix for this?

    Friday, March 09, 2012 4:58 PM
  • Hello Ginoang,

    We never developed a solution.

    The issue we had was solved by re-starting the spooler service but we settled for the user logging off and back on as a work around.

    Unfortunatly the spooler service cannot be set for a deleayed start but I suspect if it could then that may also have resolved the issue.

    Tom


    Tom

    Monday, March 12, 2012 9:31 AM
  • We're having this same issue in our computer labs.  I've tried every solution in every thread on every message board.  You name it, we've tried it - RegEdit changes, added new GPOs, disabled Point and Print Restrictions, enabled Point and Print Restrictions, applied print-related MS Hot Fixes, etc., etc., etc.

    MICROSOFT, WHY HASN'T THIS BEEN FIXED YET? 

    All we seem to get from Microsoft is "try this - even though we know it won't work"

    Wednesday, May 02, 2012 8:04 PM
  • We've had the same problem and it took me some time to figure out a solution ...

    It was some kind of a permission issue for HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows. The User had only read permissions (or even no permissions - i'm not completely sure about this)

    Furthermore the Device was an "old" device - a buggy devmode2 printer driver that has been deleted some time ago.

    After changing permissions and renaming the key to windows.x and restarting the spooler the problems where gone.

    At the moment i cannot reproduce the error - but maybe this helps someone else.


    btw.: In Acrobat Reader X we've seen the old/deleted printer, which was not visible in the printer and fax control panel

    kind regards,

    mike

    Tuesday, June 05, 2012 4:58 PM
  • I had the same issue and fixed it by editing the corrupted registry key HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

    make sure system, the user and administrator have full control to this key. reboot the computer and you should see the check mark now on the default printer and should be able to make any printer your default printer

    Rayden


    NetOnsite Solutions

    Friday, June 15, 2012 11:03 PM
  • Thank you so much! I searched for so long... Then finally found the solution here! I get full control then i edit the key, reboot, but the issue was still here. I then simply delete the renamed windows.x folder, reboot, then everything's fine!
    Wednesday, July 25, 2012 2:36 AM
  • I had tried the registry edit and deletion, but neither worked for me. What I had to do was un-share the printer then set it as the default, which I was then allowed to do. Just to test, I then re-shared the printer, set a different printer as the default, then set the problematic printer as the default again and the problem had gone.
    Thursday, August 02, 2012 9:53 AM
  • simply rename host computer name, then try to share again


    • Edited by eman shams Saturday, August 04, 2012 7:17 AM
    Saturday, August 04, 2012 6:54 AM
  • I am facing same problem. I cant even set any printer to default. I want to get rid of this error.

    I can take test print from device and printers.  But not from any software, it gives error.

    • Edited by Sanjay_ap Thursday, August 16, 2012 7:50 AM
    Thursday, August 16, 2012 7:45 AM
  • I have The same problems. I can print from application and test page, may view drivers for the printets. But on 3-4 printers i may "Use default", other printers says error 0x000000709.

    Somebody have the issue?


    Friday, September 14, 2012 7:08 AM
  • Have you tried connecting to the printer via IP address using a UNC path rather than the DNS name of the server?  If you're using a Windows 2k8 R2 print sever you may be having the issue described here: http://support.microsoft.com/kb/2546625.  This fixed my similar issue.
    Wednesday, October 17, 2012 1:46 AM
  • Hi.

    I have had the same problem.

    I think it occurs after I tried some things with the UAC User Account Control settings. I set them from "never notify" to "always notifiy" to check the behaviour.

    I had the problem even after setting back UAC to "never notifiy". I had only read permissions on the registry key.

    I think I had the problem since this time (for a longer time...) until I found this solution with the HKCU\...\Windows\-key.

    Renaming of the windows key worked for me, too. :-)

    Thanks a lot!

    Michael

    Tuesday, November 06, 2012 10:00 AM
  • modify permission to allow edit HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

    restart spooler and set the default printer.

    • Proposed as answer by Aurimas N Monday, January 07, 2013 12:15 PM
    Thursday, January 03, 2013 6:05 PM
  • Wanted to post exactly what geklo has posted.

    This worked for me.

    Monday, January 07, 2013 12:20 PM
  • Hello Oussama, i ma having exactly the same problem stated above. what are the steps do i need to take to resolve my problem.
    Friday, January 11, 2013 12:00 PM
  • Hi

    Also, if you have CutePDF Writer installed, get rid of it! Uninstalled it from one of my clients laptops, restarted and it solved the problem. I could reinstalled the printer and remove old stubs that was stuck there for some time.

    Monday, January 14, 2013 10:28 AM
  • work for me this post...

    modify permission to allow edit HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

    restart spooler and set the default printer.

    • Proposed as answer by rimon ali Thursday, January 24, 2013 7:03 AM
    • Unproposed as answer by rimon ali Thursday, January 24, 2013 7:03 AM
    • Proposed as answer by rimon ali Thursday, January 24, 2013 7:03 AM
    • Unproposed as answer by rimon ali Thursday, January 24, 2013 7:03 AM
    Thursday, January 24, 2013 7:01 AM
  • work for me this post...

    modify permission to allow edit HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

    restart spooler and set the default printer.

    I tried all of the above - specifically - I just went into regedit.  HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

    Right Mouse click on - Windows Folder (under regedit above) - Click Permissions - Highlight my user name (I have admin priv) - set full control - restart print spooler

    Same errror - error 0x0000709

    SUCKS!

    Wednesday, February 06, 2013 12:57 PM
  • The Problem for me was the result of having a x32 bit machine trying to host a printer. Had to add additional drivers so x64 bit could install driver.

    had to add x64 print driver to printer, then install from client side with the same driver and select the remote printer

    Tuesday, March 26, 2013 4:28 PM
  • Thanks Muckman,

    It worked!!!


    Thanks & Regards, Vishal

    Thursday, March 28, 2013 6:43 AM
  • here is the solution for your problem is written in Spanish but has the solution with step by step pictures : http://adf.ly/MXAec



    Monday, April 15, 2013 11:14 AM
  • Thank you very much Rayden ....

    Regards,

    Vishal


    Thanks & Regards, Vishal

    Thursday, September 12, 2013 4:33 AM
  • what particular entries should I rename from the registry.What values?

    Regards

    Antonio Jr

    Wednesday, November 27, 2013 6:18 AM
  • thanks ...it worked. Initially I had problem renaming it but then it was ok once I changed the permission settings by allowing the user full control. I had problem finding how to change the permission settings which I found under registery editor>edit>permissions..thanks once again
    Saturday, January 04, 2014 2:27 PM
  • Thanks. I simply renamed the host computer name and it worked
    Monday, January 27, 2014 8:47 AM
  • I've solved this issue by using following method on windows7 ultimate 32bit :

    Under registry:

    HKEY_CURRENT_USER\Printers\Settings\Wizard\Locate Type . change the value from (1) to (2)

    HKEY_CURRENT_USER\Printers\Settings\Wizard\Set as default. change the value from (1) to (2)

    reboot the pc and enjoy....

    Thanks.



    Saturday, April 26, 2014 11:48 AM
  • You're getting this error due to your permissions not being set correctly in your registry. Windows isn't allowed to alter the default printer setting hence the error.

    Follow the final instruction at this link to adjust your permissions and then you should be able to set as default:

    http://pcsolutions-alternative.blogspot.com.au/2014/02/unable-to-set-default-printer-lets.html

    Thursday, May 29, 2014 3:59 AM
  • seems like everyone is in different scenarios and getting the same error. For me I am in a domain environment setup on DHCP. Before this our machines were on static IP's. The machine acting as the print server was still on a static IP. I switched it to DHCP and readded to domain. It fixed my issue..just wanted to share..
    Thursday, November 06, 2014 2:58 PM
  • Finally I got it.

    Please follow:

    Right click on the Print Spooler service in services.msc and click on Properties

    select the dependencies tab,

    There is a service that is called Remote Procedure Call (RPC), make sure this service is running.

    The above worked in my case :D

    Wednesday, February 25, 2015 1:15 PM
  • Check your System Name if it it more than 15 letters then problem will be still same

    like         AIB-SSHRIVASTAVA                 (it will create problem/issue    =  16 letters))

    while      AIB-SSHRIVASTAV         (will not create problem   = 15 letters) 

    so check it. I have resolved my problem through this.

    Thursday, April 16, 2015 9:21 AM
  • If this is a network printer, unshare the printer, then share it again.  

    On the print server...  Print Management > right click the printer > Properties > Sharing > uncheck "Share this printer" > click OK.  Repeat the steps, except check "Share this printer".   That worked for me.    

    Friday, August 05, 2016 6:36 PM
  • If this is a network printer, unshare the printer, then share it again.  

    On the print server...  Print Management > right click the printer > Properties > Sharing > uncheck "Share this printer" > click OK.  Repeat the steps, except check "Share this printer".   That worked for me.    

    Thanks! that worked for me
    Wednesday, September 07, 2016 3:01 AM
  • Watch this video

    https://youtu.be/5KwDNgkNDtk

    Monday, March 27, 2017 7:50 AM
  • Watch this video

    https://youtu.be/5KwDNgkNDtk

    Monday, March 27, 2017 7:50 AM
  • Watch this video

    https://youtu.be/5KwDNgkNDtk

    Monday, March 27, 2017 7:50 AM
  • After trying literally every solution on the internet, THIS ended up being the solution for me.  Thank you, Eman Shams!
    • Edited by DevEagleKJD Friday, November 17, 2017 7:12 PM
    Friday, November 17, 2017 7:11 PM