none
Remote Desktop Connection doesn't accept connections after installing Security Update (KB2667402)

    Question

  • 64bit Windows 7 Enterprise running on a Intel Pentium chip.

    I keep losing my Remote desktop ability.

    Everytime the security update installs, I get an error that I can't connect.  I uninstall update and it works until overnight, at which point Windows update politely re-installs it.

    I checked on the site for the update
    http://support.microsoft.com/?kbid=2667402

    I have the following file versions as suggested by the articles

    Rdpcorekmts.dll 6.1.7601.17828 149,504 26-Apr-2012 05:41 x64
    Rdpwsx.dll 6.1.7601.17828 77,312 26-Apr-2012 05:41 x64
    Rdrmemptylst.exe 6.1.7601.17828 9,216 26-Apr-2012 05:34 x64

    I had to search for them, they are installed in C:\Windows\winsxs\amd64_microsoft-windows-t..instationextensions_31bf3856ad364e35_6.1.7601.17828_none_f83075d781b149cb

    I don't have a custom RDP listener, removing the registry keys suggested by the article seemed to have no effect.(I made a backup first)

    The only thing that seems to do anything is uninstalling this Security Update (which then re-installs overnight)

    Any help or ideas are greatly appreciated.

    Thanks.

    Tuesday, June 19, 2012 11:38 AM

All replies

  • 1. Interesting is that Microsoft has reissued update:

    On June 12, 2012, security update 2667402 was rereleased to address this issue. Customers who are running Windows 7 or Windows Server 2008 R2 should install the reoffered update. This includes those who already successfully installed the update that was originally offered on March 13, 2012.

    2. I would address this problem to Microsoft support

    3. Before the problem is resolved, hide this update.

    Regards

    Milos

    Tuesday, June 19, 2012 4:32 PM
  • Hi Milos,

    D'oh!  I should have remembered hiding the update.

    1.  The re-issue is what is causing the pain.  It is odd that it was re-issued, probably mucked up some other configuration.

    2.  They wanted to charge a credit card to open a support incident.  Not really big into doing that, so was hoping that they sometimes watch the boards...  if I do get an answer then hopefully it helps someone else out.

    3.  Doing it right after this is posted!

    Thanks for the reminder.

    Tuesday, June 19, 2012 7:27 PM
  • Hi,

    Microsoft rereleased MS12-020 on Tuesday to reoffer security update KB2667402 for all editions of Windows 7 and Windows Server 2008 R2. The new offering of this update addresses an issue with the update originally offered on March 13, 2012, where the update is installed on Windows 7 or Windows Server 2008 R2 and then the operating system is subsequently updated to Service Pack 1.

    This scenario results in the incorrect binary version of rdpcorekmts.dll (6.1.7600.16952) being installed instead of the correct version (6.1.7601.17514).  Systems running supported editions of Windows 7 and Windows Server 2008 R2 will automatically be offered the new version of this update. Customers using these operating systems, including those who have already successfully installed the update originally offered on March 13, 2012, should install the reoffered update.


    Niki Han

    TechNet Community Support

    Thursday, June 21, 2012 7:49 AM
    Moderator
  • Hi Niki,

    I did get the update on the re-issue.  After installing the update I could no longer remote in.  I am using Win 7 with SP1 installed on a 64-bit machine.

    According to MS12-020 I should have the 6.1.7601.17828 which is what I have.

    Oddly enough, it is still the version I am left on after removing the update and hiding it (at which point the Remote Desktop allows connections).

    I am also experiencing the same situation on a Windows2008 server.  We don't normally Remote into it, but we had a power outage and I needed to this morning... 

    Thursday, June 21, 2012 12:57 PM
  • I have the same issues - are Microsoft going to fix this or if you call them do they have an answer??
    Thursday, June 28, 2012 8:36 AM
  • I don't plan on calling...  Potentially the cost of the OS to tell them there's a problem with a patch.  I hope they read the message boards. :^)

    I suggest following Milos advice and hiding that update.

    The rub on this is that my co-worker has nearly the identical PC.  No issues...

    So it's sporadic as to what it affects?  I think our NIC's are different manufacturers, so it may have something to do with that as well.

    Thursday, June 28, 2012 12:35 PM
  • So hide the update and uninstall the patch (ver 1 or ver 2) and that should fix it??
    Thursday, June 28, 2012 6:58 PM
  • Yeah, I uninstalled the security update 2667402 then rebooted. 

    Tested the RDC was working and then hid that update.  No problems since.

    Thursday, June 28, 2012 9:21 PM
  • All,

    I have the same issue. My problem though is that if I remove the update from June, I can get the RDP Listening again but straight after logon, it crashes so I'm not much further forward.

    Anyone found any other solutions on this?

    Regards

    Chris

    Wednesday, July 4, 2012 8:09 PM
  • Hi,

    Please uninstall the current update from update history. Then install it from the following link manually.
    http://www.microsoft.com/en-us/download/details.aspx?id=29145

    If the issue persists, please delete the following registry for a test. Before deleting, please back up.

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp


    Niki Han

    TechNet Community Support

    Thursday, July 5, 2012 6:25 AM
    Moderator
  • Hi,

    Thanks for the response. I've already tried this and it didn't work. I have rasied a ticket with the Microsoft Helpdesk this morning who have advised they are looking into this on Windows 2008 R2 SP1 as well as Windows 7 SP1. I'll post to the group once I have some further feedback on this

    Regards

    Chris

    Thursday, July 5, 2012 2:11 PM
  • Hi,

    I already have it uninstalled, and I had tried the registry key earlier.

    But, this does say V2, so I'll give it a shot.  Also, the 64bit version is here

    http://www.microsoft.com/en-us/download/details.aspx?id=29138

    Your link is 32bit.

    I'll post back later with the results.

    Thursday, July 5, 2012 3:26 PM
  • No luck.

    I installed the update, reboot, tried a RDC session.  Get same error.

    Removed registry key, reboot, tried RDC session.  Same.

    Restored registry, uninstalled update, reboot.  Tried RDC session, works.

    Thursday, July 5, 2012 3:55 PM
  • This is still a problem for me with a single PC at the office.  This has been a problem for nearly 9 months now, Win7Pro x64, WSUS deployed updates.  I have tried:

    Uninstalling KB2667402 & KB2621440, then reinstalling the latest releases, FAIL;
    Uninstalling both, reinstalling 1 (both ways), FAIL;
    Interestingly enough, one go around with reinstalling ...7402 caused that rdpcorekmts.dll file to disappear from System32 so, FAIL;
    System Restore, FAIL;
    Uninstalled both aforementioned KB articles, RDP Port is open, but TS crashes at the point of login for WinXP and Win7 machines.  Ironically, my 'Jump' application on my smartphone can connect as long as both KB installs are gone.  So, still, FAIL;

    Will Try:
    Uninstall/Reinstalling with x64 stand alone installer version of the 7402 KB article.


    • Edited by JimmyITCS Monday, September 10, 2012 4:42 PM
    Monday, September 10, 2012 4:41 PM
  • Hi JimmyITCS,

    I haven't had any luck with allowing the hotfix to remain installed. 

    Uninstall and hide the 7402 update.  Don't re-install it.

    It's the ONLY thing that has worked for me and trust me, I use this a lot. 3 months since it started and no problems after uninstallation. 

    Odd though that it's only on my computer and not any of the other 3 Win7 64bit machines here...


    • Edited by JoeMathis Monday, September 10, 2012 5:24 PM typo
    Monday, September 10, 2012 5:24 PM
  • Hi JimmyITCS,

    I haven't had any luck with allowing the hotfix to remain installed. 

    Uninstall and hide the 7402 update.  Don't re-install it.

    It's the ONLY thing that has worked for me and trust me, I use this a lot. 3 months since it started and no problems after uninstallation. 

    Odd though that it's only on my computer and not any of the other 3 Win7 64bit machines here...


    Oh yeah, I can't get it running properly.  In fact, I have something to add.  After uninstalling these 2 hotfixes, port 3389 does open up and accept connections, however the TS service will crash upon RDP login, disconnecting the user and never logging them on.  HOWEVER, if the user is already logged into the PC, RDP will connect into that user's profile without issue.  I've looked at that hidden service, Remote Desktop Services Security Filter Driver, and that is also affected when TS crashes.

    I have 5 servers (Server 2008R2) and 30 client PCs (most are Win7 Pro SP1 x64, a couple of Win XP SP3 x86) and only one has this issue.  Even an identically configured machine (identical with hardware, not installed programs) is running fine.

    WSUS is the method of update distribution with updates being pushed every 2 weeks and all clients are updated within that 2 update blocks (up to 4 weeks behind, rare, but happens).

    I've also noticed that rdpcorekmts.dll is stripped from System32 once update 7402 is reapplied.  On working computers, rdpcorekmts.dll remains in System32 and also in the corresponding AMD64 folders.  Why is rdpcorekmts.dll being stripped from the System32 I wonder....

    It certainly is starting to look like conflicting file revisions, something got murky with these hotfixes.  I bet order of install matters in this case.  Maybe if I install 7402 first and then 1440....ah well, let's see if this is still being monitored by MS.

    Monday, September 10, 2012 8:32 PM