none
Printing Backwards After SP3 Installed

    Question

  •  

    I just installed XP SP3 on my HP tablet. Now when I print to my HP printer, everything prints backwards,. The printed page is a mirror image of the on-screen image. I should note that the installation failed the first time. I had to end the process, reboot and let it all clean-up. Then I ran the installation program again without problems (or so I thought). Any ideas how I can fix this or where to look?

    Tuesday, June 10, 2008 10:05 PM

Answers

  • I have resovled the problem. I have an HP OfficeJet Pro 7780 printer. I contacted HP at the same time I posted this issue here. They told me about a setting that I need to change. It must have been altered somehow when I installed SP3. It works fine now. Here are the steps they advised (which resolved the problem).

     

    * Open HP Solution Center.
    * Click on Settings.
    * Click on Print Settings.
    * Click on Advanced tab.
    * In the printer features select the mirror image off.
    * Click OK.

     

    Thursday, June 12, 2008 7:31 PM

All replies

  • Which is the HP printer driver you've installed?

    Wednesday, June 11, 2008 7:09 AM
  • I'm not completely sure how to tell which driver is installed. I opened the printer list and looked at the properties. I found the driver settings on the "about" tab. It listed this driver first... HPWL7703.gpd  There were a couple more GPD files lower on the list. Is this what you are looking for?

    Wednesday, June 11, 2008 5:39 PM
  • Can you please answer following questions?

     

    What is the model name of the HP Printer you installed? (You can look in Printer Properties for this)

    Was this printer installed on your machine before XP SP3 installation? or Did you install it over XP SP3?

    Is this printing backward problem seen consistently or is it only applicable to some specific printing scenario? (say only for a particular application)

     

    By any chance do you remember the error encountered during first installation?

    Thursday, June 12, 2008 11:58 AM
  • I have resovled the problem. I have an HP OfficeJet Pro 7780 printer. I contacted HP at the same time I posted this issue here. They told me about a setting that I need to change. It must have been altered somehow when I installed SP3. It works fine now. Here are the steps they advised (which resolved the problem).

     

    * Open HP Solution Center.
    * Click on Settings.
    * Click on Print Settings.
    * Click on Advanced tab.
    * In the printer features select the mirror image off.
    * Click OK.

     

    Thursday, June 12, 2008 7:31 PM
  • That was it!  I had the same problem this morning after installing the update yesterday.

     

    Thank you.

     

    Wednesday, June 25, 2008 2:44 PM
  • I installed XP SP3 yesterday, and now my HP OfficeJet Pro K5400 prints mirror images when I select "Duplex Printing"  Even if I unselect duplex printing, it continues printing in mirror image until I close the app (Word).  But, when I open Word, it prints fine until I select the duplex printing option.  I followed your instructions, and the "mirror image" was already "off".  Suggestions?

     

    I have an update to this.  When I select "duplex printing" then go to the Advanced tab, the "mirror image" option is tripped to the "on" position. If I keep it on duplex printing, then take the extra step to shut off the mirror image afterward, it works fine.  BUT, it sounds like SP3 introduced a bug that triggers the mirror imaging to turn on after choosing duplex printing.

    Saturday, August 23, 2008 2:45 AM
  • I have an HP Officejet Pro L7780 and since installing XP SP3 I find duplex printing produces mirror images.  Yes, I can go to the Advanced tab and set "mirror image" to "off", and that works fine for that one print.  However, every time I select duplex printing it resets the "mirror image" to "on".  I can correct it each time, but it is very irritating, and I hope a 'patch' will be released a.s.a.p. to overcome this problem.

    Saturday, September 06, 2008 3:51 PM
  •  tonyh_100 wrote:

    I have an HP Officejet Pro L7780 and since installing XP SP3 I find duplex printing produces mirror images.  Yes, I can go to the Advanced tab and set "mirror image" to "off", and that works fine for that one print.  However, every time I select duplex printing it resets the "mirror image" to "on".  I can correct it each time, but it is very irritating, and I hope a 'patch' will be released a.s.a.p. to overcome this problem.



    Same issue here. Installed SP3 over the weekend.  HP Officejet Pro L7780 previously installed.  All printjobs are now mirrored.
    Changing the "mirror image" setting to "off" only creates a new "Customed Settings" on the Printing Shortcuts tab.  As soon as you try to use one of the Default presets (which cannot be deleted and cannot be edited and cannot be renamed), then you are back to mirrored printing.

    Chatting with HP Technical Support for an hour and I was left with "Reinstall your HP Software".  Meh.. I am not going to do that till I get back from my 2 week business trip.

    Another option that I thought of is to create "Customized" versions of all of the standard printing shortcuts.  At least that way when I won't have to mess with the stupid mirror thing and reinstalling software and resetting up my secure wireless connection and resetting up my shared printing ports and reconfiguring my printing preferences and and and and and you get the picture. 

    Also one last thought was that the defaults are saved in the registry under: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Printers\HP Officejet Pro L7700 Series\HPPresetRoot\PresetPoolData
    Unfortunately the data is in Binary... but perhaps they could be removed after creating customizations?? I dunno, just a thought.

    Tuesday, September 09, 2008 9:10 PM
  • This is interesting as I just had a client call with this problem and looking at the install logs they just upgraded to SP3 as well
    the strange part is that it is only doing on one account that noted and not other person main account but I still have not checked the prime account for that system(they have 3 accounts on that system). this was a an new HP office K series printer I think as well.(turn out to have been an L series HP office printer)

    I am here a lot from people that are using HP printer in both XP and Vista having these kind of issues did some at HP say the wrong thing or what? why is HP getting the hit in print errors?
    I am still asking my client to hols of installing SP3 till i can get all info on errors like this to make sure we can keep all running after install. I have been switching over to Brother printers so I will be looking at if there will errors with those printer my self or has anyone made list of printer having problems with SP3 yet?

    thank all for the info I know my client will be happy..

    GC

    followup:
    Now it did effect the admin user account and the second account but not the third account on this system.
    the only difference  is that the last account for that user is it was re-built account.
    they had a corruption that we I had to more files off kill the account and make new one with he same name and re-install the files  but this was done last year before the new printer and before SP3 so I don't think that has anything to do with it but that is the only know is different  also the printer that was on that system before this new one was an HP office 6110.

    I have feeling this going to make for some more calls this week from other clients.

    GC

    Tuesday, September 09, 2008 10:23 PM
  • You are great.  I had the same problem.  Thanks.

    Monday, September 15, 2008 1:24 AM
  •  

    I had the same problem, I thought I was going crazy. Thank God it's fixed now.
    Friday, September 19, 2008 3:28 PM
  • Thank You!!  It Works!

     

     

    Thursday, October 16, 2008 2:21 PM
  •  

    Friday, November 21, 2008 12:14 AM
  • Thank You , that was too easy. It worked like a charm. I'm embarrassed I didn't look there. I forgot the Solution Center existed.
    Here is a free cleaner for you to enjoy. It's great I have used it for years.  Have fun.
    http://www.stevengould.org/index.php?option=com_content&task=view&id=29&Itemid=223

    Monday, April 20, 2009 3:26 PM
  • Thanks you rock...Karen
    Thursday, September 03, 2009 1:13 AM
  • Thank you for this help.  I followed your description and everything is printing like it is suppose to again.
    Tuesday, December 15, 2009 3:05 AM