Outlook Data File Access Denied


  • I am running fully patched Win 7 RTM & Outlook 2007.  When I tried to attach my outlook data file of archived posts I get: File access is denied.  You do not have permission required to access the file: <archive file name on Windows 2003 R2 server>.pst.  I looked at the permissions of the file and it said I had Modify etc, so I changed it to Full Control and still get the access denied error.  The pst file is on a Windows 2003 R2 server, when I copied it to the C: drive, it connected just fine.

    Does anyone know how I can connect to this file while it's on the network?
    • Edited by PaulNations Monday, August 17, 2009 1:46 PM
    Friday, August 14, 2009 7:07 PM


All replies

  • Can you tell the full path where are you placing PST files. 
    In Windows 7 there is a specific path for PST files and this is per user. Navigate to following path and copy your PST file to this location :

    C:\Users\<your user name>\AppData\Local\Microsoft\Outlook\

    Note : AppData is hidden folder.

    I hope this will help you to cofigure your outlook with archieves posts.

    Monday, August 17, 2009 7:42 AM
  • The problem is that I don't want the pst file on my local hard drive.  I want it stored on the network share that is backed up nightly.  This is the standard location for our entire operation.  This problem must be solved before we can go further in Win 7 deployment.
    Monday, August 17, 2009 1:45 PM
  • Hi,


    Thank you for your posts.


    May I know if you can access the share folder which contains the PST file you need? If it is possible, you can also copy the file to local computer and see if you can open it then.


    At this time, let’s also check the security settings of the share folder and the PST file:


    1.    Right-click on the file (folder) and select Properties.

    2.    Go to “Security” Tab and ensure the account Everyone is present and have been assigned “Full control” permission.


    3.    Continue clicking OK to apply the settings to the file (folder).


    Hope this helps.Thanks.

    Nicholas Li - MSFT
    Tuesday, August 18, 2009 10:59 AM
  • Yes, when I copy the file to my local hard drive I can open it from Outlook 2007 without problem.

    Everyone is not in the security profile, and I'm not inclined to give 'Everyone' access to this file.  However, my user name and Administrator both have Full Access to the file and the entire share.  It's a personal share, each person in the organization has a personal share with only themselves and Administrator having access, this is the location of our Outlook archive files.  It works fine like this in Windows XP, it's only when I switched over to Win 7 for testing that the problem began.
    Thursday, August 20, 2009 1:21 PM
  • Thursday, August 20, 2009 7:40 PM
  • So, XP was allowing something that wasn't supported?
    Friday, August 21, 2009 4:19 PM
  • I had the same issue, but my folder was on an external drive. When i moved it to the "C" drive it opened.  All i did was add my domain user to the security tab and gave it full access.   My domain user was in an admin group with full access but for some reason that didnt work.
    Friday, November 13, 2009 7:02 PM
  • I am having this same problem.  Here's my situation:  This computer was running Windows 2000 with Office 2003.  This is stand-alone, not on a domain.  I put a new HD in as C: and moved the old HD to D:.  I installed Windows 7 on the new C: drive and installed Office 2007.  The user is in the Administrators local group.

    I tried to copy the PST file to the C: drive root and also the C:\Users\Pansy\AppData\Local\Microsoft\Outlook\ folder and gave the current user explicit Full Control rights to the old PST file.  I also made the user the owner of the PST file.  When I try to import info from the file, I get the Access Denied message.  I've also looked at the Effective Permissions and the user has Full Control.  I created a backup file through Outlook and compared the permissions and location and everything is exactly the same.  Outlook will open the 2007 backup file but will NOT open the Outlook 2003 PST file.

    Any other ideas?
    Monday, December 07, 2009 9:07 PM
  • OK, one last stab - Now that I can see all the folders (thanks MS for HIDING everything!), I put the PST file back in it's original folder on the (now) D: drive and tried to import from there.  As if by magic, it worked.  Go figure.  I wonder why M$ thinks they have to lock everything down to the point of making people non-productive? 
    Monday, December 07, 2009 9:14 PM
  • Dimondwoof, Did you find a solution for your problem?  If so what did you do?  I am having the same problem.  I have a .pst file from an older version of outlook and upgraded to win 7 and outlook 2007.  When i go to import the .pst file i get the "file access denied. You do not have the permissions to access the file c:\... "

    I went in to properties and gave full access to all and i still get the access denied.

    I originally had it on an external HD. Then i copied the file to the root folder mentioned above where outlook saves .pst files and still does not work.

    Anyone, Please help.



    Tuesday, June 22, 2010 4:57 AM
  • Yes, I did.  What you need to do is close Outlook, go into Control Panel/Mail, click on Email accounts, under Directory, choose "View or change existing directories or address books".  Click the button to remove the address book, then Add.  Choose Additional Address Books, Next, then choose Outlook Address Book, Next and Finish.  Close that and re-open Outlook.  You should be good to go.  Worked like a dream for me.
    Thursday, June 24, 2010 3:35 AM
  • Woops, sorry.  That was a solution to another Outlook issues I was having.  If you get to a point where you can get to the PST file, but the contacts don't show up, that is how you fix it.  :)

    As to the Access Denied problem, and this is why I ran into the Contacts issue - instead of importing things from the old PST file, I just closed Outlook, renamed the newly created PST file, put the old 2003 PST file in place and opened Outlook 2007.  It grabbed the old 2003 PST file and did all the diagnostic it needed and started right up.  But, then I would open the Contacts folder, it shows all the contacts.  When I open a message and click the TO button, it says there are no contacts.  The other post tells you how to fix that.


    Hope this helps!

    Thursday, June 24, 2010 3:51 AM
  • And help me! Thank you!
    Wednesday, August 11, 2010 2:03 PM
  • Are you saying that this thread helped you or that you still need help?  If you still need help, where are you stuck in the process?
    Wednesday, August 11, 2010 2:31 PM
  • Just trying to help and see if youse still have issues...


    Replication of case:

    a PST was copied to your windows 7 client, you try to attach the PST to  your outlook.. you get access denied.


    Solution if the case above is right (which worked for me)

    Get outlook to run under administrator mode, try to attach the PST


    • Proposed as answer by CK_Chua Thursday, January 06, 2011 3:47 AM
    Tuesday, August 17, 2010 8:24 AM
  • For Windows7, you would need to run Microsoft Outlook 2007 as asministrator in order to proceed with the data file adding.

    So, Just make sure this item is checked.

    Microsoft outlook 2007 icon -> Properties -> Compatibility tab -> Privilege Level -> Run as administrator


    Once you completed acknowledge Microsoft Outlook to run as administrator, you can add/ remove any data file that you want.

    • Proposed as answer by Machadod Thursday, December 15, 2011 3:54 PM
    Thursday, January 06, 2011 3:51 AM
  • it is incredible how bad microsoft  is these days.  their products are horribly broken out-of the box, and multiple googles are required for any minor procedure.   seriously, why do we stand for such bad products?
    Monday, January 10, 2011 7:53 PM

    Changing the way Outlook needs to run to "Run as Administrator" in the compatibility tab was the solution.

    Thank you very much, is was driving me up the wall.


    Thursday, February 24, 2011 10:20 AM
  • resolve this issue, copy the .pst file from the CD-ROM and save it to a hard disk or to another type of media. Then,  remove the Read Only file property. To do this, right-click the file, click Properties,  click to clear the Read Only check box, and then click OK. The Import process should now finish successfully
    • Proposed as answer by James.Burgess Tuesday, September 18, 2012 6:08 AM
    Thursday, June 07, 2012 7:15 AM
  • For Windows7, you would need to run Microsoft Outlook 2007 as asministrator in order to proceed with the data file adding.

    So, Just make sure this item is checked.

    Microsoft outlook 2007 icon -> Properties -> Compatibility tab -> Privilege Level -> Run as administrator


    Once you completed acknowledge Microsoft Outlook to run as administrator, you can add/ remove any data file that you want.

    This worked for me! Thank you! I have never in all my days ever had to run Outlook as Admin in order to add Data Files. Was this some sort of recent SP update or security change? This only has happened on one machine in the entire domain and I would really like to understand more as to why all of a sudden this happened. 



    Wednesday, April 17, 2013 3:11 PM
  • I was facing same problem, then I noticed .pst file is ‘Read only’ marked. Removed this – restarted Outlook and then I could access my .pst file.

    Friday, February 14, 2014 11:43 AM
  • Unticking the Read Only check box worked for me, my .ost & .pst files on the 2nd hard drive of my PC.
    Monday, March 10, 2014 7:34 AM
  • Thank you for the suggestion. It saved me a lot of trouble.
    Friday, April 25, 2014 12:43 AM
  • I had the similar issue when opening a old outlook pst.

    I did the same. Go to the Properties of the file and uncheck the Read Only check box and click OK.

    Bingo!!!!!!!!It worked for me.

    Thanks James.

    Wednesday, June 04, 2014 7:24 AM
  • Run as Administrator worked for me
    Tuesday, June 10, 2014 2:18 AM